2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
So ever since I got my car in November 2014 I have been one of the many who suffer from the active driving display (ADD) that randomly will not open. Several months ago I had a rear shock replaced under warranty and told them about the ADD issue. Told them that this is a common issue and they reply that they have never seen one or heard of this issue. Since they cannot replicate it they cannot fix it. Asked them if while it happens and I bring it in and show them will that be good enough. They say yes. So today I had to go to the dealership (Mazda, Toyota, Nissan, Dodge Jeep, Hyundai) today to get my daughters Jeep a new gas cap. Started the car and the ADD didn't raise. So finally it happens when I can do something about it. Drove there and showed them. Long story short there is a bulletin on it and they are ordering a new one for me. So hopefully this will end the issue.

To anyone who has had there ADD replaced has the issue been fixed or does it still happen? This is one of those things that just doesn't sit right with me. And along with the shit infotainment system (slower than molasses) it makes me not want to buy another Mazda. Love the car but these two things are a major let down

Don
 

·
Registered
Joined
·
637 Posts
So ever since I got my car in November 2014 I have been one of the many who suffer from the active driving display (ADD) that randomly will not open. Several months ago I had a rear shock replaced under warranty and told them about the ADD issue. Told them that this is a common issue and they reply that they have never seen one or heard of this issue. Since they cannot replicate it they cannot fix it. Asked them if while it happens and I bring it in and show them will that be good enough. They say yes. So today I had to go to the dealership (Mazda, Toyota, Nissan, Dodge Jeep, Hyundai) today to get my daughters Jeep a new gas cap. Started the car and the ADD didn't raise. So finally it happens when I can do something about it. Drove there and showed them. Long story short there is a bulletin on it and they are ordering a new one for me. So hopefully this will end the issue.

To anyone who has had there ADD replaced has the issue been fixed or does it still happen? This is one of those things that just doesn't sit right with me. And along with the shit infotainment system (slower than molasses) it makes me not want to buy another Mazda. Love the car but these two things are a major let down

Don
The 2017 model ADD with the colour ADD is good and can be improved by my fix here http://mazda3revolution.com/forums/2014-2017-mazda-3-skyactiv-discussion/201746-tip-improve-active-driving-display-contrast.html

I don't have any problems with the infotainment system either. My main complaint is the excessive road tyre noise from the Dunlop Sport Maxx TT tyres on 18" wheels. Mazda engineers have dropped the ball on noise suppression.
 

·
Registered
Joined
·
1,998 Posts
I've had my HUD not come up many times. Dealer always say they can't replicate it and of course it never happens when I'm there. One morning when I started the car the HUD did not come up so I went straight to the dealer. They noted it and scheduled for an appointment to get it checked in a week. Got busy never went in. Long story short, I finally brought the car in last August to get it replaced under extended warranty. Ever since the day I got it replaced till the day I traded the car in, I never had an issue and it worked perfectly fine since.
 

·
Registered
Joined
·
6 Posts
Could you get the bulletin number? My dealer refuses to replace it and I have even shown up with the display down. "We have nobody available to look at it. Make an appointment or leave the car".
 

·
Registered
Joined
·
170 Posts
Discussion Starter #5
Could you get the bulletin number? My dealer refuses to replace it and I have even shown up with the display down. "We have nobody available to look at it. Make an appointment or leave the car".
I cannot help with the bulletin number. But my service writer tried doing the same thing to me. Said make an appointment. I said why make an appointment? So I can show up and they can tell me they can't replicate the issue? So I told him I want it in their computer that they eye witnessed it. He got his manager and the manager handled it the rest of the way.

Don
 

·
Registered
Joined
·
170 Posts
Discussion Starter #6
I've had my HUD not come up many times. Dealer always say they can't replicate it and of course it never happens when I'm there. One morning when I started the car the HUD did not come up so I went straight to the dealer. They noted it and scheduled for an appointment to get it checked in a week. Got busy never went in. Long story short, I finally brought the car in last August to get it replaced under extended warranty. Ever since the day I got it replaced till the day I traded the car in, I never had an issue and it worked perfectly fine since.
That is comforting to know. I hope I have the same results. Thanks

Don
 

·
Registered
Joined
·
170 Posts
Discussion Starter #7
I had the active driving display changed this morning. I will try and update this thread on its performance. If it acts normally like it should I will update every month or so. So hopefully this info will be of use to anyone else who has this issue

Don
 

·
Registered
Joined
·
170 Posts
Discussion Starter #8
I hope I don't jinx my good fortune. Been three weeks and no misfires from the ADD. Also had a software update done and no flash drive resets. Fingers and toes crossed that the good luck continues

Don
 

·
Registered
Joined
·
88 Posts
I hope I don't jinx my good fortune. Been three weeks and no misfires from the ADD. Also had a software update done and no flash drive resets. Fingers and toes crossed that the good luck continues



Don


Just brought my car in. The guy was telling me it not be covered under my extended warranty or some bullshit like that.

They reference any special codes in the paperwork they provided when hey repaired yours?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
88 Posts
Got a call back ,it’s not covered under the extended warranty. Since the car is low on the mileage, they are going to replace the part on good will and I pay for the labor.

Part cost $700. The labor will $190


Wtf is the point of an extended warranty. Complete garbage .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
170 Posts
Discussion Starter #11
Mine was replaced under the 3 year bumper to bumper warranty. Most extended warranties are for powertrain only. But I digress. To date no misfires. Almost 2 months trouble free. So I think the new ADD is a success. But time will tell

Don
 

·
Registered
Joined
·
88 Posts
Yea barely missed the 3 year, hardly drive the car to begin with. Expired this Feb and I only have 15k on the odometer. Didn’t help that they couldn’t replicate the problem the last time when it was under the warranty .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
170 Posts
Discussion Starter #13
I am 35 months in and have only about 16,500 miles. Commute to work is only 7 miles. I feel fortunate that mine got changed for free.

Don
 

·
Registered
Joined
·
2 Posts
Had the same problem in my 2014 S-Touring, every couple times I would start the car the ADD wouldn't pop up. However, probably a little over a year ago, I had issues with the car cranking slowly upon starting, and got the battery replaced. New battery of course solved the slow-cranking issue, but it also solved the issue with the ADD not popping open
 

·
Registered
Joined
·
170 Posts
Discussion Starter #16
Just about three months since having the new updated ADD installed. Not a single misfire. I am calling this one done (fingers crossed). My 3 year bumper to bumper just ran out 4 days ago. Now things are gonna cost me unless it is drivetrain related

Don
 

·
Registered
Joined
·
6 Posts
ADD wasn't popping up almost every other time. Got "battery malfunction" warning. Replaced battery over two month ago, since then not a single ADD misfire.

Check your battery before replacing ADD.
 

·
Registered
Joined
·
553 Posts
ADD wasn't popping up almost every other time. Got "battery malfunction" warning. Replaced battery over two month ago, since then not a single ADD misfire.

Check your battery before replacing ADD.
Yap! been discussed here on a couple of different threads. As I've mentioned previously...how cool is that to know when the HUD doesn't pop up it is likely sign you need to replace your battery soon instead of being surprised with a dead battery.
 

·
Registered
Joined
·
2 Posts
Hi
My AD display opens, but the display is blank. It opens and closes but nothing is displayed. ?? What can I do?
 
1 - 20 of 22 Posts
Top