2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey yall, a few days ago my trackion control came on and my engine light started flashing then lost a bunch of power and the engine started to shake. I replaced the spark plugs today but the problems is still there. Although it is better now the engine still shakes a bit and the engine light is solid. I can drive for a bit with noticeably lower engine performance with the engine and then after a few minutes I lose power and cant rev past 3000rpm, but when I turn it off and start it again the power is back.
If anyone has an idea what may the the problem help would me much appreciated

2014 mazda 3 2.0 skyactive
 

·
Super Moderator
Joined
·
5,678 Posts
Guessing on the internet with few actual facts won't help....neither will throwing parts at it randomly....Stop driving the car and take it to a competent mechanic. The flashing check engine light usually means something serious has happened. Driving it might make things worse. At best it might be a plugged cat, but it could be any number of things.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Hey yall thanks for the feedback. I went and bought a diagnostic tool. Got the code p0300 which is for engine misfiring, so I took out my spark plugs and gapped them properly, and now my car doesn't go into limp mode anymore. However I did notice that one of the the plugs were still brand new and havent been firing at all
 

·
Super Moderator
Joined
·
5,678 Posts
Check for spark on all cylinders, might be a bad coil....
In any event you are dumping raw gas from that cylinder through the cat. This can result in cat failure in fairly short order.
 
1 - 5 of 5 Posts
Top