2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
410 Posts
Discussion Starter #1
It happened 2 or 3 times but it's not a consistent behavior. Sometimes I press the driver switch full-down or full-up and it doesn't go AUTO.

I know how to enable it again which is keep the switch up for some seconds after the window is fully closed but eventually it looses the setting some days later. Can't find a pattern and all the other windows work fine in the meantime.

Did anyone else already experience the same or is it mine an isolated case?
 

·
Registered
Joined
·
333 Posts
Only times I've lost the auto function is when I disconnect car battery. After a day or 2, it began working properly once again.
 

·
Registered
Joined
·
410 Posts
Discussion Starter #8
This is not the case. The switch looses the auto function despite the car having the battery charged all time. In the end is also about low voltage arriving to the switch and making it loose the function.

It may happen today. You reprogram. Loose again 3 days later. You reprogram. Loose only 1 month later. And so on. Happens from time to time and it seems like we are not alone.
 

·
Registered
Joined
·
15 Posts
In my case it happened sometimes, but later it works well, without reprogramming it...
This has happened to me as well. The function has come back both automatically without programing and also when I program. I lose the function multiple times a week regardless.
 

·
Registered
Joined
·
39 Posts
This has happened to me as well. The function has come back both automatically without programing and also when I program. I lose the function multiple times a week regardless.
Yesterday they again dont work automatically. When I was driving. I only keep the window button up for 10 secs, not the regular reset process, and they work proper again... Strange...
 

·
Registered
Joined
·
35 Posts
It's possible that in some of these cases, that the power window has been operated a few times without being closed fully, the AUTO function is disabled if the power window is operated for 10 consecutive times without being fully closed (turning the ignition OFF and then ON does not reset the counting), doing that, causes small errors in the window position sensor to accumulate and may conflict with the jam-safe function, so the AUTO function in then disabled.

This is mentioned in the owners manual, (albeit slightly less detailed) under power windows:

Link to owners manual page

So in those cases it's normal.
 

·
Registered
Joined
·
24 Posts
I ha the opposite - I couldn't incrementally move the windows at all, I could ONLY fully open or shut them (irrespective of where I had thy window switch)

Seems to be working again but it's gremlin that annoyed me a lot.
 
1 - 16 of 16 Posts
Top