2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there,

I'm new and I am an idiot messing with options I really should not mess around with :frown2:

I am from the Netherlands an I drive a 3 months old 2016 CX-5 Skylease+.
Because I like cool gadgets, I installed the All In One hacks like enabling touchscreen while driving, speed restriction disabling and the nagscreen.
This was running great.
But not being satisfied yet, I wanted to upgrade the firmware.
Looking through this site on the right fw, I crossed a topic that you can also enable touchscreen through the JCI Test Mode.
Because I prefer basic settings more than tweak scripts, I tried this out, but I think I accidentally disabled the whole touchscreen (stupidly toggling around).
The screen stays black now..

I tried rebooting, disconnecting battery, locking and walking away for 10 minutes or so, trying a factory reset but I think I constantly miss the right option being blind now.
Is there a way to solve this?
Probably when I do a factory reset, but as the screen isn't functioning I am sort of blindly fooling around with the commander and cannot find the exact option. It's a CX-5 with dutch language without Headup display..

Help a newbiee please..!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Hi there, Too bad no one of you replied me.
Doesn't matter, because I managed to fix it myself :)

I recorded the exact steps from a display from a M3 Sedan with heads up display by phone.
Doing just that, I found out that I skipped the tabs too fast to get to the system settings tab.
In a M3, you do a factory reset like this.
Click on home.
turn the commander twice to the right.
Press the commander button
press the commander 7 times (CX-5 is 6 times) to the right but wait a 1 or 2 seconds between presses, pretend you actually see tabs switching.
Turn the commander 5 times to the right and press the commander button
Turn the commander 1 time to the right and press the button again
Now you hear a beep.. keep your eyes on the screen and YEAHHHzzz..!! Bootlogo is back.

I need to configure all settings again, but hey.. it's fixed..
 

·
Registered
Joined
·
1 Posts
Thank you very much Mike -- I too had the same issue and tried everything. Your steps worked & I'm so happy not to have to go to the dealership!!!
 
1 - 3 of 3 Posts
Top