2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi people. First time posting here

Have a 2010 MS3 with 160k km
Today It started behaving differently.
When it's cold, It would have rough idle at start for the first 20-30 seconds. It pulls fine. After it warms up, restarting idle is fine. There does not seem to be any loss of power.
Please see the video in link


No real modification or tune

Recently had fuel injector replaced.
Otherwise no recent issues.
Really appreciate all the useful information
Thank you
 

·
Registered
2013 Mazda 3 i Hatchback
Joined
·
170 Posts
I'm with Mike. Clean your throttle body and consider changing plugs. Throw some fuel injector cleaner in the gas, as a sticking/clogged injector can smooth out when up to temp.

Beyond that, it could be a bunch of things. It could be caused by a faulty intake air temp sensor or coolant temp sensor. How's your coolant level? A small leak into the intake/head can cause a rough cold idle, but clear up once hot (if that's the problem, it will get worse).

If you had an OBD scanner with live data capability, I'd want to look at misfire counters to see if it's on one cylinder or if it's random. I'd want to look at fuel trims while it's misfiring. I'd want to look at the reported intake air temp and coolant temp. See how useful a scanner can be? Best $150 you'll ever spend.
 

·
Registered
2013 Mazda 3 i Hatchback
Joined
·
170 Posts
I'm with Mike. Clean your throttle body and consider changing plugs. Throw some fuel injector cleaner in the gas, as a sticking/clogged injector can smooth out when up to temp.

Beyond that, it could be a bunch of things. It could be caused by a faulty intake air temp sensor or coolant temp sensor. How's your coolant level? A small leak into the intake/head can cause a rough cold idle, but clear up once hot (if that's the problem, it will get worse).

If you had an OBD scanner with live data capability, I'd want to look at misfire counters to see if it's on one cylinder or if it's random. I'd want to look at fuel trims while it's misfiring. I'd want to look at the reported intake air temp and coolant temp. See how useful a scanner can be? Best $150 you'll ever spend.
Oops, forgot to mention that it could be a failing coil on one of the plugs, or a plug/coil drowning in oil because of a failed seal around the plug tube/valve cover.
 

·
Registered
Joined
·
41 Posts
Hi people. First time posting here

Have a 2010 MS3 with 160k km
Today It started behaving differently.
When it's cold, It would have rough idle at start for the first 20-30 seconds. It pulls fine. After it warms up, restarting idle is fine. There does not seem to be any loss of power.
Please see the video in link


No real modification or tune

Recently had fuel injector replaced.
Otherwise no recent issues.
Really appreciate all the useful information
Thank you
. My car does that too and it's a newer model. Even when I bought it new it did that. I would start it and it would rough idle for 10-20 secs then level out normally. I think it's a Mazda thing to regulate the mileage properly. Nothing to worry about
 

·
Registered
Joined
·
41 Posts
Can anyone suggest a good OBDII reader for a 2006 Mazda3? (Economical purchase that works good)
I bought a regular ond2 reader from Amazon for around $10. It plugs into your obd2 reader and you download an app. It tells you your fault codes and let's you reset the check engine light.
 

·
2018 mazda owner
Joined
·
33 Posts
Can you give me the brand name and model number?
 

·
Registered
Joined
·
41 Posts
Afterwards go to google and type in torque pro APK. It is the full version that will let you delete the fault codes
 
1 - 11 of 11 Posts
Top