2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 9 of 9 Posts

·
Registered
Mazda 3 2014 GTS
Joined
·
9 Posts
Discussion Starter #1
Hi all, I just replaced a dead boot looping CMU in our Mazda 3 2014 GTS. All well except the nav now I’d not recognised, does not load at all, does NOT give ‘invalid SD card’ Notification either. I assume the new CMU is upsetting the relationship with the card (genuine Mazda original). Is there anything I can attempt to do to marry them? Thanks in advance,,,
 

·
Registered
Joined
·
1,292 Posts
Check if the USB ports work. Insert a USB FAT32-formatted with mp3s on it. Check if the usb stick is recognized by the MZD (shortly after plugin at the top row in the MZD pops a message up). If this is not happening, the USB hub (Nav-SD-Slot inside) might not be connected properly to the CMU. Disconnect and reconnect the connector(s) at the back of the CMU. That`s my assumption.
 

·
Om Shanti Shanti Shanti O
Joined
·
169 Posts
I also think that the matter is in the absence of a connection to the USB Hub
But if the case is not in the Hub - contact me. I try to help.
 

·
Registered
Mazda 3 2014 GTS
Joined
·
9 Posts
Discussion Starter #4
I also think that the matter is in the absence of a connection to the USB Hub
But if the case is not in the Hub - contact me. I try to help.
thanks! Yes, even though USB was getting power, the data connection had comeaway from the CMU, I must have not fully pushed it in when refitting it. I got the software update done and have ordered A CarPlay unit. Meantime my NAV has definitely disappeared, I’m assuming because the CMU doesn‘t correspond. Any way to make the new CMU talk to my original NAV card?
 

·
Registered
Mazda 3 2014 GTS
Joined
·
9 Posts
Discussion Starter #5
thanks, that was exactly the problem. Sorted now for the USB connection and software update ...Just need to try and get the NAV card to shake hands with the CMU...
 

·
Om Shanti Shanti Shanti O
Joined
·
169 Posts
Is the SD card now recognized by the system? What does it write when you insert it into the slot?
 

·
Registered
Mazda 3 2014 GTS
Joined
·
9 Posts
Discussion Starter #7
no, the NAV card produces no reaction from the system when inserted. I am assuming that the new CMU just appears alien to the card and they will not shake hands. I have just written to Mazda to see if they might be willing to send me a new card.
 

·
Om Shanti Shanti Shanti O
Joined
·
169 Posts
I changed CMU to another several times and Navigation continued to work.
Have you updated your card in Toolbox?
Try to insert any other SD card up to 32 Gb (fat32 !!!) The system should write on top "SD card inserted"
 

·
Registered
Mazda 3 2014 GTS
Joined
·
9 Posts
Discussion Starter #9
Put the card in Toolbox. Did nothing to it apart from checking the data on it. Put it back in the car and it works now. Dunno why..... Cosmic. :)
 
1 - 9 of 9 Posts
Top