2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 20 of 31 Posts

·
zoom freakin' zoom
Joined
·
613 Posts
Discussion Starter #1
As the title says has anyone experienced this and if so how did you resolve it?

...wife texted me this morning saying that while she was waiting at the bus stop with our son and the controls set to the defroster and the fan set on one, she heard a clicking sound. She turned the fan off and it went away. I haven't heard it myself yet but wanted to see if anyone else has heard the same.
 

·
cro-magnon man
Joined
·
510 Posts
You may have sucked up a leaf twig or something and the blower motor is hitting it. Is it at all fan speeds? Change the cabin air filter lately? I'd start at these possible problems.
 

·
MAAAAAD
Joined
·
2,140 Posts
I have the same issue.. gonna take mine to the dealer.. can't stand it haha i'm also thinking its a leaf or twig so might try checking the cabin filter before i take her in

edit-

so the clicking sound is bothering me a lot so.. I decided to find out how to replace the filter. Here is the DIY I found. Hopefully this resolves it. If not, off to the dealer I go. My car only has about 6700 miles on it :mellow 1: so hopefully its nothing major.

http://mazda3revolution.com/forums/2010-mazda-3-how-guides/2788-how-change-cabin-air-filter.html
 

·
zoom freakin' zoom
Joined
·
613 Posts
Discussion Starter #4
You may have sucked up a leaf twig or something and the blower motor is hitting it. Is it at all fan speeds? Change the cabin air filter lately? I'd start at these possible problems.
Thank you and I'll have to check that out. Not sure if it is at all speeds or not. She just heard it this morning and only used speed 1. Cabin filter is original but I'll give that a look too. Not expensive and easy to do.
 

·
zoom freakin' zoom
Joined
·
613 Posts
Discussion Starter #5
I have the same issue.. gonna take mine to the dealer.. can't stand it haha i'm also thinking its a leaf or twig so might try checking the cabin filter before i take her in

edit-

so the clicking sound is bothering me a lot so.. I decided to find out how to replace the filter. Here is the DIY I found. Hopefully this resolves it. If not, off to the dealer I go. My car only has about 6700 miles on it :mellow 1: so hopefully its nothing major.

http://mazda3revolution.com/forums/2010-mazda-3-how-guides/2788-how-change-cabin-air-filter.html
Be sure to post back up if replacing the cabin filter works or not and also how your visit at the dealer goes should you still need to go that route. Good luck!
 

·
So Far So Good
Joined
·
189 Posts
You may have sucked up a leaf twig or something and the blower motor is hitting it.
This is what happened to me once, check to see if there is any debris.
 

·
Registered
Joined
·
33 Posts
Happened to my 2010 s hatch.Dealer had to replace a part inside the dash for climate control.No problem since.
 

·
MAAAAAD
Joined
·
2,140 Posts
so I got around to checking the cabin filter. There was a good amount of stuff like leaves and what not in there. FYI, there are2 screws on the black piece that the air sensor or w/e attaches to. I was trying to pull it off then realized there were 2 screws on the bottom and a clip at the top.

After I cleaned it and put it back together, started the fan and the sound was still there but after I turned it to high it went away, guess whatever was making the sound got pushed out or w/e. If it happens again, I'd probably just take it to the dealer so they can deal with it.
 

·
Registered
Joined
·
293 Posts
Im bringing mine to the dealer 11/10, next Thursday to get it check out. I will let you guys know what the cause and result is.
 

·
Registered
Joined
·
293 Posts
They're working on it right now. Said that the actuator motor for the door that makes the air recirculate needs to be lubricated, and it's the cause of the clicking noise coming from the climate control vents. It has nothing to do with leaves or anything getting caught up in there. I got the car back, the clicking is still there but it's not as bad compared to before. I think the climate has something to do with it being dry outside and such.

Sounds like this should be a recall on all the 2010 Mazda 3.
 

·
Registered
Joined
·
2 Posts
They're working on it right now. Said that the actuator motor for the door that makes the air recirculate needs to be lubricated, and it's the cause of the clicking noise coming from the climate control vents. It has nothing to do with leaves or anything getting caught up in there. I got the car back, the clicking is still there but it's not as bad compared to before. I think the climate has something to do with it being dry outside and such.

Sounds like this should be a recall on all the 2010 Mazda 3.
They most likely won't do a recall because it's not an explicit safety/security issue. Usually those are the only things that get recalls. However (unrelated to this post), I have been experiencing a buzzing sound coming from one of the locks (rear passenger door). I've heard about this from a couple people, usually happening in bad weather. If enough people have problems with this, they might have a recall on it because its a security issue for the car.

Also, is anyone experiencing a loud A/C compressor noise when starting the A/C or defroster? It seems like whenever I leave the car sitting (overnight for example), and start the car in the morning (turning on the defroster in winter, or A/C in summer), i hear a loud "Clank" sound. Should the compressor be getting this much torque to make it "clank" like that? I called the dealer, and they said it's normal - but i just wanted to get the rest of the community's experience. Is this the original "clicking" sound that the OP's wife heard?
 

·
Registered
Joined
·
9 Posts
I have kind of the same issue. I get a clicking from the center-back dash area when I start my car, whether or not the heat is on. It lasts for 10 to 30 seconds and then stops. It sounds like when you go to start a car with a dead or dying battery. Loud. It returns only if you change the direction of the climate controls.

Do you think this is the same problem?
 

·
Registered
Joined
·
293 Posts
I have kind of the same issue. I get a clicking from the center-back dash area when I start my car, whether or not the heat is on. It lasts for 10 to 30 seconds and then stops. It sounds like when you go to start a car with a dead or dying battery. Loud. It returns only if you change the direction of the climate controls.

Do you think this is the same problem?
It's the same problem as mine. Im gonna take mine back into the dealer and have it replaced with a brand new one. The clicking won't go away.
 

·
Registered
Joined
·
293 Posts
They ordered a new part, there wasn't any in stock. Have to bring car in Friday at 10am to get fixed ,it should solve the problem.
 

·
Registered
Joined
·
293 Posts
I got it fixed, took about an hour. The service guys went through the glovebox to save ALOT of time. Was out of the dealer around 11am.

The cost with parts and labor was $138, all covered under warranty. If anybody on the forums experiences the clicking noise, get it covered under warranty ASAP.

No more clicking noise from fan = happy man!
 

·
Registered
Joined
·
43 Posts
Yea, mine started the other day... Sounds like a card shuffler in my dash. Next time I go to the dealer I will get them to fix it.

Update: It stopped! It must have been the extreme heat we had here in Toronto. Now that its cooler the clicking stopped.
 

·
Registered
Joined
·
10 Posts
This happened to me too. Right around last fall so I'd expect it to be something to do with leaves, twigs, etc
 

·
Registered
Joined
·
6 Posts
I was wondering if anyone that has had trouble with the clicking noise can tell me it is similar to what I'm experience. About 2 years ago during a hot day in the summer, I noticed the fan clicking. There's a lot of corn fields around where I was parked, so I figured it was just something jammed in there. It did once more a day later, and then no clicking noise at all from the fan.

Fast forward to about a week ago. It seems like anytime it's really damp, the fan starts making a clicking noise. Probably 4 or 5 times in the past 8 days. No matter what speed I turn the fan up to it doesn't go away. It makes less noise as I speed up and more when I'm not moving. It seems like it mainly happens after sitting overnight. It goes away every time I turn the fan off, which I think is bizarre. I have about a month and a half left on the warranty, so I'm debating on taking it in. I just don't want to take it in and then have them say it didn't make the noise for them, so there is nothing wrong.
 

·
Registered
Joined
·
97 Posts
I got it fixed, took about an hour. The service guys went through the glovebox to save ALOT of time. Was out of the dealer around 11am.

The cost with parts and labor was $138, all covered under warranty. If anybody on the forums experiences the clicking noise, get it covered under warranty ASAP.

No more clicking noise from fan = happy man!
I know its been a while, but do you happen to have the part number they replaced? Mine started doing it outside of warranty, so I'd like to try and replace it myself.
 
1 - 20 of 31 Posts
Top