2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Was leaving work today. I thought I heard the engine make a weird noise on startup. I shut the car off, but it ended up being something that fell in the place I work. Started the car up, everything was fine. When I put the car into reverse and was backing up, my infotainment screen displayed the message "Warning Guidance Charging System Malfunction. Stop vehicle immediately in a safe place." Message only displayed for maybe 5 to 10 seconds and then went away. I pulled into my parking space and shut the car off. I turned the car back on and everything seemed fine. I drove about 30 miles home from work and the message did not come back on. Car seemed to drive fine. Nothing felt unusual. No, lights displayed on my dashboard either. My car is a 2015 Mazda 3 Automatic with Skyactiv Engine. Weather was sunny. 83 Degrees and I was running my ac at the time.

Anybody have any idea what this could be? I'm going to monitor it this weekend. Luckily, I have an appointment for an oil change Monday at the dealership and I'm going to mention it to them.
 

·
Registered
Joined
·
29 Posts
This is the error mine displayed when the battery got too low, but still functioned. I replaced the battery and it's been fine ever since - been about a year now. It was last summer sometime.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
This is the error mine displayed when the battery got too low, but still functioned. I replaced the battery and it's been fine ever since - been about a year now. It was last summer sometime.
I, was thinking maybe something to do with the battery. Its most likely the original battery in the car since its a 2015 and is probably starting to go bad.
 
1 - 5 of 5 Posts
Top