2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
5861 - 5880 of 6427 Posts

·
Registered
Joined
·
94 Posts
That I know, I just didn't want to lose my changes so far. Was hoping to track down whatever made it stop working, but I only see one drl related thing, and it's in fbcm. It's also showing as enabled, so I guess that's not it. :(
 

·
Registered
Joined
·
634 Posts
... my drls have stopped working. I have the bi-xenon version with the led drls. They come on with the parking lights, so I know they work. Any ideas how I could fix it?
1. No wonder that You have DRL lights OFF, due to every US market Mazda has them originally OFF except few vehicles of 2021;
2. If You have those lights retrofitted with proper harness - then do not forget that the F_BCM bit to ENABLE them must be set to ZERO
 
  • Like
Reactions: kalongauto

·
Registered
Joined
·
94 Posts
My 2014 sGT definitely had them enabled from the factory. Even on the front of the US manual, it shows the DRL's on. I'll attach an image of the same lights I have. (not my car though)

Anyway, I'm pretty sure the only values I've touched lately are in IC, does anyone know if there's any setting in there that could cause the DRL's to be disabled? I can't figure this out... 😣
280800
 

·
Registered
Joined
·
634 Posts
I'm afraid that You have confused the DRL with something different. The DRL lights get on only when You shift the drive lever from PARK & start moving >20kmph. And gets OFF when You shift driving lever to paking position or use the parking brake. Exactly for that reason You cannot see their functioning unless watching someone else to drive your car or see the reflection of your headlights daytime in some mirror ahead or from the car ahead
 

·
Registered
Joined
·
94 Posts
I understand that, they just aren't working at all.

In my car, they used to come on immediately when you put the car in drive, but mine aren't coming on at all under any circumstance. The only way to turn them on is to turn on the parking lights, but that's at low brightness.
 

·
Registered
Joined
·
634 Posts
According to the attached You can see that the DRL is ON only in case of symbiosys:
'>' 2mph/3kmph +
IGN - ON +
Parking brake released +
Selector lever out of P position +
Light switch position - OFF or AUTO (with Auto light system OFF - meaning at the daytime).

In all the other cases DRL is OFF.

In M2/CX-3 there's PID H/L_DRL available indicating the command from BCMM to ESU.
But there isn't any similar PID available for M3.

Also that perfectly explains why the feature is configured in F_BCM & hidden in BCMM for M2/CX-3.

Check also whether setting the 720-01-01 B3b4 bit into ZERO can help You
 

Attachments

  • Like
Reactions: bobstar_fr

·
Registered
Joined
·
94 Posts
I figured it out. The bit for DRL in fbcm was set to 1 which is off. I assumed 1 was on, but the description says on is 0. I have no idea how it got disabled, but I'm happy it's fixed now. :p
 

·
Registered
Joined
·
94 Posts
Also, I picked up a TK80 fsc from a 2016 cx9. Maybe I can get stock LKAS working with both the new FSC, and the 2018 eps I have retrofitted. Even if not, hopefully it will help get openpilot working, because right now my eps still won't accept LAS commands sent from openpilot even though I have most of the messages from a gen2 fsc with LAS enabled being spoofed.
 

·
Registered
Joined
·
634 Posts
The settings with TK80.. in your case should be:

706-01-01 C330 5120 00xx (M3/HB/NO_MRCC/US) / C310 5220 00xx (M3/SD/MRCC/US)
706-01-02 7081 0000 70xx (HBC/LDWS/LAS) / 8C81 0000 70xx
720-04-16 x2xx ....
720-04-19 C000 ....
 

·
Registered
Joined
·
94 Posts
Thanks @Nikodim. What about settings for hatchback with MRCC?
 

·
Registered
Joined
·
634 Posts
706-01-01 C330 5220 00xx (M3/HB/MRCC/US)
706-01-02 7081 0000 70xx (HBC/LDWS/LAS) / 8C81 0000 70xx
720-04-16 x2xx ....
720-04-19 C000 ....

In 706-01-02 You have to check the both cases
 

·
Registered
Joined
·
2 Posts
Hello,

Could anyone share latest (newest) exel file with updated codes (and explanations)?
In this many pages there are many version but I want latest to check some parts in RBCM (I've Mazda 6 2014)

Thank you in advance!
 

·
Registered
Joined
·
94 Posts
My TK80 fsc should be delivered tomorrow, I'll be testing it as soon as possible. This is it guys, we're finally going to figure out if it's possible to enable LAS on a mazda3 bm, even if it requires swapping out some modules. ;)
 

·
Registered
Joined
·
94 Posts
Lane keep assist is working!!! The only problem is now I get MRCC error, so cruise control won't work at all. Any ideas?
 

·
Registered
Joined
·
94 Posts
Here are my two DTC's if anyone has any ideas. I wonder why it's saying not configured.

Code:
Code:
===SBS/MRCC DTC C1A67:56-08===
Code: C1A67 - Forward Looking Sensor

Additional Fault Symptom:
- Invalid/Incompatible Configuration

Status:
- Previously Set DTC - Not Present at Time of Request
- Malfunction Indicator Lamp is Off for this DTC

Module: Smart Brake Support/Mazda Radar Cruise Control

Freeze Frame :
-VPWR: 13.90 V - Module Supply Voltage
===END SBS/MRCC DTC C1A67:56-08===

===SBS/MRCC DTC U2300:55-8A===
Code: U2300 - Central Configuration

Additional Fault Symptom:
- Not Configured

Status:
- DTC Present at Time of Request
- Malfunction Indicator Lamp is On for this DTC
And here's my FSC asbuilt data.
Code:
;Block 1
7060101C330522070E4
70601028C810000708D
7060103000000000011
7060104000012
;Block 2
7060201848100007085
706G2G2000000000011
706G2G3000012
And IC data.


Code:
;Block 1
720010165A26B668081
72001027900B2FF1064
720010300000000002B
720010400000000002C
720010500000000002D
720010600000000002E
720010700002F
;Block 2
7200201BAFF100000F3
;Block 3
720G3G1012C
;Block 4
72004011C290080FFF0
7200402FFFFFFC100EB
72004034A4D31424D85
720040431C1014D33A2
720040533453131C1CB
7200406023931353204
72004073100C103385F
7200408001B099400EB
7200409C10400000700
7200410BD0000BF01B8
720041121000000005D
720041200BF0220001E
72004130000000FBF0C
7200414033000020074
72004150000BF043235
7200416020010000053
7200417BF0530B4200A
7200418784F80BF064F
7200419C00000200024
720042000BF07000011
720042100200000BF2B
7200422082120010097
72004230000BF093046
720042400002000006F
7200425BF102000003F
7200426200001BF1142
7200427203F80000031
72004280053
edit: Incompatible configuration in IC as well.. It lets me write the values though. I'm using the settings for LAS+HBC.

edit2: Openpilot is working wonderfully as long as I have the LAS menu itself disabled in asbuilt. Just what I wanted. ☺

Yet another edit: So, after the first drive, openpilot suddenly stopped working. Go figure. Looks like the best way to get this working would be to fix the dtcs when I enable the LAS menu. I'm open to ideas. :/
 

·
Registered
Joined
·
634 Posts
Actually, I have no idea who figured that setting out in 720-04-17 line to have only MRCC functioning:
7200417BF0530B4200A
You can try to check in any original configuration & find that there are only three of them present: BF0570.., BF0572.. & BF0590.. The latest one was used with the first models of radar in 2013-2014.

In the real world, among thousands of analysed mazda original configs, I have never seen it to happen.
So, my first suggest for You would be to correct it to:
720-04-17 BF05 70B4 204A
as this is the one used in most cases in US since 2015 (though it can depend also on the radar model used by You, if it's a very old model maybe You need to check there BF0590..)

P.S. After correction You may need to make DSC/FSC/MRCC re-learn & reset DTCs at least 3 times
 

·
Registered
Joined
·
634 Posts
Also, I found that in your config You have the both of them enabled RVM + BSM, which is never met in the real world. You have to make a decision - either one, either the other one. 'Cause it can create conflicts
 
5861 - 5880 of 6427 Posts
Top