2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

4681 - 4700 of 4796 Posts

·
Registered
Joined
·
20 Posts
I re-write the setting for Find my Car in Mazda 6 2017 and used the Write button, not the Write all, but still no effect, maybe this functions only works on CX-5.

Also I managed to activate HBC and LAS using the combination posted by Ghost on page 180, but my parking sensors are off now:)) although they appear on CMU settings and the phisycal button does nothing now:

My IC and FSC Gen2 Data:

Before:

Line 16:
720G4H000002400066B
Line 19:
720G4H3100000100064

After:

Line 16:
720G4H08400000000C5
Line19:
720G4H3C00000100014

And the CHecksum accordigly

FSC Before:

;Block 1
706G1G100009000009F
706G1G2001800001038
706G1G3202000000051
706G1G4000012
;Block 2
706G2G10000900002A2
706G2G20011


FSC After:

;Block 1
706G1G16C80900072FD
706G1G28420000010C4
706G1G36060000000D1
706G1G4000012
;Block 2
706G2G16C80880072F6
706G2G24455


I tried to re-activate the parking senzors by making value b3b2 in B2 of line 16 to 01 but nothing, maybe it was a typo , I will recheck tommorow.

HBC and LAS work perfectly but I have a DTC:

Code: U0131 - Lost COmmunication with Power Steering Control Module A

Not sure if this is because the dezactivated parking sensors or other setting in line 16 and 19 of IC.

DO you have any ideas about the DTC above and how to activate parking sensors again?

Thank you!
 

·
Registered
Joined
·
15 Posts
I just compared a CX-5 from norway with one nearly the same equipped CX-5 from Germany and mine (other equipment)... I have not found a bit in IC, FBCM or RBCM which could indicate that it`s used in norway for the tail lights always on... afterwards I remembered, that some time ago I asked another northern EU M6 2018 owner and he told me that the tail lights are not active when DRL is on ... so you have to do your own comparison and find fitting cars/VINs/AS Builts... unfortunately - I would have been happy to help.
Are you sure about the tail light on by law with DRL on? Might it be that the front headlamps have to be on by law - and with these come the active taillights? Just asking.
Politics here in Iceland changed the law recently and want the cars to have their tail lights on all the time. Its not enough for them that auto light will turn the tail lights on, when dark.

It used to be the case in Sweden until 2011 but from what I read it changed and if you have auto light, your tail lights can be off during day time.

I know that on VAG Group cars you can code the tail lights to be one with the DRLs so I am wondering if anybody have come across to this setting in As-build. My only source of VIN numbers to compare are Swedish cars, but wont do me any good to me with the current law there.
 

·
Registered
Joined
·
809 Posts
So I understand you correctly, that even in Iceland currently the taillights are off when DRL is active in the available Mazdas? Then there most probably is no Mazda AS-Built we can compare it to and it is nearly impossible to find the one bit which has to be changed - if there is any...

Here at mcx5.org is shown how the taillights are operated in a CX-5 2012-2014. This indicates that if there is any bit, it could be in the SSU module or in the FBCM.
274892


274893
 

·
Registered
Joined
·
20 Posts
Any more ideas on Find my car feature for Mazda 6 2017? i tried changind the b7 in B0 to 1 from block 7B7-01-02 but to no effect, maybe it needs something in IC also?
Tristan did it on CX-5, anyone else with Mazda 6 tried this and worked?

PS: I enabled the parking sensors back after enabling HBC/LAS/DAA, but I still have the DTC U0131 Lost Communication With Power Ateering Control Module A, maybe this is because LAS and maybe I don;t have the steering wheel module for Vibration in LAS, anyone know how to verify with Forscan if I have the Vibration module for the steering wheel?

in LAS options from CMU I can select the warning type between Beep/Rumble and Vibration but I don;t know if Vibration is just "fake there" or it actually sees the module for that.

Thank you!
 

·
Registered
Joined
·
4 Posts
If I try to enable some functions in my car (LDWS and LAS, after reading almost all posts from this thread), is there is a danger to permanently break something?
In case of something not working properly will there be a possibility to back to default values and all will work back again?
 

·
Immortal
Joined
·
239 Posts
If I try to enable some functions in my car (LDWS and LAS, after reading almost all posts from this thread), is there is a danger to permanently break something?
In case of something not working properly will there be a possibility to back to default values and all will work back again?
If you save your data(backup) then you can restore - without backup its difficult. Always save/write down/ screenshot or whatever before you channge something.
 

·
Registered
Joined
·
15 Posts
So I understand you correctly, that even in Iceland currently the taillights are off when DRL is active in the available Mazdas? Then there most probably is no Mazda AS-Built we can compare it to and it is nearly impossible to find the one bit which has to be changed - if there is any...
Yes this is my case. Car from factory has this behavior, but now the local law changed, I try to explore my options.


One way to verify what is the expected behavior in Norwegian cars is to see what it states on the user manual, if it even exist (Mazda cars in Nordic countries and Iceland, are always through Mazda Denmark. Mazda offers only the options that Danish MAzda dictate).

My car came with Danish user manual, that states the same as English manual for the the taillights in Auto lights mode.
 

·
Immortal
Joined
·
239 Posts
if asbuild data dont make it - always is hardware possibility . diodes to right place or relay. i made my M6 front direction lights as an addition to DRL/park to white with switchback LEDs and using diodes they always lighting(of course when turn signal is on they are yellow). no matter if drl or dark ( i'm from nordic also) this one might me edit with asbuilt - when led you need modify asbuild because you get hyperflash (fast blink) when dont add resistors
 

·
Registered
Joined
·
1 Posts
Hello,

I have a Mazda 6 2015 EU edition. The function follow me home works only if the headlights are ON by Default, this it's not working if i have the headlight on Auto mode;

It's there any way to make this function to work even if the headlights are in Auto mode?

Thank you!
 

·
Registered
Joined
·
19 Posts
PS: I enabled the parking sensors back after enabling HBC/LAS/DAA, but I still have the DTC U0131 Lost Communication With Power Ateering Control Module A, maybe this is because LAS and maybe I don;t have the steering wheel module for Vibration in LAS, anyone know how to verify with Forscan if I have the Vibration module for the steering wheel?

in LAS options from CMU I can select the warning type between Beep/Rumble and Vibration but I don;t know if Vibration is just "fake there" or it actually sees the module for that.
Most likely you don't have the Vibration hardware and it just appears by default in the list of options. If you select Beep/Rumble and clear the DTC error, is it coming back?
 

·
Registered
Joined
·
20 Posts
Most likely you don't have the Vibration hardware and it just appears by default in the list of options. If you select Beep/Rumble and clear the DTC error, is it coming back?
Yes, I cleared the DTC and it appears again but I don;t remeber what warning was selected, if vibration or other.
I suspect this also, that I don't have the Vibration module in steering wheel and it has nothing to communicate with.

I also haven't tested the LAS yet, from what I've read it acts at speeds above 60KM/h or higher...My goal was to activate HBC, LAS is kinda annoying anyway.

I will select Beep/Rumble and clear, read the DTC again, will let you know, but I have a feeling that the DTC will persist.

Cheers!
 

·
Registered
Joined
·
1 Posts
Hello! Could you please help me? I have a 2014 Mazda6 (EU) with a retrofitted radar. I am trying to set the proper asbuild vaules for 720 04 23, 720 04 17 and 720 04 18. I am still getting errors, in the asbuild excel I cant' find any info for B2 and B3 vaules in these blocks. What should I set?
 

·
Registered
Joined
·
41 Posts
Has anyone seen IPC address start with 720-G1-G1 to 720-G4-HC? My 2017 CX-5 uses this address instead of the typical 720-01-01 to 720-04-28.
 

·
Registered
Joined
·
20 Posts
I set the Beep/rumble in LAS bvut I still have the DTC Code: U0131 - Lost COmmunication with Power Steering Control Module A

Does anyone knows the part number for Power Steering Control Module A?

Or if I can scan with Forscan to see if my car has this module equipped?
 
4681 - 4700 of 4796 Posts
Top