2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 20 of 278 Posts

·
Registered
Joined
·
2,366 Posts
Hi,

like some other users (here), I would like to install the washer fluid-level sensor to my car (cx-5). Installation and wiring is not a problem. The FBCM receives the correct value "low" and sends it to the HS-CAN. But the receiving Instrument Cluster (IC) is doing nothing with it. Probably because the washer indication symbol/text has to be activated to be shown in the LCD part of the right instument (including text). Does anyone know which values of the IC module have to be changed (and how) to activate the display of the washer fluid-level sensor indication/warning? And if someone could send me a download-link to his via ForScan saved IC configuration (or a screenshot) I really would appreciate that. So that I can compare mine with this. And I know, that there might be some more values that differ, due to differnt car models/equipment. But it`s worth a try...

Thanks & best regards
Tristan-cx5
 

·
Registered
Joined
·
2,366 Posts
@Tyrfing: Thanks for the file and the screenshot. Just for clarification: The blue icon in the screenshot is not the washer fluid level indicator - this is the coolant temperature indicator. Do you really have Xenon headlights and thus a headlight washer which brings along the washer fluid-level sensor? Only if these pre-requesites are met, it is worth a try with the values of your IC module.
 

·
Registered
Joined
·
2,366 Posts
@Tyrfing: Thanks a lot, but the values of the m3 and the cx-5 seem to be too different after comparsion. I would have to try too many values.

Meanwhile I got an IC module backup of a cx-5 2016 with washer fluid level sensor - thanks to @apnt1984. The IC values differ only in 11 positions to my cx-5. I compared them in this comparsion list. If no one is speaking against it, I would try to copy/program the differing values to my IC one by one/only one at a time. Hoping, that with one of them the washer fluid-level sensor shows up (which I short-curcuited so that it shall show "low"). Before doing so, I would do a backup of my IC config and after each attempt I would change back to the original values to change another value from the comparison list. If something else happens/shows up, I will note it.

@SergSlim: I found your "Mazda SkyActiv OBD-II calc (FORScan) v6.8-original.xlsx" some posts ago, but do not understand it (and have not read all 200+ pages of this thread). And I am not a developer. Could you please tell me, if something is speaking against my intention - meaning - shall I skip some of the yellow marked values from my comparsion list? Afterwards I will send my results to you - perhaps it somehow helps your Excel sheet?
 

·
Registered
Joined
·
2,366 Posts
@SergSlim:
Thanks a lot for your effort, time, work, help and the updated post & file! I will try to change/set the new IC value as soon as possible and will come back with the result.

Additional:
The following information might help for adding one more headlight info to your xls:
720-04-14 changes seem to be related to headlights as you already assumed.

apnt1984`s 2016 CX-5 GT-O has fully equipped matrix (ALH) LED headlights (he told me and according to this PDF). Shown as b6=1, b5=0, b4=0.

My 2016 CX-5 has "small version" LED headlights with only AFS (light follows driven curve), but no ALH (matrix dotted light). Shown as b6=0, b5=1, b4=1.

So the assumption is, that the ALH / matrix dotted LED headlight is b6=1 while b5 and b4 =0.


Edit: And of course thanks to @gxl78896610 for confirming the values!
 

·
Registered
Joined
·
2,366 Posts
Guys - you are awesome! It works! Thanks a lot to everybody! That was a nice international (ukrainian-norwegian-chinese-german) project - well done.

I changed my IC values from:
7200101A3017B2680EE
to
7200101A3217B26800E

If connector is short-circuited the display shows the low level washer warning:
Speedometer Auto part Gauge Measuring instrument Car


Full instrument view with ignition on:
Speedometer Gauge Vehicle Car Auto part


Connector short circuited, because sensor & grommet are not bought by now - that follows:
Electrical connector Technology Electronic device Electronics


FBCM_PID-value: normal (when connector is not short-circuited)
Text Blue Font Yellow Line


FBCM_PID-value: low (when connector is short-circuited)
Text Blue Font Yellow Line


Values of the IC (Instrument Cluster) module I changed/took over from apk1984`s values:
Text Green Font Line Screenshot


You need a type A instrument for this change:
Text Diagram Auto part Line art


Function of the washer fluid-level sensor (closes circuit):
Text Diagram Line Technical drawing Parallel


Probably the needed parts for a cx-5:
- Sensor KD3567488
- Grommet KD3767491
 

·
Registered
Joined
·
2,366 Posts
@drazick:

Please see also this thread for more information about that topic.

Can you explain it a little more?
See pics and their names:

Text Line art Font Auto part Diagram


Auto part Wire


Text Diagram Line art Design Font


Electronics Computer hardware Electrical wiring Technology Machine


Cable management Electrical wiring Wire Cable Electrical supply


Text Diagram Design Parallel Line art


Text Font Line Number Parallel


Text Diagram Line Parallel


Text Line Font Diagram



Did you need to make an electrical connection to the RBCM?
No, not to the RBCM - just to the FBCM on PIN 2S (blue at my connector and at the PIN 2S @FBCM) and there has to be a ground connection (black-red at my connector). This was already given at my car with the pre-installed connector I found near the washer tank - see photos above.

How did you install the level sensor in the tank?
Not yet installed - have to buy it. See parts above. In Germany there is a large tank for xenon with headlight washers which has the sensor installed, but halogen and LED headlights have not installed the sensor and a smaller washer tank. So you have to drill a hole the size of the sensor-grommet or buy/use the large tank. But the large tank might have a hole for the headlight cleaner motor you have to seal - see added thumbnail.


Was the preinstallation ready?

At least the connector from the washer tank to the FBCM was already installed at my car.
 

·
Registered
Joined
·
2,366 Posts
May I ask how to access the above mentioned website https://web.b2b.mazda.co.jp/AsBuilt/ ? Which browser do you use? It mentions to need IE 6.0 or higher: "System Error Warning ; To view this system, use Internet Explorer 6.0 version or above.." I tried the browsers MS Edge (IE 6 to 11 is not possible to install anymore at Win10), Firefox, Chrome and even an online emulator for IE 11 and IE 6. But the site always shows the same system error warning.
 

·
Registered
Joined
·
2,366 Posts
Today I tried to activate DAA and SCBS-R:

- Activation of DAA did not work due to missing, but required FSC - as I found out later by SergSlim`s xls-file
- SCBS-R requires "Parking assist unit (ultrasonic)" and "Laser sensor", which my car both should have, as it has working SCBS-F and front&rear PDC. Or is the Park Distance Control something else than the required "Parking assist unit (ultrasonic)"?

IC Module: 720-04-16:
Original value: 8000 2400 06EB
Value I tried to program: 8000 4400 060B - as I wanted to enable the two options b5 and b6 in B2. Was that correct? Is that necessary? When I tried to program that, the followinig error text was displayed:
Text Font Line Number Parallel
Text Font Line Screenshot Computer program


Already enabled was in B0 b1 = 1 (1 - Enable SCBS-R). Does this mean SCBS-R is already working?

What did I do wrong or is just the special ultrasonic hardware missing?
 

·
Registered
Joined
·
2,366 Posts
@Vadmmc: Yes, I think I have parking sensor picture overlay on CMU - see picture of rear camera beneath. And DAA could usually be found accoring to this video (see 1:25) via MZD settings - security.

@Nikodim: Thanks a lot! SCBS-R is working now after I considered the necessary correction in 720-04-01. But there is no text/message displayed in the instrument as it is when SCBS-F is activated after breaking. Is that the expected behavior? Edit: At a second test the same text/message for SCBS-R was displayed as for SCBS-F. Everything is fine now.

I changed:
720-04-01: 1A09 0080 FFCE to 1A29 0080 FFEE
720-04-16: 8000 2400 06EB to 8000 4400 060B

My IC module config after changing the values:
Text Font Line Screenshot Number
Text Font Screenshot Line Software


Directly after breaking via SCBS-R with just walking speed:
Tire Automotive tire Motor vehicle Vehicle Automotive design
Sport venue Skatepark Skateboard Photography Recreation
Speedometer Gauge Vehicle Auto part Car
 

·
Registered
Joined
·
2,366 Posts
@[email protected]:

Mine also beeps loud. And at a second test the same text/message for SCBS-R was displayed as for SCBS-F. Everything is fine now:
Speedometer Gauge Vehicle Auto part Car


I tested SCBS (front and rear) with empty moving boxes in my basement garage - without risking hurting anybody. Inspired by this video.
Land vehicle Car Vehicle Automotive tire Tire
Tire Automotive tire Motor vehicle Vehicle Automotive design
Sport venue Skatepark Skateboard Photography Recreation



@Vadmmc:
I tried to read my PSM_MZ module. It was not possible to read values/hex numbers etc. - I could only get these information:
Text Font Line Number Screenshot
Text Blue Font Line Screenshot


But I found a DTC "U2300:56-08" in PSM_MZ, which I deleted and will check regularly if it comes back again:
Text Font Line Screenshot Software
 

·
Registered
Joined
·
2,366 Posts
I have the same as Vadmmc.
PSM_MZ - Parking Sensor Module
Part number: GMC8-67UU0
@Meteoor: That`s not correct. Vadmmc has PSM_MZ Part number: BHS2-67UU0 in his Mazda 3. You have the same PSM_MZ Part number as I do (both CX-5) - but it was not possible for you to activate SCBS-R (rear) so far. You want to know why or how to activate aside from the information I already provided. Do you have your park distance control shown as overlay in your MZD? Does your car had SCBS-F (front) activated when you bought it (e.g. german equipment package "Prime Line" did not have it)? Please post your actual data/values for 720-04-01 and 720-04-16 here.
 

·
Registered
Joined
·
2,366 Posts
@Meteoor:

The second highest version should be able to activate SCBS-R (I also drive the 2nd highest - but the equipment might differ from country to country). Probably you only need to program the correct values. Make a backup of your original values before. According to your VIN (with which I calculated the whole block 04) you sent me via PN the correct data for enabling SCBS-R at your car should be:

720-04-01: 1A33 0080 FFF8
720-04-16: C000 4400 064B

Remember to only use the button "Write" (not "Write all") afterwards.
 

·
Registered
Joined
·
2,366 Posts
@SergSlim or @Nikodim:

I got the VIN of a nearly same equipped car as my own CX-5 - I would like to try to find differences to enhance the XLS of SergSlim.

The other car has:
- no Bose Soundsystem
- no Keyless
- Rear camera is not ex factory, but installed by the dealer before buying (mine ex factory)
- 2WD (mine: 4WD)
- Diesel (mine: gas)

Differences I saw in the IC module comparison:
720-01-01 in B1: b1 and b0
720-04-10 in B0: b5, b3 and b0
720-04-11 in B0: b2 and b0
720-04-16 in B0: b6
720-04-27 in B2: b3 - that is obviously the different type of rear camera

This leaves 8 bits of difference... I think about programming the bits of the other car (one by one) in my car and see what`s missing/happening (e.g. with Keyless or Bose settings). Or is there anything speaking against this project or do I have to consider something (aside from the correct checksum in 720-04-01)? And yes, I will do a backup of IC module before and do it on my own risk.
 

·
Registered
Joined
·
2,366 Posts
The problem is to find another CX-5, which does not have these overlay features and at best no other equipment differences (as they disturb/prolongue the trial & error anaylsis)... Does anyone know with which features these overlays @ MZD are connected? Rear camera with dynamic assist lines instead of fixed assist lines ? Original front PDC? Part number of PSM_MZ version?
 

·
Registered
Joined
·
2,366 Posts
Just activated front parking sensors with CMU overlay and meny item.

The bit responsible is 720-04(3)-16 B2:b3=1. @SergSlim, you can add this into xls.
I also suppose that 720-04(3)-16 B2:b2 is rear park sensors only/no overlay, but i have to check it additionally.
Congrats if it works for you.

But your findings irritate me a little after I compared them with my values. Perhaps you would like to check your values with mine. As I am quite new to this topic, I might miss/oversee something. My CX-5 has original front and rear parking sensors - I assume with CMU overlay (see pictures below):

My 720-04(3)-16 B2:b3=0 (and not 1, like you wrote how it shall be)
My 720-04(3)-16 B2:b2=1 (but I have overlay and not only rear parking sensors - but also front ones)
Text Font Line Number Parallel

(I already activated SCBS-R and tested it with moving boxes - it works.)

My IC module backup *.abt:
View attachment 20180214_IC_Modul_backup_as_built format_cx5_after_activating_scbs-r - and already activated was.txt

Drive gear - front parking sensors:
Light Lighting Nightlight Ceiling Window


Rear gear - rear parking sensors with overlay and rear camera with dynamic assist lines:
Screen Technology Luxury vehicle Car Electronic device


My PSM_MZ - Parking Sensor Module
Part number: GMC8-67UU0
 

·
Registered
Joined
·
2,366 Posts
@Tristan-cx5 this seems to be one more difference between PSM_MZ versions. Your car has OEM front/rear PS sensors and PSM_MZ module with SCBS-r related readable PIDs. Besides AFAIK there are no facelift CX-5 with rear park assist only but prefacelift M3 has this option. So there might be only single bit responsible for activation both front/rear+overlay in some newer revisions of PSM_MZ without possibility to activate rear only like in my car with simplified PSM_MZ where activation option is splitted into 2 single bits. I think you may check it by disabling this bit. IMHO.
@Vadmmc : Thanks for the explanation. Correct, there is no CX-5 I know of with rear park assist only. I tested some PDC values this morning. According to these findings and your explanation there are differences between the PSM_MZ modules. My 720-04-16 B2:b2=1 seems to activate rear+front PDC, but it interferes with b3=1 - with this additionally activated, front+rear PDC is not working.

Findings / test results:

Original; B2:b3=0,b2=1 - front & rear PDC working normal
720-04-01: 1A29 0080 FFEE
720-04-16: 8000 4400 060B

B2:b3=0,b2=0 - front PDC not working (no LED, no overlay, no beep @ drive gear), rear PDC working normal
720-04-01: 1A25 0080 FFEA
720-04-16: 8000 4000 0607

B2:b3=1,b2=1 - front & rear PDC not working - not via button, no beeps, no overlay
720-04-01: 1A31 0080 FFF6
720-04-16: 8000 4C00 0613

B2:b3=1,b2=0 - front & rear PDC not working - not via button, no beeps, no overlay
720-04-01: 1A2D 0080 FFF2
720-04-16: 8000 4800 060F

...in all cases the rear camera worked fine and showed dynamic lines.

...these findings as XLS:
View attachment Parking_Values_Test_CX-5_FL_2016.xlsx

Named pictures of the test:
Bumper Headlamp Automotive exterior Vehicle Light
Red Carmine
Electronics Lighting Sky Technology Display device
Darkness Graphic design Illustration
Font Graphic design Art
Screen Electronics Multimedia Technology Display device
Font Technology
Electronics Multimedia Technology Vehicle Car
Modern art Line Eye Art Painting


Edit: If you test like this - please be aware that you have to clear DTCs in PSM_MZ afterwards.
 

·
Registered
Joined
·
2,366 Posts
Regarding PSM_MZ swap - i will probably try to do this also but first i will add front sensors and find wiring diagrams for both cars PSM_MZ. Till today i can not find parking sensors diagrams.
@Vadmmc : If with "both cars" a M3 and a CX-5 was meant, please find attached PDC information for CX-5 (2012-2014). Infos are from a RHD, so the modules are sometimes on the other side of the car for our LHD.
1. View attachment Mazda-CX-5-Electrical-Wiring-Diagram for RHD - PDC wiring.pdf
2. View attachment Mazda-CX-5-Technical-Guide-Manual_wiring_of_PDC-to-clima-control-unit.pdf
3. View attachment Mazda-CX-5-Technical-Guide-Manual_PDC.pdf

Edit: And perhaps you can find some M3 info at this link. Or have a look, if the needed wiring diagram is available here.

-------------

... For example, in CCC - there's difference in 720-04-16 B0 b7-b6.
I have b7 =1 and b6 = 0, and that other car vice versa. We have it noted as related to SCBS-R in the file, but we don't have all those fancy i-Active stuff in our cars. No Parking sensors in both of our cars.
@SergSlim :
I also found a very similar car to my cx-5 (see post #2169). We also have different values in 720-04-16 B0 b6. He b6=1, Me b6=0. I tested this morning and overtook his b6=1 (and adapted the checksum in 720-04-01), but no visible changes in IC after turning ignition on and no changes in CMU setting for Bose/Keyless (as this is different equipment).
 

·
Registered
Joined
·
2,366 Posts
I suppose you should also look for changes in other modules. Not only IC.
I just compared data from that website which gives As Built by VIN code.
Thanks for the reminder. I also compared the other modules/data which are available with VIN via website. Only in SSU I found different bits:
731-01-01 B2:b7=Keyless // B4:b0= ?
731-01-02 B0:b3= ?

When I changed 731-01-01 B4:b0 from 1 to 0 the "walk-away-lock" was unchecked afterwards. That makes sense, as the other car has no Keyless. After checking the "walk-away-lock"-checkbox at CMU the value in SSU module stayed as programmed before. While the checkbox was ticked at CMU I switched back to B4:b0=1 and afterwards the checkbox was also unchecked. Did not expect that.
Text Font Technology Vehicle Car
Text Font Technology Material property Electronic device


I also tested more bits - as stated in post #2169. But most value changes did not show anything in instrument and no changes in CMU settings. I expected Bose-Options to disappear somewhen, but they always stayed. Only visible changes at instument after changing in IC module 720-04-11 in B0:b2 from 1 to 0 and 720-04-11 in B0:b0 from 0 to 1 (both at changes at once including new checksum at 720-04-01) three LED showed up: ABS brake and TCS glowed directly and TPMS blinked for a while before it glowed.
Speedometer Gauge Auto part Measuring instrument Tachometer


In my car it's: 7B7-01-03 B1: b5 = 1, b4 = 1
Same in my RBCM: 7B7-01-03 B1: b5 = 1, b4 = 1. I also have Leaving Home and Coming Home menu in CMU and both works fine. My Module: AFS - Adaptive Front Lighting System, Part number: KA0G-5102X-
 
1 - 20 of 278 Posts
Top