2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
My 2014 Mazda3 iGT had a weird electrical short or something on my way home tonight.

I was driving home from work today and suddenly the radio went quiet, cruise control turned off and all the dash lights came on for a second or so before returning to normal! It really freaked me out, especially as I was going around 70 on the highway. However, about 15 minutes later it happened again, but this time the speedo went to zero then back up again. I don't think the engine shut off, but it was enough to get me to pull over. I turned off the car and restarted. It didn't happen again all the way home.

I called the dealer and have an appointment to bring it in tomorrow. I would never have expected this to happen, let alone in a car that is barely a year old. It really worries me wondering what caused this, but hopefully the dealer can find an issue and they don't just tell me they couldn't replicate the issue. It makes me a bit nervous to be driving it if the electronics are acting up.

Anyone else have this issue?
 

·
Registered
Joined
·
249 Posts
That's pretty bad i'm glad the engine did not shut off! Hopefully there's some sort of logs the dealer can look up, but don't be surprised if they tell you they can't reproduce the issue that seems to be the answer for ANY intermittent issues of this generation of Mazda3. I would put a camera like a dash cam or a GoPro somewhere in the car to record the issue so you have proof.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #4
Forgot to post a reply, but I got the car back the next day and they said there were some error codes showing the electrical shorts. They determined it was most likely a loose connection on the battery or something like that. They weren't able to reproduce it, but at least it hasn't happened since. Hopefully, that was it.
 
1 - 6 of 6 Posts
Top