2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
354 Posts
Discussion Starter #1
[repost - posted in the wrong forum originally]

Hi All,

When I got my M3, I paired my iphone to my car, and everything has been working flawlessly (up to and including upgrading to iOS 4 for the phone), until this morning.

I got into the car, and the display showed it was "searching" for quite a few minutes, and I found it rather strange, so I switched the "mode" to CD, turned the stereo & car off, and back on again. When I started the car and pressed the "Aux" button, nothing happened, at all, no beep, no switching from the CD that was playing, I tried using the steering wheel to change it incase somehow the button on the dash was acting up, and the car isn't recognizing the Aux function at all. I thought maybe the iPhone was acting up somehow, so I restarted it. Still nothing.

Has anyone had this issue? I'm going to try it again tonight on the way home, but I'm wondering if it's something that's going to need to be looked at by Mazda?


Thanks!!
MM
 

·
Registered
Joined
·
213 Posts
Your post is not really clear. The AUX input is for the wired input port. There is a separate BT audio input. I am not sure why you are going to the AUX setting on the car radio.

If BT pairing is messed up, you can repair the phone; but you need to delete your iPhone pairing on the car and the phone first. After deleted you can try setting up a new pairing withe the car and phone.
 

·
Registered
Joined
·
354 Posts
Discussion Starter #3 (Edited)
When I click the AUX button, it switches to my bluetooth connection (for music). Always has, I don't have a separate button for my bluetooth. Maybe it's a Canadian thing?

The phone is still recognizing the car (mazda is listed under it's bluetooth devices), it's the car that isn't recognizing the phone.

[edit] found the page in the manual that tells you to press the AUX button for BT Audio http://www.mazda.ca/files/2010Mazda3OMENG.pdf page 290 (mostly just to confirm I'm not losing my mind! haha)
 

·
Registered
Joined
·
213 Posts
I didn't mean to doubt, you i always just cycle through using steering wheel controls. I never tried the button.

I still suggest trying to remove and redo the pairing. Can you make calls using bluetooth? If you take it into the dealer, they will probably try to pair it with something first anyway.

My attitude is that if it doesn't work now, you can't make it worse by deleting the pairing. Also, there seem to be reports about problems regarding iOS 4.0 and stereo bluetooth headphones - this is the same BT profile used to send music to the car radio so it could be related.

iPhone 4 issues with stereo Bluetooth headsets? | iPhone Atlas - CNET Reviews
 

·
Registered
Joined
·
354 Posts
Discussion Starter #5
I would use the button more if I listened to the radio, but it's quicker to switch back and forth to cd/bt audio on the dash rather than cycling thru.

I thought it could have been the new OS, but it worked perfectly when I updated it on Tuesday (or monday? which ever day it was lol), it was just this morning that it decided to hate me. Checked out your link, and I have a 3GS, just with the new operating system, so it isn't likely to be the signal issue that the iPhone 4 is having.

I'll give your suggestion a try tonight, I need my tunes for the drive home! It's not picking anything up, no calling, no music, makes me a sad bear :(. Worst case scenario I suppose is I delete and re-pair and it still doesn't work and I detour to Mazda on the way home.
 

·
Registered
Joined
·
15 Posts
I noticed the same thing after I installed ios 4. I didn't have to delete the pairing then redo it again, but it did take a while for the phone and car to find each other. After the first time like that it connects fine, although it sometimes it takes a few seconds for a call to be transfered to the car, ie it rings in my pocket once or twice then the car picks it up. Feels like an ios bug to me, but what do I know.
 

·
Registered
Joined
·
354 Posts
Discussion Starter #7
Got in my car tonight, pressed the AUX button, and it's back to normal. I'll keep an eye on it and make sure it doesn't happen again, maybe it was just a one-off
 
1 - 7 of 7 Posts
Top