2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Hi guys
my CX5 2016 has problem in BSM system
when i Simply switch on the car BSM dosnt work at all

But when i Press ignation key 2 times without pressing break padel then press it and switch on car BSM works normal

any one have idea or have same issue

many thanks
 

·
Registered
Joined
·
61 Posts
Sounds like a warranty issue.

My 3 once had blindspot monitoring on the mirrors that stopped working. It would still light up when turning on the car or pressing the power twice while parked. I washed the car and it worked. Weird, iono how dirt can affect it, but whatever.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #4 ·
Sounds like a warranty issue.

My 3 once had blindspot monitoring on the mirrors that stopped working. It would still light up when turning on the car or pressing the power twice while parked. I washed the car and it worked. Weird, iono how dirt can affect it, but whatever.
Thank you for reply ,, i washed car already and nothing happen

the point is : it works normaly when i pushed switch 2 times
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #5 · (Edited)
I go to dealership they didnt know anything about it .. they tell me computer check everything is good
but the system dose not work until now normaly

what should i do Help me !!
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #7 ·
Does it work when you start driving? It's not supposed to work when you're under ~7 mph or so.
it is not working at all i try it in all condition
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #9 ·
Hi ,,

The problem solved ,,, it was so easy but dealer here missed experience
the problem was the Battery ,, they just change it and everything works normally .

thank you :)
 

·
Registered
Joined
·
16 Posts
Hi ,
i have the same problem. I don't think the problem is with the battery , in my opinion the battery is just the trigger and the system is faulty. because every other accessory is working ok , including the ignition.
I mean , if it is the battery why it does not affect the lights, iginition, wipers, turn signal , AC, etc ?
 

·
Registered
Joined
·
286 Posts
Hi ,
i have the same problem. I don't think the problem is with the battery , in my opinion the battery is just the trigger and the system is faulty. because every other accessory is working ok , including the ignition.
I mean , if it is the battery why it does not affect the lights, iginition, wipers, turn signal , AC, etc ?
Cars do weird things when they get low voltage and lower-draw items are more likely to suffer first.

On my last car forum (Hyundai) we had a guy with an Elantra whose daytime running lights (the high beams running at reduced voltage) weren't working. I was one of the first replies and told him to replace the bulbs but he didn't listen. He replaced the entire on board computer, the headlight switch, and everything but the bulbs to no avail. I think he spent close to $1000 before popping in a set of $15 bulbs and guess what? His DRLs and high beams came back on.

My point is, start with the cheapest and easiest fix first.
 

·
Registered
Joined
·
16 Posts
I absolutely agree with you , but in my case BSM is covered by warranty for few more months and the battery is not.
The service man suggested me to replace the battery because with a new battery the BSM works.
That means within a year i may stay with unnecessary new battery and non functioning BSM and without warranty.
 
1 - 12 of 12 Posts
Top