2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 20 of 34 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
Hi there,

Before the Kit Kat 4.4 upgrade my bluetooth and infotainment worked fine. I just updated to KitKat today. The infotainment will not download any text messages. I would get a text and would hit the update, it spins for a while and swill say unable to download. I have tried unpairing the phone and reseting but it still does not work. Has anyone experienced this or have a solution?
 

·
Registered
Joined
·
72 Posts
Hi there,

Before the Kit Kat 4.4 upgrade my bluetooth and infotainment worked fine. I just updated to KitKat today. The infotainment will not download any text messages. I would get a text and would hit the update, it spins for a while and swill say unable to download. I have tried unpairing the phone and reseting but it still does not work. Has anyone experienced this or have a solution?
I have an S2 w/Ice cream sandwich and it it will not download text. Same error you are getting. My wife has Galaxy Blaze and soemtimes it downloads them and other times it says unable to connect to phone. Had it at dealer and they could not fix it.

Now during incoming phone calls it will only show number , not the name.

This infotainment has too many bugs. First gen of anything is a bad idea to purchase.....I knew better, but needed a new car.
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #3 ·
Sometimes contact names will show up. Sometimes it just shows the number. My text is still not working. I may have to try and wipe my phone. Or downgrade the Kit Kat to 4.3.....
 

·
Registered
Joined
·
72 Posts
Sometimes contact names will show up. Sometimes it just shows the number. My text is still not working. I may have to try and wipe my phone. Or downgrade the Kit Kat to 4.3.....
mine were working fine until I had homelink mirror installed. They disconnected the battery. I think that may have something to do with it. IDK

You should not have to wipe your phone. I am hoping dealer will update my firmware to latest version and that will fix it.

Do you have to reconnect everytime you get back into car? even if you leave it paired?

It should auto connect, but it never does....
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #5 ·
My phone still connects automatically. Every thing still works fine except for the text messaging part.
 

·
Registered
Joined
·
9 Posts
I have the exact same problem with my texts, at least I know I'm not the only one. I have to manually pull up the texts on my s4 then it will show up on the screen (defeats the purpose haha) I've also disconnected my battery when I put in my footwell lighting. Everything else works fine tho.
 

·
Registered
Joined
·
590 Posts
mine were working fine until I had homelink mirror installed. They disconnected the battery. I think that may have something to do with it. IDK

You should not have to wipe your phone. I am hoping dealer will update my firmware to latest version and that will fix it.

Do you have to reconnect everytime you get back into car? even if you leave it paired?

It should auto connect, but it never does....
Do you have the 2.5, if so battery disconnection is tricky...
 

·
Registered
Joined
·
590 Posts
I have the exact same problem with my texts, at least I know I'm not the only one. I have to manually pull up the texts on my s4 then it will show up on the screen (defeats the purpose haha) I've also disconnected my battery when I put in my footwell lighting. Everything else works fine tho.
Same here, if you have a 2.5 you need to disconnect the battery a certain way. You may need to go to the dealer and get a reload.

To tell you the truth, the whole info-caca is wonky...never seen anything like this..
 

·
Registered
Joined
·
70 Posts
I have an LG G2, stock that acts weird with the system. Via Bluetooth to Infotainment:

1. Text messaging works 30% of the time. Most of the time "unable to connect."
2. Incoming and outgoing calling works. However,
3. Outgoing phone calls show phone number, name, and picture of contact just fine!
4. Incoming calls ONLY show phone number. I have to study the phone number real closely to see if I recognize it. Otherwise I let go to voicemail. Keep in mind, my phone is setup to only accept calls from people in my contacts. However, when I ignore the call and then go back into call history (in infotainment), it shows contact's name and picture. Go figure. Pain in the butt!!
5. Email doesn't work at all. Never has.
 

·
Registered
Joined
·
1,791 Posts
Do you have the 2.5, if so battery disconnection is tricky...
No it isn't. I've done work on the car and disconnected the battery a few times. The system always works fine. When there is a version update, you should reset the infotainment system to factory defaults, remove the pairing from your phone, and re-pair your phone. I've had none of the problems you guys have. Methinks there are some user issues out there. New systems like this are never foolproof. It's just learning how to use it properly. Of course there will be more features and updates as time progresses. If you have a proprietary system like Apple then you can expect more problems because Apple is a closed system.
 

·
Registered
Joined
·
590 Posts
No it isn't. I've done work on the car and disconnected the battery a few times. The system always works fine. When there is a version update, you should reset the infotainment system to factory defaults, remove the pairing from your phone, and re-pair your phone. I've had none of the problems you guys have. Methinks there are some user issues out there. New systems like this are never foolproof. It's just learning how to use it properly. Of course there will be more features and updates as time progresses. If you have a proprietary system like Apple then you can expect more problems because Apple is a closed system.
I work with computer all day long and search as well. Many many many sites that comment on or has a forum about the M3, all say the INFO-:shit: just stinks...

My dad is a car nut and has had lot of car and many with Navi-phone-media, u name it, and he said the M3 info-:shit: is the worst.

Sorry to vent, i lost all my favorites again today. I have stop adding them till this is fixed. :taz:
 

·
Registered
Joined
·
1,791 Posts
I work with computer all day long and search as well. Many many many sites that comment on or has a forum about the M3, all say the INFO-:shit: just stinks...

My dad is a car nut and has had lot of car and many with Navi-phone-media, u name it, and he said the M3 info-:shit: is the worst.

Sorry to vent, i lost all my favorites again today. I have stop adding them till this is fixed. :taz:
I don't know what you're doing, but I've never lost my favorites. You always hear from those who have problems but rarely from the majority of us who don't. If I had to hazard a guess it sounds like you're doing something that breaks the code. If you do know something about coding, then you'd know that you should take a diagnostic approach to problems. I'd start by first doing just basics. You'll want to reset your system to factory defaults and don't connect your phone. Try this for a week or so and see if you have problems. Then, pair your phone and use it for audio only. Try that for a week an see if you have issues. Then add media to the connection and so on. My guess is that you'll hit a point where a problem occurs.

If I had to hazard a guess it would be that your phone is asking the car system to do something it wasn't programmed to do. This often occurs on new system development which is why Microsoft, and Apple, constantly update their OS. Apple users, again, are particularly problematic because Apple is a closed system. It is also possible a very new Android version can cause problems. I use a USB stick and Android 4.1 and have zero issues. When you are at the bleeding edge, you should expect problems.

So what you should do is find the problems, document them, and report them to Mazda. At least that would be a lot more helpful than just complaining which absolutely no one likes. How do you think Microsoft and Apple fix issues like this? Even final versions from those companies have bugs which are reported and fixed. So please get a clue.
 
  • Like
Reactions: Nitsuj

·
Registered
Joined
·
468 Posts
I have apple and I can't get email notifications or reply to my texts. Oh wells.
Other then that, all seems to work fine. Once in a while it has a difficult time connecting to the iPhone's hotspot.
 

·
Registered
Joined
·
1,791 Posts
I have apple and I can't get email notifications or reply to my texts. Oh wells.
Other then that, all seems to work fine. Once in a while it has a difficult time connecting to the iPhone's hotspot.
It will take at least a year to fix all of the bugs in a new system like this. Fortunately, the firmware can be updated. We all take a risk in buying something new and I think most of us realize this and cut Mazda some slack. I'm happy with the car but no new car is perfect...
 

·
Registered
Joined
·
590 Posts
I don't know what you're doing, but I've never lost my favorites. You always hear from those who have problems but rarely from the majority of us who don't. If I had to hazard a guess it sounds like you're doing something that breaks the code. If you do know something about coding, then you'd know that you should take a diagnostic approach to problems. I'd start by first doing just basics. You'll want to reset your system to factory defaults and don't connect your phone. Try this for a week or so and see if you have problems. Then, pair your phone and use it for audio only. Try that for a week an see if you have issues. Then add media to the connection and so on. My guess is that you'll hit a point where a problem occurs.

If I had to hazard a guess it would be that your phone is asking the car system to do something it wasn't programmed to do. This often occurs on new system development which is why Microsoft, and Apple, constantly update their OS. Apple users, again, are particularly problematic because Apple is a closed system. It is also possible a very new Android version can cause problems. I use a USB stick and Android 4.1 and have zero issues. When you are at the bleeding edge, you should expect problems.

So what you should do is find the problems, document them, and report them to Mazda. At least that would be a lot more helpful than just complaining which absolutely no one likes. How do you think Microsoft and Apple fix issues like this? Even final versions from those companies have bugs which are reported and fixed. So please get a clue.
Geee....you sound like you work for MonkeyConnect. I know a ton about apples. I eat them every day, there good for you.

Anyway. I did all that I is was suppose to do. What I believe is the problem with the Infotainment system , is corrupt memory, or a corrupt firmware update. It just takes one file left over from a previous version to cause havoc. I am waiting for the next version, and will tell the dealer to totally wipe the previous versions and install the A new clean update. SOME DEALERS DONT WHAT I FOUND OUT.

A CLEAN INSTALL IS BEST FOR DIAGNOSING ISSUES.
 

·
Registered
Joined
·
1,791 Posts
Geee....you sound like you work for MonkeyConnect. I know a ton about apples. I eat them every day, there good for you.

Anyway. I did all that I is was suppose to do. What I believe is the problem with the Infotainment system , is corrupt memory, or a corrupt firmware update. It just takes one file left over from a previous version to cause havoc. I am waiting for the next version, and will tell the dealer to totally wipe the previous versions and install the A new clean update. SOME DEALERS DONT WHAT I FOUND OUT.

A CLEAN INSTALL IS BEST FOR DIAGNOSING ISSUES.
So do a factory reset yourself. There is a place in the menu for resetting factory defaults. Do it. It's generally not code left over that causes problems, but changes in format for the settings files. When you reset factory defaults, it gets rid of those files. You should know and understand this. But I guess you work for the monkeys as well -- only those that are out of a job.

If you don't like your car, instead of complaining, get rid of it...
 

·
Registered
Joined
·
1,791 Posts
I have apple and I can't get email notifications or reply to my texts. Oh wells.
Other then that, all seems to work fine. Once in a while it has a difficult time connecting to the iPhone's hotspot.
One more comment... My text messages and email works great on the system. I especially like the feature that reads back my email messages aloud. Apple is so damn proprietary that you have to be a hacker to get it to work right. Unless Apple builds a driver for our Infotainment system, I doubt whether you'll ever see an iPhone work with it properly. And I'm sure Mazda doesn't want to pay the royalties to Apple to use their patents on this system.

Don't get me wrong, I like Apple products. But when I'm interfacing with other complex systems, I don't want to touch apple products. Only if I remain in the Apple ecosystem do their products work properly. Mazda will eventually hack their way into making Apple products somewhat effectively work with the infotainment system. But again, it will take some time -- perhaps years to make that happen. In addition, international sales for the iPhone is not great and Mazda's U.S. share is low which makes this a lower priority for the company. Since I like connectivity, and connect a lot of systems, I would never buy an iPhone.
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #19 ·
Hi Rvoll,

So I should unpair my phone first, then do a factory reset on the infotainment system, then disconnect the battery. Then reconnect the batter and then pair my phone again?

I have already unpaired the phone a few times, and reset the infotainment once. It did not work. Never thought of disconnecting the batter. I will give it a try this weekend.

Thanks!
 

·
Registered
Joined
·
468 Posts
One more comment... My text messages and email works great on the system. I especially like the feature that reads back my email messages aloud.
Glad this function actually works on the iphone :biggrin:
I mentioned in another post that it also displays messages in Korean, which was an added surprise.
 
1 - 20 of 34 Posts
Top