2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
As the title says, has anyone attempted to upgrade their USB ports?

As noted and buried in threads elsewhere (Ah, modern day acronyms. Too short to search. Too common to be worthwhile.), these ports are extremely out of date. I'm convinced this is one of the things alluded to needing to be upgraded once AA and Carplay hit. (Which makes me now think that we will not actually see a retrograde addition of these but I'll take them at their word.)

This morning, I tried out using the USB port to charge my phone while streaming audio over BT with the screen off. The phone said that it was charging but all it does is slightly slow down the battery drain. My battery was lower at my destination than when I started. For now, I'll just go back to using the 12v charger with the phone connected normally to the infotainment system via BT and run AA on my phone on the dash.
 

·
Registered
Joined
·
1,998 Posts
Hmm my USB port charged my phone. Wouldn't say fast but I get about 8-10 percent on my 15 minute drive to work.
 

·
Registered
Joined
·
8 Posts
I have the '17 2.5L, and it charges my iPhone 5S just fine regardless of what I'm doing. I even went on a road trip and had Waze going for a good portion of it and my phone wasn't discharging.
 

·
Registered
Joined
·
899 Posts
Its not a fast charge but still counts LOL. I leave my cable plugged into the usb at all times and use it on my drive home.
I also carry a dual USB lighter adapter that charges much faster. I don't like to leave the lighter adapter in all the time because it gets warm even though its new.

I have read where some people hardwired USB plugs into better spots as well but i am not that concerned.
 

·
Registered
Joined
·
65 Posts
Buried in one of those thread I was recommended one of these USB hub that passes through data and also provide additional charging. I picked one up but haven't tried it yet.

Search for "UNITEK Portable USB 3.0 4-Port High Speed Hub with BC 1.2 Charging " on Amazon.
 

·
Registered
Joined
·
19 Posts
Buried in one of those thread I was recommended one of these USB hub that passes through data and also provide additional charging. I picked one up but haven't tried it yet.

Search for "UNITEK Portable USB 3.0 4-Port High Speed Hub with BC 1.2 Charging " on Amazon.
I bought one of those after reading that thread and it wont pass data though :( Be interested to see if anyone has got it working.
 

·
Registered
Joined
·
65 Posts
Buried in one of those thread I was recommended one of these USB hub that passes through data and also provide additional charging. I picked one up but haven't tried it yet.

Search for "UNITEK Portable USB 3.0 4-Port High Speed Hub with BC 1.2 Charging " on Amazon.
I bought one of those after reading that thread and it wont pass data though
Be interested to see if anyone has got it working.
Awww really? Let me give it a shot when I get home tonight.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #8
Yeah, no, I'm barely getting a trickle charge out of the USB port. It's got juice coming out but not enough to keep up with my phone with the screen off. Screen on would be murder pushing that many pixels! Also, the infotainment does not see/cannot select it as a USB source for music. Going to try another cord but this might be another case where Mazda isn't caught up with current phone tech.
 

·
Registered
Joined
·
65 Posts
Buried in one of those thread I was recommended one of these USB hub that passes through data and also provide additional charging. I picked one up but haven't tried it yet.

Search for "UNITEK Portable USB 3.0 4-Port High Speed Hub with BC 1.2 Charging " on Amazon.
I bought one of those after reading that thread and it wont pass data though
Be interested to see if anyone has got it working.
Awww really? Let me give it a shot when I get home tonight.
Okay I tried mine and it seems to work. I have it connected to my 2A cigarette charger and the USB port under the armrest.

I measured the current using the Ampere app and was able to "start" Android Auto. But I have v0.93 of AA on my car and it looks like Google increased security on the phone side? But regardless, my phone tried to start AA when I launched the app from the car which means the data connection is there.

Side question: the latest homebrew AA is able to bypass Google's latest and greatest security checks?
 

Attachments

·
Saab ex-pat
Joined
·
9 Posts
I think a USB Y cable would work. Plug one USB male port into data and the other into a cigarette to USB adapter for power. Then plug your phone cable into the female port. I just ordered one and will get it Saturday so I can test it out and tell you all if it works.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #11
I tried a different cord. The USB ports definitely do not keep up with a modern phone operating. Lost battery on my drive in.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #12
Ok, did a "control" test on my drive in and they will definitely need to redo the USB ports. Last two tests were with various USB cords and lost battery. 12v adapter, charges full speed. Today, drove in under same conditions with no charger and streaming BT. Started the drive at 100% and got to work a half hour later.... 100%. So when I'm plugged into my USB port, it's actually sucking battery out. I'm guessing it is due to the phone being USB-C and since that is the direction most devices will be going, they need to get on that.
 

·
Registered
Joined
·
114 Posts
This will solve all charging problems, 3.0 AUKEY Car Charger with Dual USB Ports. I ran the cables under the console and use these nets to hold the phones
 

Attachments

·
Registered
Joined
·
156 Posts
Discussion Starter #14
I've already got a Belkin 12V adapter for USB-C QC. That's fine for now but if Android Auto ever comes out, they will definitely have to replace the USB ports. They're about as useful as 5 inch floppy disks.
 

·
Registered
Joined
·
110 Posts
I think a USB Y cable would work. Plug one USB male port into data and the other into a cigarette to USB adapter for power. Then plug your phone cable into the female port. I just ordered one and will get it Saturday so I can test it out and tell you all if it works.
Sorry, USB Y cables don't work with smartphones. They only work with dumb USB devices like harddrives. We discussed it last month in the massive AIO thread; see, e.g.:

http://mazda3revolution.com/forums/2014-2017-mazda-3-skyactiv-audio-electronics/122458-aio-all-one-tweaks-378.html#post2053618

http://mazda3revolution.com/forums/2014-2017-mazda-3-skyactiv-audio-electronics/122458-aio-all-one-tweaks-378.html#post2054106
 

·
Registered
Joined
·
110 Posts
I've already got a Belkin 12V adapter for USB-C QC. That's fine for now but if Android Auto ever comes out, they will definitely have to replace the USB ports. They're about as useful as 5 inch floppy disks.
I'm assuming this is an Android phone? Could you install the Ampere app as shown by another poster earlier in this thread and check the [dis]charge rate when plugged/unplugged? I agree with you that more modern ports would be a big plus but I'm still surprised just how poorly the current ones work for you.

As to upgrading the ports, see what I did:

http://mazda3revolution.com/forums/2014-2017-mazda-3-skyactiv-audio-electronics/192954-mazda-says-apple-carplay-support-coming-soon-including-retroactive-upgrades-5.html#post2001090

More details here:

http://mazda3revolution.com/forums/2014-2017-mazda-3-skyactiv-discussion/192858-usb-ports-useless-3.html#post1989018
 

·
Registered
Joined
·
12 Posts
@mil, it looks like you built that off of my setup. I'm glad to see that it's working for others.

Details on my setup
and why a Y-cable won't work

The BC 1.2 standard supports charging at up to 1.5A but I only hit charge rates of about 900mA (using either the other USB port or a cigarette lighter adapter as the extra power input). Seeing that mil is hitting the same limit, I'm guessing that this is a limitation of the USB hub and not the phone. If anyone finds a smaller hub that supports BC 1.2 or one that is actually able to hit 1.5A, I would like to hear about it.

EDIT: it looks like Unitek makes a new, slimmer BC 1.2 hub that you could adhere to the inner wall of the center console for a bit cleaner install. Note that I have not tested this hub. Don't forget that you need a second USB cable to power the hub.
 

·
Registered
Joined
·
110 Posts
@mil, it looks like you built that off of my setup. I'm glad to see that it's working for others.

Details on my setup
and why a Y-cable won't work
Yes, I remember I found the solution in some buried post on this forum and looking at your post linked above it does look familiar. Thanks! I consider my main contribution to be taking the pictures and posting them, and trying to answer these questions every time they are asked, which seems to be every two weeks or so. In this day and age, it seems common for people to completely disregard anything you say unless unless they see some photos or, better yet, a video on youtube (ugh!). >:)

The BC 1.2 standard supports charging at up to 1.5A but I only hit charge rates of about 900mA (using either the other USB port or a cigarette lighter adapter as the extra power input). Seeing that mil is hitting the same limit, I'm guessing that this is a limitation of the USB hub and not the phone. If anyone finds a smaller hub that supports BC 1.2 or one that is actually able to hit 1.5A, I would like to hear about it.
My phone maxes out at 900 mA even if I plug it directly into a dedicated charger so I don't know what the actual limit of the hub is. Post #9 earlier in this thread has a screenshot of a phone charging at 1260 mA so I guess 900 mA is not the limit?

EDIT: it looks like Unitek makes a new, slimmer BC 1.2 hub that you could adhere to the inner wall of the center console for a bit cleaner install. Note that I have not tested this hub. Don't forget that you need a second USB cable to power the hub.
Yes, I saw it too when ordering mine; unfortunately it was out of stock at that time so I couldn't test it.
 
1 - 19 of 19 Posts
Top