2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2020 CX5 that came with version V70.00.335 . I successfully installed the tweak to enable touchscreen while driving, but it does not seem to work in the ANdroid Auto interface. Did I miss somethings? I am using the Android Auto from the headunit instead of the one from AIO because the AIO one is not compatible with v70 from what I read. Can you recommend a way to get touchscreen while driving with Android Auto on v70?

Thank you!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you for the answer, Tristan. I have not lost hope yet:

I noticed two approaches that I am hoping may work:
  • a new android auto app compatible with my fw versions, though the touch support is listed as "not recommended" - it's the one by abarth124 spider
  • maybe downgrading to v59, on which the regular mazdatweaks android auto app should work with touch support? I don't know if possible since my car came from the factory with v70 ?
 

·
Registered
Joined
·
1,539 Posts
Cant tell you something about a), but b) is possible.

Before you asked for touch for official AA at FW 70 and thats not possible.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Tristan, Thank you for your help so far! For downgrading to v59, since I am on ID2, what is the process to downgrade? Do I need serial connection? I would like to avoid it if possible since I just reassembled my dashboard :D.
 

·
Registered
Joined
·
1,539 Posts
When I once downgraded from 70.00.335 (with ID7v2 installed) to 70.00.100 I think that it was still possible to install AIO Tweaks after the downgrade, without having to do the serial access again.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks, Tristan. Are you sure it is ok to downgrade to a version that is earlier than the factory default version for my car? I don't want to irreparably break the infotainment.
 

·
Registered
Joined
·
210 Posts
Thanks, Tristan. Are you sure it is ok to downgrade to a version that is earlier than the factory default version for my car? I don't want to irreparably break the infotainment.
@dreckgos all tweaks, mod, upgrade/downgrade at your own risk. Nobody takes irresponsibility for your own decision/action. If you're worry or have no idea what you're doing then stop and leave it alone as its not recommend for you to tinker with your system.

Now If your car is straight from the factory brand new with fw70 its likely u have new usb hub with official car play and AA. You'll need to buy and install old usb hub to downgrade fw below fw70, else you'll risk bricking your $1,200 cmu.

 

·
Registered
2018 CX-3
Joined
·
10 Posts
@dreckgos all tweaks, mod, upgrade/downgrade at your own risk. Nobody takes irresponsibility for your own decision/action. If you're worry or have no idea what you're doing then stop and leave it alone as its not recommend for you to tinker with your system.

Now If your car is straight from the factory brand new with fw70 its likely u have new usb hub with official car play and AA. You'll need to buy and install old usb hub to downgrade fw below fw70, else you'll risk bricking your $1,200 cmu.

Hmmm interesting!

My CX-3 came with the old hub but I had it upgraded a couple of months ago to have native AA. But now I just recently did the Serial Tweak and left the serial interface alive just in case (through a usb cable on my glove box). But despite all efforts, AA touchscreen while driving or parked does not work at all. Unless I run the AA available from the AIO Tweaks installation, which in turn, disables the oem AA. Touchscreen works but it's a bit slow sometimes.

But what if I install the old USB hub and downgrade to V59 and try it like that? Would it be better in any way?

Thanks!
 

·
Registered
Joined
·
1,539 Posts
Enabling touch for the native AA will not work - it`s unkown how to do it. Several people tried a lot.

If you do the downgrade-thing, touch can be enabled for AIO AA and will work. But I would recommend to keep the new hub and native AA (more usb-charging-power at the marked AA/CP port - up to 2.1A instead of 0.5A) and native AA is more stable.
 

·
Registered
2018 CX-3
Joined
·
10 Posts
Enabling touch for the native AA will not work - it`s unkown how to do it. Several people tried a lot.

If you do the downgrade-thing, touch can be enabled for AIO AA and will work. But I would recommend to keep the new hub and native AA (more usb-charging-power at the marked AA/CP port - up to 2.1A instead of 0.5A) and native AA is more stable.
In fact, AIO AA with touchscreen can be used with the native USB port via Tweaks. It will automatically disable the native AA implementation and allow AIO AA with touch. The issue I'm having now is that any audio coming from AIO AA is not passed through automatically. For it to work (somewhat) is to first go to the Media menu and select Bluetooth as audio input. But now the problem with that is audio latency. But at least touchscreen input works ok with the occasional blank screen here and there while going back and forth between AIO AA and Mazda's system.
 

·
Registered
Joined
·
210 Posts
In fact, AIO AA with touchscreen can be used with the native USB port via Tweaks. It will automatically disable the native AA implementation and allow AIO AA with touch. The issue I'm having now is that any audio coming from AIO AA is not passed through automatically. For it to work (somewhat) is to first go to the Media menu and select Bluetooth as audio input. But now the problem with that is audio latency. But at least touchscreen input works ok with the occasional blank screen here and there while going back and forth between AIO AA and Mazda's system.
@SergioNayar
Most of your issues has been fixed/resolved with AA Tru_go V1.15 please post/report your results over --> AA Tru_go V1.15 FW59.00.504-FW70.00.xx-Fw70.00.352

Thank you.
 

·
Registered
Joined
·
1,539 Posts
The kudos for AA Tru_go have to go to Radarwild only. I only tested for the (unfortunately unsuccessful) trials to enable touch at official Mazda AA.
 

·
Registered
2018 CX-3
Joined
·
10 Posts
Brief update: Finally I was able to install AA Tru_go V1.15 FW59.00.504-FW70.00.xx-Fw70.00.352 onto my Mazda CX3 with .352 FW. and it really enables touch and sound however, the system lags to the point of being unusable. Any pointers or ideas on how to improve latency even while using USB? (I'm not interested on WiFi tethering).

Thanks and great work!
 

·
Registered
2018 CX-3
Joined
·
10 Posts
unplug the nav-sd-card
I have no nav-sd card inserted.

I am also using a high-quality USB cable and my phone's OEM cable to assure high-speed communications.

I'm going to give AA Tru_go V1.15A FW59_504-FW70_352 AV10 beta.zip Android 10 version a try, since I'm in Android 10 actually.

Also, I will uninstall any unnecessary Tweaks I currently have installed.

Thanks for the heads-up Tristan!
 
1 - 18 of 18 Posts
Top