2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

Android Auto suddenly stopped working and no longer starts

17248 Views 13 Replies 5 Participants Last post by  FlexoRodriguez
So I've had Android Auto running for a bit over a year now. I have AA 1.08 installed on my 2015 Mazda3 with firmware 59.00.441A-NA. Just yesterday I upgraded my Sony Xperia X Compact from Android 7.1.1 to Android 8.0.0. I had to reboot the phone and CMU in order to get it to connect the first time, but then it worked normally heading home from work and then again heading to work this morning. Then all of a sudden it has completely stopped working at all.

I've tried rebooting both the phone and the CMU several times. The CMU never seems to get a signal to start AA. Even if I manually start AA from the CMU, it just sits there with a blank window never doing anything. I've tried starting the headunit server from the AA Developer options on the phone, enabling and disabling USB debugging, clearing USB debugging credentials, and clearing the list of authorized cars in AA. None of it seems to make a difference.

I did just update the Google app, but when I try to uninstall the latest updates, AA fails to launch on the phone and then downloads the latest Google app anyway. That's the only other thing I can think of because it worked fine after the Android 8.0.0 update.

Has anyone else started having problems like this recently?
1 - 7 of 14 Posts
I did not clear AA's data nor cache, but it suddenly started working again this morning. The only things that I have done are reboot the phone since my testing last night (because it was still showing as connected to my car) and insert the Navigation SD card back into the car (which I'm not sure if this is connected at all). Suddenly I was prompted to add my car to AA and after a few connection retries it finally launched on the CMU. So I'm not really sure what changed because nothing was working last night despite several reboots of both systems. The only Google application that updated since then was Gmail. Facebook Messenger was also updated (that does have the ability to forward messages to AA, but I wouldn't think it would interfere with the connection). So I'm rather at a loss. I just hope it keeps working as it's been fine up until this point.
I've noticed that sometimes the phone doesn't disconnect from the car correctly. There will be a notification that "Google Play Services is connected to your car". When it's working correctly, this will clear itself when you disconnect it from the car or turn the engine off. I've had better luck if I unplug the phone before shutting off the engine. When the notification is up, it won't start AA on the CMU. Sometimes rebooting the phone will clear it. Sometimes a complete shutdown of the phone, then waiting a few seconds, then starting it again will work. However it's all inconsistent now. I'll go from it working great for a couple days to not working at all the next. There may also be some conflict with Google Wear as I also have a Pebble Time and the Pebble app wanted Google Wear installed, but the watch itself is unable to connect through Google Wear (go figure).

I'm planning to upgrade to the Sony Xperia XZ2 Compact once it becomes available, but I'm worried that there may be another bluetooth connectivity issue like there was when I went to the XC. That required a firmware update of the CMU to 59.00.441A-NA in order to maintain a stable bluetooth connection. I hope that the same thing doesn't happen again next time.
See less See more
I'll have to install that when it becomes available. My updates are often a few weeks later because I installed the European firmware so that I could enable the fingerprint reader (which I still find dumb on Sony's part). Hopefully it resolves the issue permanently because this not knowing whether it's going to work or not when I need it is getting very annoying.
I'm still having trouble with this being intermittent and not having a reliable way to make it work. Many people having the issue said that turning on USB debugging made it work, but I already had it on. Sometimes if I turn off debugging, then turn it back on, unpair the car and phone from each other, and reboot both systems, then it might come up and work again. However it's not guaranteed and is a chore to try and do every time I go to drive somewhere.

There is still no 34.4.A.2.32 firmware update for my phone and this is really getting on my nerves. Being tied to an OS update is incredibly frustrating how far apart updates are from each other. At this point, I'm considering flashing a different region firmware if it will correct the problem.
@mil can you confirm that this update corrected the issue for you? And does it still work after a reboot? Thanks.
I rebooted the phone today and it still connected to the car without problems, twice. I'm guessing you are on the CE1 firmware? For some reason it seems to get updated much slower than the US one, although the Oreo update for US wasn't exactly quick either.
I think it was either CE1 or CE5, but I can't remember which. I did it a year ago and chose one of the Generic European ROMs because it didn't have any carrier bloat and kept LTE labeled as "LTE" and HSPA+ as "H+". Although it looks like the Generic UK firmware already has 34.4.A.2.32. I'm debating doing a dirty update and just clearing the cache to try an preserve my data. I hate doing a factory reset as I consider that the nuclear option, but this is affecting me on a daily basis now.

I've really come to hate this phone and it seems to have had problems since the Nougat update and often gets into weird states where it's unresponsive for several seconds. It also overheats sometimes, although not nearly as much now as when it was first updated. My old Xperia Z3 Compact would get sluggish, but it wouldn't freeze up like this. I'm waiting for the Xperia XZ2 Compact to come out in the US and plan to get that. Although that has me worried because it uses a new bluetooth chip and when that happened from the Z3C to the XC, my CMU wouldn't maintain a stable connection until it was upgraded to 59.00.441A-NA. So I'm fearing I might have to upgrade that again for the new phone.

I'm going to try going back to AA 2.9 and see if that makes a difference. If it does, that will probably hold me over for a bit.
See less See more
Downgrading to 2.9 had no effect. However, doing the dirty flash over the phone's firmware does appear to have done the trick. I haven't had much time to test it thus far, but it worked right away this morning. I'll do some more experimenting with it when I get some time and see if it's working like normal again.

I ended up flashing the Custom UK 34.4.A.2.32 firmware. They don't have .50 yet, but were a month ahead of the CE1 firmware that I confirmed I was on. I was worried that I may have accidentally overwrote my TA partition. It appears to be intact, but Remote Play is giving me issues over the Internet. So I hope I didn't do something wrong.

After some thorough testing this appears to be back to normal again. I'm going to try updating back to 3.1 again and see if it stays the same.
1 - 7 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.