2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
My daughter was driving to her apartment yesterday and as she got ready to pull in all the warning lights came on and the power steering went. I drove to check on it this morning and the battery was completely dead. Battery was 4 years old and being my daughters car i changed it out for a new one anyway. Started car up and after just a few seconds all the lights come back on. I'm thinking bad alternator. Anyone else have this happen on a gen 2? Her car is a 2010, my old car actually.
 

·
Registered
Joined
·
2 Posts
My daughter was driving to her apartment yesterday and as she got ready to pull in all the warning lights came on and the power steering went. I drove to check on it this morning and the battery was completely dead. Battery was 4 years old and being my daughters car i changed it out for a new one anyway. Started car up and after just a few seconds all the lights come back on. I'm thinking bad alternator. Anyone else have this happen on a gen 2? Her car is a 2010, my old car actually.
Did you ever figure it out? I may have the answer. I just went through this with my car
274996
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
Found out the alternator is putting out 20 volts. The voltage regulator in it is gone out. In the process of changing that out first. I am hoping that the over voltage was just throwing the system in to chaos.
 
1 - 4 of 4 Posts
Top