2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I have the Bose hatchback GT and have a 64 GB flash with all my music plugged in. Every album has a folder that contains the album cover art but only some of the covers actually display the album cover on the screen. How do I get all my album covers to display. Can some one provided a step by step method to accomplish this?

thanks.
 

·
Registered
Joined
·
6 Posts
Hi ouc,
I actually experience the same issues as you are having.
After doing some searching on the internet, I found out that it's due to the ID3 Tag version.
I believe the ID3 Tag version needs to be v2.3 or higher.

If you are using itunes, I think it saves the ID3 Tags to v2.2 by default.
But you can convert the ID3 Tags to v2.3 or v2.4 within the itunes software.
To do this, you must be in the Songs list view.
Right-click on the songs you wish to convert and select "Convert ID3 Tags...".
A dialogue box will then appear where you can select the version you wish to convert to.
I selected v2.4 for all my songs and this rectified the problem.

Hope this helps.
 

·
Registered
Joined
·
6 Posts
Hi All,
I'll just share some other information that I have just figured out recently regarding the infotainment system and the usb port.

When I first used the usb flash drive, I only placed about 5 different artists and their albums onto the drive as a test run. This worked fine so I then deleted these off my usb drive then copied my entire music collection onto the drive.

But then the infotainment system kept showing the songs in the list twice for the original 5 artists that I used for the test run. The infotainment system seems to remember that past songs on the usb and retains them in the list despite the original file no longer being located on the usb.

I found that if you go to "Settings", move to the "System" tab, scroll down and select "Music Database Update", the system will refresh its memory and remove the double listed songs.
The "Music Database Update" is meant to be for updating Gracenote but it seems to also refresh the systems memory.

Just something I found recently which I hope may help some others with similar issues.
 

·
Registered
Joined
·
2 Posts
Hi there, I am currently on infotainment ver. 29 in europe. I would like to ask you if you get any artwork via bluetooth connection?

I am using an iPhone 4 and my iTunes library holds the artwork in ID3 tag ver. 2.3

Best regards from Czech Republic
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
Hi ouc,
I actually experience the same issues as you are having.
After doing some searching on the internet, I found out that it's due to the ID3 Tag version.
I believe the ID3 Tag version needs to be v2.3 or higher.

If you are using itunes, I think it saves the ID3 Tags to v2.2 by default.
But you can convert the ID3 Tags to v2.3 or v2.4 within the itunes software.
To do this, you must be in the Songs list view.
Right-click on the songs you wish to convert and select "Convert ID3 Tags...".
A dialogue box will then appear where you can select the version you wish to convert to.
I selected v2.4 for all my songs and this rectified the problem.

Hope this helps.
Thank you for these instructions. The reason I've taken so long to reply is because I was working on this. I converted all song to v2.4 successfully. Then I lost all the art work and folder that contained the art using Itunes (I'm new to Itunes). Then I had to go out find over 100 album covers that Itunes didn't find and add them to the songs. I only did a preliminary test and it appears that some art that was there does not show up or some that wasn't there now shows up. Should the art show up immediatly or will there be some sort of loading delay because I have over 30 Gb of songs?

thanks for the help, I really appreciate it.
 

·
Registered
Joined
·
297 Posts
Also make sure your plugging it into port 2 USB as #1 will not allow album info to display. Also in the user manual.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
Also make sure your plugging it into port 2 USB as #1 will not allow album info to display. Also in the user manual.
Port 1 does display art. I tried port 2 but still the same thing. the art is there because I see it when I open in itunes. Somehow, some, and not exactly sure how many, are not showing up.
 

·
Registered
Joined
·
6 Posts
Hi there, I am currently on infotainment ver. 29 in europe. I would like to ask you if you get any artwork via bluetooth connection?

I am using an iPhone 4 and my iTunes library holds the artwork in ID3 tag ver. 2.3

Best regards from Czech Republic
Hi,
I can confirm that I don't get the album art to appear when streaming music over bluetooth.
(I'm using an iPhone 5).

The bluetooth protocol has a list of subset profiles for various functions. For example:
Advanced Audio Distribution Profile (A2DP)
Audio/Video Remote Control Profile (AVRCP)
etc.

I believe there is a profile for video/images but is not supported by the infotainment system.
This seems to be common place in the automotive industry (not just Mazda).
I assume it is not supported because if was, it would allow playing of videos which would be a driving distraction.

This is one reason why I like to use the usb for my music so that the album artwork appears on the screen (the other reason is for slightly better audio quality).
 

·
Registered
Joined
·
6 Posts
Thank you for these instructions. The reason I've taken so long to reply is because I was working on this. I converted all song to v2.4 successfully. Then I lost all the art work and folder that contained the art using Itunes (I'm new to Itunes). Then I had to go out find over 100 album covers that Itunes didn't find and add them to the songs. I only did a preliminary test and it appears that some art that was there does not show up or some that wasn't there now shows up. Should the art show up immediatly or will there be some sort of loading delay because I have over 30 Gb of songs?

thanks for the help, I really appreciate it.
No worries mate. Glad to help where I can.
I'm not sure why the artwork is still not showing up on some of your music. Maybe double check that the tags were successfully converted to v2.4 for the songs not showing the artwork.
Just right-click on one of the problematic songs in itunes and select "Get Info".
The first tab will shown the general properties where it'll state the I.D. Tag version for confirmation.
Maybe also check what type of file the artwork is for those songs.
I use .jpg files without any problems.

The artwork should show up almost immediately.
The artwork sometimes takes a second or two to load and as it does, it gradually appears from the top down.
This is what I experience with my music collection which is 21 GB in size.
 

·
Registered
Joined
·
41 Posts
Hi,
I can confirm that I don't get the album art to appear when streaming music over bluetooth.
(I'm using an iPhone 5).

.....

This is one reason why I like to use the usb for my music so that the album artwork appears on the screen (the other reason is for slightly better audio quality).
For me it's an interesting tradeoff. I find that skipping tracks is much, much quicker over bluetooth than USB for some reason (slowed by loading the image data perhaps?). Reminds me of why I prefer cable to satellite TV, though in this case the wired and wireless media are switched. :)

I agree that audio quality is slightly better over USB, but you can't beat the convenience of never having to take your phone (or keys) out of your pocket.
 

·
Registered
Joined
·
212 Posts
For me it's an interesting tradeoff. I find that skipping tracks is much, much quicker over bluetooth than USB for some reason (slowed by loading the image data perhaps?). Reminds me of why I prefer cable to satellite TV, though in this case the wired and wireless media are switched. :)

I agree that audio quality is slightly better over USB, but you can't beat the convenience of never having to take your phone (or keys) out of your pocket.
I don't find in inconvenient leaving the USB stick in the car all the time, and I don't find it sluggish skipping through tracks either. What I do find inconvenient is having to carry that big fob around in my pocket, I think if much rather just have a key.
 

·
Registered
Joined
·
86 Posts
Does anyone know why XM Radio does not display the album art? The album art displays when I use Pandora or HD radio but not with XM. Seems odd. Is this just me or is this normal? FYI, I'm on Ver. 28.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #14
No worries mate. Glad to help where I can.
I'm not sure why the artwork is still not showing up on some of your music. Maybe double check that the tags were successfully converted to v2.4 for the songs not showing the artwork.
Just right-click on one of the problematic songs in itunes and select "Get Info".
The first tab will shown the general properties where it'll state the I.D. Tag version for confirmation.
Maybe also check what type of file the artwork is for those songs.
I use .jpg files without any problems.

The artwork should show up almost immediately.
The artwork sometimes takes a second or two to load and as it does, it gradually appears from the top down.
This is what I experience with my music collection which is 21 GB in size.
When i go to Get Info, the art is there. How do I check what type of file when it's in the tag? Could it be that the file size is too big? running out of ideas.
 

·
Registered
Joined
·
212 Posts
When i go to Get Info, the art is there. How do I check what type of file when it's in the tag? Could it be that the file size is too big? running out of ideas.
Try testing out a different brand of usb stick. While I was testing for one that didn't freeze up on me, I came across one stick that did have garbled artwork. I will also note that they have all been 32gb usb sticks, almost completely full. Nothing has been changed with the tags, it was simply the usb stick that caused the issue.
 

·
Registered
Joined
·
117 Posts
I used a SW program called MediaMonkey and embedded the album art into each song/album. I'm not sure if having the jpeg in the folder will work. Every song has worked perfectly since I did that. I also read somewhere the infotainment system doesn't like variable rate songs. I have not seen a problem with that but I haven't run a specific test.

I have some audiobooks but they just show up in the folder option. I haven't been able to find any special way to make them work right. I just wish the system would remember where it was in the audiobook. Sometimes it does and sometimes it doesn't. Mazda still has some bugs to work out but they system is much better then where it started.
 

·
Registered
Joined
·
15 Posts
I used a SW program called MediaMonkey and embedded the album art into each song/album. I'm not sure if having the jpeg in the folder will work...
I suggested similar on another thread about sporadic artwork. I wondered if the system picks up embedded art but not the image file in the folder.

I have always detested iTunes. Stuff like the way it handles album art, renames everything, messes about with stuff, just rattles my cage. I use an application called TagScanner to update my media files and find it brilliant. It's free (but you can donate to them) and lets you tweak everything in the file/tag. That way, I know exactly how my media is set up! :cool2:
 

·
Registered
Joined
·
3 Posts
Just a quick question about this album art....
I have an iPhone 5s, ios 8.1.2 and I mostly plug my phone into the usb charger. When I play music, either through the phones stored music or through spotify, the album art comes up as a bunch of vertical lines. The colors are all proper, but it's just a series of colorful lines that want to make up the album art.... but don't.

Anyone else having this issue?
I also bought a PNY 64gb USB stick (usb3.0), formatted it and the car won't even acknowledge that it's plugged in?
 
1 - 19 of 19 Posts
Top