2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1 (Edited)
I drive a 2010 Mazdaspeed 3 and my A/C was working fine one evening and the next day it did not. No incident to cause this to happen or unusual circumstance. When I turn on the A/C on the console and the light will sometimes turn on and the compressor may go on for a second but then the light and compressor shuts off. It seems electrical because in the past I could turn on the A/C and the light would stay illuminated if the car wasn't completely on even though the compressor was not engaged whereas it now shuts off quickly.

I am not sure if this is related, but after having some work done the ABS/TC lights are on and the night it stopped working the car had what felt like a vacuum leak momentarily where the car sputters and loses power but no other disturbance since despite going on a long trip this weekend.

Everything looks normal under the hood and the fuses all appear to be fine.
 

·
Registered
Joined
·
1 Posts
My air conditioner also lives its own life. Turns on and off when it wants to. I'm tired of this. Moreover, I reread a lot of forums and a lot of different information on this topic . For some reason, none of the suggested methods worked with my air conditioner. Maybe it's because I'm doing something wrong. Thus, I will have to allocate extra money to repair my air conditioner. And I hope I'll find the best aircon repair servicing to help me solve this issue.
 
1 - 3 of 3 Posts
Top