2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hello,
i have tried to instal some tweaks with AIO in mazda 3 with 59.00.504 ver and in cx5 with 70 ver and it didn't work at all like in my mazda that have 56 ver.
after some checking i undestand that i have to do it in other way not like for 56 ver .
can someone please explain me what i need to do ?
thank you !
 

·
Registered
Joined
·
4 Posts
I have V70.335 however aio tweaks talks about update.up file? Does anyone know how or where can I get this update.up file? Also I'm assuming the serial connection and writing the files through Putty process is same as V59 just that there's an additional update.up file besides XX folder, is that right?
 

·
Registered
Joined
·
1,186 Posts
The required FW update files of .335 or .354 for NA region can be found here.

Read www.mazdatweaks.com/id7 and the ID7v2 thread for the ID7v2 process, which is necessary at .335

It is a little different from the old ID7 process of FW 59. Wiring is the same. You need to do a FW update to .335 or .354 (not .367) and at the end paste the commands (do not restart the car/mzd before pasting the commands).
 

·
Registered
Joined
·
4 Posts
The required FW update files of .335 or .354 for NA region can be found here.

Read www.mazdatweaks.com/id7 and the ID7v2 thread for the ID7v2 process, which is necessary at .335

It is a little different from the old ID7 process of FW 59. Wiring is the same. You need to do a FW update to .335 or .354 (not .367) and at the end paste the commands (do not restart the car/mzd before pasting the commands).
Thanks for your quick reply @tristan.

One last question if you can answer it for me before I roll with making those updates is :

When the fw update is finished, instruction says I need to copy and paste certain command into putty console. However the instructions listed on v59 version related thread states three more additional steps:

1. Reboot Mazda CMU by holding the Nav + Mute button for 10+ seconds.
2. Input user and push Enter
3. Input jci and push Enter

Do I need to perform these 3 steps on v70.335+ serial connection workflow or not? Also the link you've given for fw file download doesn't have v354 instead it has 352B, is it safe to assume that updating fw to 352B will cause no harm or it's an untested version of the fw with aio tweaks.
 

·
Registered
Joined
·
1,186 Posts
No, you do not need to erform these 3 steps - you should not! Do not reboot the CMU/MZD after the FW update is done. 1st paste the commands in Putty! If you reboot before pasting the commands, you have to do the FW update again!

Sorry, then I mixed .354 and .352 up. It is .352. And I installed some tweaks from AIO without a problem to .352 EU.
But do not update to .367 NA, as with that one ID7v2 does not work.
 

·
Registered
Joined
·
4 Posts
Thanks @tristan

You're the man! Happy 4th of July to you.
Hey Tristan,

So I gave it a shot but could never get it to work, once the serial connection is established, it goes on a loop, with "Login timed after 60 sec" message and then it repeats the same command. When you did the same steps, do you recall how much time it took for the update?

What I did so far is after establishing the serial connection, I'm launching putty/SecureCRT and turn the car into acc mode and the text starts flying by but going by the logs as it gets in a loop and can't move past certain stage, I'm assuming there are one of the 2 things going wrong, for some reason it's not able to login into CMU or my wiring is gone. However if my wiring is wrong which I'm almost certain is not, I shouldn't see the messages writing into CMU

I'm on v70.335c nan
 

Attachments

·
Registered
Joined
·
1,186 Posts
If I were you, I would check if my cables are connected correctly: Do not go to ACC (ACC/IGN/Engine off), as then the text is flying by slower. Connect via putty. Hit enter. You should be requested for username/password. If that is not happening, your TX wire is not connected corretly, as no input is possible.

Are you sticking to www.mazdatweaks.com/id7 ? Only try to paste ID7v2 commands in putty directly after you did a FW update.
 

·
Registered
Joined
·
1,186 Posts
See the ID7v2 thread for more details and photos how it looks like in putty:

ID7v2 installation after entering the commands took about 3 minutes I guess. Maximum.
 
1 - 11 of 11 Posts
Top