2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1321 - 1336 of 1336 Posts

·
Registered
Joined
·
7 Posts
Summing up my story.
Thanks all for help. My new/used radio I bought and I updated to FW 59.00.449 works perfectly now.
I give up on my original one. I couldn't deal with it via serial on 70.00.335 following ID7v2 so I downgraded it to 70.00.021 hoping ID7 would be easier. No success. Putty doesn't show anything on CP2102. It shows text using PL2303 but no commands go through. Connection must be good. I tried using CP2102 and PL2303 HX. I think it's time to give up. Don't what did wrong. Checked on CP2102 - RX&TX receives/sends signals.
Anyway, thanks guys for your engagement and I'm happy to use android auto now - it still cost me 100$ in total instead of 350$ they want for it in service. Thanks to you (y)
 

·
Registered
Joined
·
3 Posts
Hello, I can't seem to get the autorun scripts to run on a serial connection. I think the error said no such file or directory in putty. Does that mean i'm not logged in? FW is 59.00.504
 

·
Registered
Joined
·
1,199 Posts
1. Have you tested it with a FAT32 USB Stick with a AIO tweak on it?
2. Are you sure to use the files and instructions from www.mazdatweaks.com/serial (and not the ID7v2 from www.mazdatweaks.com/id7)?
3. When do you see this error message? What exactly did you do before?

Can`t remember ID7 for your FW 59.00.504 properly, but at ID7v2 for later FW there are some error messages with text like "no such file or directory" - but you have to ignore them, as also when you see them, all is fine. Perhaps its the same with ID7.
 

·
Registered
Joined
·
3 Posts
1. Have you tested it with a FAT32 USB Stick with a AIO tweak on it?
2. Are you sure to use the files and instructions from www.mazdatweaks.com/serial (and not the ID7v2 from www.mazdatweaks.com/id7)?
3. When do you see this error message? What exactly did you do before?

Can`t remember ID7 for your FW 59.00.504 properly, but at ID7v2 for later FW there are some error messages with text like "no such file or directory" - but you have to ignore them, as also when you see them, all is fine. Perhaps its the same with ID7.
I figured it out, thank you!
 

·
Registered
Joined
·
1,199 Posts
I just checked. When I did the ID7v2 serial access the last two times, I also got the messsage "no such file or directory". Thats usual and already described by Trezdog44 at ID7 Recovery v2 as "Don’t worry about the error messages and after a minute turn ACC off and on again."

Here you can find my screenshots of putty (ID7v2)... Post 1 / Post 2 - both times it worked fine. Just reboot afterwards and test with a AIO Tweak USB stick.

Unfortunately I do not have any screenshots of the ID7 serial access process anymore for comparsion.

Edit:
Are you sure to have used the ID7 files from AIO or www.mazdatweaks.com/serial (use them for FW 59.00.502 - 70.00.100). Make sure not to use the ID7v2 files from www.mazdatweaks.com/id7 which are for 70.00.335 + 70.00.352 only (as far as I know).
 

·
Registered
Joined
·
2 Posts
I just checked. When I did the ID7v2 serial access the last two times, I also got the messsage "no such file or directory". Thats usual and already described by Trezdog44 at ID7 Recovery v2 as "Don’t worry about the error messages and after a minute turn ACC off and on again."

Here you can find my screenshots of putty (ID7v2)... Post 1 / Post 2 - both times it worked fine. Just reboot afterwards and test with a AIO Tweak USB stick.

Unfortunately I do not have any screenshots of the ID7 serial access process anymore for comparsion.

Edit:
Are you sure to have used the ID7 files from AIO or www.mazdatweaks.com/serial (use them for FW 59.00.502 - 70.00.100). Make sure not to use the ID7v2 files from www.mazdatweaks.com/id7 which are for 70.00.335 + 70.00.352 only (as far as I know).

Oh, you are saying I'm using the wrong version of the autorun files? I used the files from the archive in the serial page you linked above, under "Manual Method." That file name indicates its version 3. Where can I find version 1, which it sounds like the one I need?
 

·
Registered
Joined
·
1,199 Posts
ID7 = filename v3 in the link is fine for FW version up to/including 70.00.100. I do not know which one you have.

Have you tested if you can install AIO tweaks with one or more FAT32 formatted usb sticks? I would recommend this.
 

·
Registered
Joined
·
2 Posts
I just checked. When I did the ID7v2 serial access the last two times, I also got the messsage "no such file or directory". Thats usual and already described by Trezdog44 at ID7 Recovery v2 as "Don’t worry about the error messages and after a minute turn ACC off and on again."

Here you can find my screenshots of putty (ID7v2)... Post 1 / Post 2 - both times it worked fine. Just reboot afterwards and test with a AIO Tweak USB stick.

Unfortunately I do not have any screenshots of the ID7 serial access process anymore for comparsion.

Edit:
Are you sure to have used the ID7 files from AIO or www.mazdatweaks.com/serial (use them for FW 59.00.502 - 70.00.100). Make sure not to use the ID7v2 files from www.mazdatweaks.com/id7 which are for 70.00.335 + 70.00.352 only (as far as I know).
I just checked. When I did the ID7v2 serial access the last two times, I also got the messsage "no such file or directory". Thats usual and already described by Trezdog44 at ID7 Recovery v2 as "Don’t worry about the error messages and after a minute turn ACC off and on again."

Here you can find my screenshots of putty (ID7v2)... Post 1 / Post 2 - both times it worked fine. Just reboot afterwards and test with a AIO Tweak USB stick.

Unfortunately I do not have any screenshots of the ID7 serial access process anymore for comparsion.

Edit:
Are you sure to have used the ID7 files from AIO or www.mazdatweaks.com/serial (use them for FW 59.00.502 - 70.00.100). Make sure not to use the ID7v2 files from www.mazdatweaks.com/id7 which are for 70.00.335 + 70.00.352 only (as far as I know).
I just checked. When I did the ID7v2 serial access the last two times, I also got the messsage "no such file or directory". Thats usual and already described by Trezdog44 at ID7 Recovery v2 as "Don’t worry about the error messages and after a minute turn ACC off and on again."

Here you can find my screenshots of putty (ID7v2)... Post 1 / Post 2 - both times it worked fine. Just reboot afterwards and test with a AIO Tweak USB stick.

Unfortunately I do not have any screenshots of the ID7 serial access process anymore for comparsion.

Edit:
Are you sure to have used the ID7 files from AIO or www.mazdatweaks.com/serial (use them for FW 59.00.502 - 70.00.100). Make sure not to use the ID7v2 files from www.mazdatweaks.com/id7 which are for 70.00.335 + 70.00.352 only (as far as I know).
Hi Tristan,

If i want to tweak, current version .335
So I need to serial access and upgrade to .352 right?
Do i need to login?
If yes, what user name and password need to use?

Kindly help.. confuse..
 

·
Registered
Joined
·
2 Posts
You need to do a FW "update" - it can be to the already installed .335 or to .352.

If you want to check if the serial access works, before doing the FW update, use user/jci, as stated at www.mazdatweaks.com/serial or try cmu/jci as stated at www.mazdatweaks.com/id7. For the serial access during/directly after the FW update I do not think that you need to login.
Thanks a lot.. 😉
 

·
Registered
Joined
·
2 Posts
You need to do a FW "update" - it can be to the already installed .335 or to .352.

If you want to check if the serial access works, before doing the FW update, use user/jci, as stated at www.mazdatweaks.com/serial or try cmu/jci as stated at www.mazdatweaks.com/id7. For the serial access during/directly after the FW update I do not think that you need to login.
By "update" does that also mean I can downgrade the currently unusable .367 down to .352 using the stock update process and run the ID7v2 commands over serial before rebooting in order to enable USB tweak?
 

·
Registered
Joined
·
2 Posts
That should work, yes.
Great thank you! I was able to do this successfully and enable USB autorun to install the driving touchscreen and no warning tweaks. Originally I was doing this to enable touchscreen in the native Android Auto with the new USB hub, however I was dismayed to find that this is not supported. 😔 On our Honda AA natively uses touchscreen, so it's a bit of a jolt using the physical controls only. Oh well, we'll have to get used to it and hope this changes in the future!
 
1321 - 1336 of 1336 Posts
Top