2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1141 - 1160 of 1207 Posts

·
Registered
Joined
·
136 Posts
So I already did the serial connection on 59. and have access. Is there not a way to update to 70. without doing another serial connection. ID7 is saying you need to do a serial connection. Pain in the a$$. The search on this thread is horrible, cant find anything. can someone tell me where to find the Diff from 59. to 70.
 

·
Pretty Cool Dude
Joined
·
281 Posts
So I already did the serial connection on 59. and have access. Is there not a way to update to 70. without doing another serial connection. ID7 is saying you need to do a serial connection. Pain in the a$$. The search on this thread is horrible, cant find anything. can someone tell me where to find the Diff from 59. to 70.
If you did serial already AND installed ID7 then you are fine to upgrade to V70. But do NOT upgrade to V70.00.335 because otherwise you will have to follow the instructions @ https://mazdatweaks.com/id7/ which would essentially require doing Serial mod again
 

·
Registered
Joined
·
4 Posts
I like to make a permanent wirering to future updates (Only the wirering not connectet CP2102 module). So i don't have to take the car appart again.

How do you attatch the wiring in CMU connector. Do you have a linke where to buy pins to put in the connector (2S (top) and TX port to 2T (bottom))?
 

·
Registered
Joined
·
12 Posts
I like to make a permanent wirering to future updates (Only the wirering not connectet CP2102 module). So i don't have to take the car appart again.

How do you attatch the wiring in CMU connector. Do you have a linke where to buy pins to put in the connector (2S (top) and TX port to 2T (bottom))?
For example, https://www.hi-1000ec.com/product/1302

I’m sure there are other sources as well. I’ve seen someone found on AliExpress or somewhere but they are sold in a pack of 50 or 100 or something.

Cheers,
Yushi


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
644 Posts
@Dan Nielsen : I figured out how to do this and which pins to use. I have connected the 2 wires permanently and have the wires near the fuse box in the drivers legroom (or put them behind the glove-box).
See post here - including Aliexpress-Link. (50 pieces for approx. 12 USD)
But keep in mind to NOT permanently connect the USB-Adapter, as this could drain your battery. Because as soon as the adapter is connected to the CMU, its receiving data and uses power.
 

·
Registered
Joined
·
2 Posts
The tweaks are not dependent on language so it should work fine.
Thank you for you help Albuyeh

I am now having issues with serial connection well the CP2102 I've tried 3 different computers and each time I install the software for the CP2102 USB TTL UART it always comes back with error code 10 wont start, I have uninstalled drivers and tried windows 7 instead of windows 10 but always get the same error message no matter what version of windows or which 1 of my PC's Im using.....anyone else had this issue..?
 

·
Registered
Joined
·
136 Posts
@Trezdog44
Ok if anyone else is having this problem where the Service Due is not counting down:

Fix: download new AIO & re enable touch screen while driving. FIX the problem :)
Sad that I lost my compass. I know if I want it back I would loose puting input of Navi and it disables touch. That's my understanding.

#service #due #not #working #countdown
 

·
Registered
Joined
·
2 Posts
We just bought a preowned Mazda 3 (2014) which has OS 56.00.511 EU N installed. The previous owner installed Android Auto and I'm not sure what else. We would like to take the car to the local dealership to install Carplay hardware and the latest firmware. Should we remove the tweaks with mazdatweaks.com or is they a simplier way to factory reset the head unit? Or is it fine to leave these there and the dealership firmware upgrade will remove everything? Is there any chance that the head unit gets bricked during tweak uninstall or during the firmware upgrade if we leave the tweaks?
 

·
Registered
Joined
·
644 Posts
@mm00: I would suggest to use AIO (mazdatweaks.com) and uninstall all tweaks via AIO before taking it to the dealer. From my point of view thats the most secure/best option. Usually a FW update removes tweaks, but I am not sure, if all are removed completely - so just use AIO`s burger menu (top left), click "uninstall all" and compile, copy to USB, put USB in car, perform the uninstallation. Done.
 

·
Registered
Joined
·
644 Posts
Correct! I would not use the fully system restore when I have tweaks installed, as I remember that there might occur some problems - perhaps this is fixed already, but there somewhen were problems with this AIO option. So I strongly recommend only to use "uninstall all" - which only ticks all checkboxes for you - you could do this also by yourself.
 

·
Registered
Joined
·
3 Posts
Hey guys. I've got a Mazda CX5 2016 and my goal is upgrading to Car Play.

My current OS version is 51.00.350. I realize I eventually have to move to a 70s firmware before installing the kit (which I plan to buy off eBay).

My question is regarding the AIO tweaks and if its worth it for me to do that first. I think I'd have to upgrade to something before 59.00.502 and install the Autorun script before migrating to 70.00.100.

Would this give me the ability to use carplay properly, and tweak only through USB and without using a serial connection?
 

·
Registered
Joined
·
644 Posts
@HBP: Yes it would. Everything else is correct. And yes you have to install FW 70 first, before installing the cables and usb hub for the original Mazda AA/CP. Good luck.
 

·
Registered
Joined
·
4 Posts
hi
I updated my car to V70.00.335 after that I tried to install autorun recovery and I used
" user " and " jci " as username and password but the message show "login incorrect",
I downgraded the Cmu to 59.00.504 the same message is show again, what is problem?
please help
 

·
Registered
Joined
·
2 Posts
hi

I updated my car to V70.00.335 after that I tried to install autorun recovery and I used

" user " and " jci " as username and password but the message show "login incorrect",

I downgraded the Cmu to 59.00.504 the same message is show again, what is problem?

please help


I have the same issue on a 2016 CX-5. After getting the tweaks installed on the V70.000.100 I decided to continue on and upgrade to 335. The instructions say to ignore the errors but are not specific, which is a problem if more serious error comes up.

The instructions also say:
  • If it does not work, keep the serial console open and try to login with cmu/jci and run sh /mnt/data_persist/dev/bin/autorun.
Now both user and cmu logins fail.

Below is the console output at the end of the upgrade to V70.000.335.

The squashfs wasn’t created and the password file was not updated. Are we now locked out for good or do we just need to reflash to get access to the shell at the end of the update?

272953
 
1141 - 1160 of 1207 Posts
Top