2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1861 - 1880 of 8776 Posts

·
Registered
Joined
·
1 Posts
Hello all :)

First of all i would like to thank you guys for all this awesome teawks.

i have Mazda 3 hatchback 2016 and i would like to install AIO but i have a questions please , my OS version is 56.00.100 4A N can i install AIO on it ? if no ,how i can upgrade the OS or change it by using MAC computer ..


by the way i am saudi and im so happy to know this site :)

Thanks again
 

·
Registered
Joined
·
718 Posts
Discussion Starter #1,862
Hello all :)

First of all i would like to thank you guys for all this awesome teawks.

i have Mazda 3 hatchback 2016 and i would like to install AIO but i have a questions please , my OS version is 56.00.100 4A N can i install AIO on it ? if no ,how i can upgrade the OS or change it by using MAC computer ..


by the way i am saudi and im so happy to know this site :)

Thanks again
I really can understand, that it can be difficult to find infos, if you're new to this.

BUT:
You could have read the AIO readme and/or the FAQ and especially the last view pages of this thread, then you could have found this post only one page before with infos from the readme about which FW is supported (I do not know how many times I have answered this before ...).

Here you could have read this:
WHICH FW VERSIONS ARE SUPPORTED:

The tweaks can be installed for all FW versions I now at this time, for most of the tweaks it doens't matter, which FW you have, which are these:


  • 56.00.100A/230A/240B/511A/512A/513C -ADR (4A N)
  • 56.00.230A/511A/512A/513B -EU
  • 55.00.650A/753A/760A / 58.00.250A -NA
  • 56.00.401A-JP

So, YES, your FW version 56.00.100A-ADR is fully supported.

If you want to update your FW, then look into this thread for info.
Here you can download latest available version (56.00.513C-ADR).

Look into folder \choose\docs of AIO, there you can find some docs (amongst others, this FW Update Howto.txt).
 

·
Registered
Joined
·
2 Posts
Thank you Siutsch!

I did notice that when I went into the SD card to add the speedcam.txt, I see in the root there is a new file that I did not put there named SD_CID.txt. with the contents of that text document showing "SD Card CID: 03534453553136478008CC2D9F00D800". Obviously that is the wrong CID. Did I patch the NNG wrong originally?

And my FW is 55.00.753 NA N
 

·
Registered
Joined
·
718 Posts
Discussion Starter #1,864
I really don't know, why you have to patch the NNG file with a CID.

For using the speedcam patch this file has only to be patched for speedcam using.

I use another SD card too (16 GB Transcend) and everything works.

Perhaps @Modfreakz can explain better, what for the CID patch has to be used, he is expert in this. ;)
 

·
Registered
Joined
·
63 Posts
Hi,

I think I have to write small howto or summary in the future of all NNG/licence patching/hack, locking/unlocking SD-card, .....

But its realy easy! I try explain in easy words, not in detail.

We have two phase of locking.

Phase_1. You put original/virgin SD card into car (eg: car_A)
what happen now is: The CMU checks the Typ1.lyc against the CID of the insert SD card. If all is fine, it creates the device.nng with vehicle specific data. The files (cardnotused.txt+cardnotused.txt.sgn) are deleting after this. Navigation works.

Phase_2. after 100km you have second stage of locking.
what happen now is: The CMU renames the Typ1.lyc. At the end of the lyc file you will see different key in big letters. After renaming the file you can't use the card in other cars. Also if you don't know the original key in small letters, you can't unlock the SD-card anymore.

As far as I understand this, if you put the card after phase_1 into other car (Car_B) the CMU will lock SD-Card immediately to Car_B. This remains to be confirmed.


Now we come to Mazda Toolbox.

After Phase_1 or phase_2 (don't matter) we put the SD-card into PC and start Mazda Toolbox. We update the maps. The Toolbox creates a new Typ2.lyc in which now the latest maps (hash) plus VIN are locked. After this you will never need the Typ1.lyc. Every time you update to the new maps a new Typ2.lyc will be created.


What does this means for our patch.

The CID patch is needed if you never updated the maps. Also the CID patch is needed if you like to use non original SD-card and you need the device.nng. After updating the maps via Toolbox you can use any (bigger/faster) SD-cards and the CID patch can now be undone.

The optional SIGN patch (only for speedcams at the moment) is still required.
 

·
Registered
Joined
·
80 Posts
Siutsch,

I've confirmed that the Speedometer app install works perfect for the Fiat Spider, with no negative effect on the GPS or Nav system. Using your beta test copy, I haven't tried Android Auto [R], speedcam-patch [P] and track-order/FLAC support [N] yet though.
Also noted that WiFi menu is enabled.
 

·
Registered
Joined
·
90 Posts
I have just had my car updated to 56.00.513 -EU and have seen the warnings that with 56.00.5xX "There is no GPS data anymore". The wording implies this is only significant to installations that have included the "Speedometer app" or that display GPS Data.
I only intend to remove the disclaimer and unlock the touchscreen.
If I do not install the Speedometer, can anyone tell me if will my factory fitted SatNav still work?
 

·
Geek
Joined
·
174 Posts
Hi,

I think I have to write small howto or summary in the future of all NNG/licence patching/hack, locking/unlocking SD-card, .....

But its realy easy! I try explain in easy words, not in detail.

We have two phase of locking.

Phase_1. You put original/virgin SD card into car (eg: car_A)
what happen now is: The CMU checks the Typ1.lyc against the CID of the insert SD card. If all is fine, it creates the device.nng with vehicle specific data. The files (cardnotused.txt+cardnotused.txt.sgn) are deleting after this. Navigation works.

Phase_2. after 100km you have second stage of locking.
what happen now is: The CMU renames the Typ1.lyc. At the end of the lyc file you will see different key in big letters. After renaming the file you can't use the card in other cars. Also if you don't know the original key in small letters, you can't unlock the SD-card anymore.

As far as I understand this, if you put the card after phase_1 into other car (Car_B) the CMU will lock SD-Card immediately to Car_B. This remains to be confirmed.


Now we come to Mazda Toolbox.

After Phase_1 or phase_2 (don't matter) we put the SD-card into PC and start Mazda Toolbox. We update the maps. The Toolbox creates a new Typ2.lyc in which now the latest maps (hash) plus VIN are locked. After this you will never need the Typ1.lyc. Every time you update to the new maps a new Typ2.lyc will be created.


What does this means for our patch.

The CID patch is needed if you never updated the maps. Also the CID patch is needed if you like to use non original SD-card and you need the device.nng. After updating the maps via Toolbox you can use any (bigger/faster) SD-cards and the CID patch can now be undone.

The optional SIGN patch (only for speedcams at the moment) is still required.
Could you reply why the device.nng method work even thru we had the europe cid initially for the gcc maps thread where i posted the steps first you download the europe maps via the patched cid and make it work then you use my device.nng and you will be able to download the gcc maps but when you try them in the cmu it gives them invalid sdcard while it worked for me. What do you think ?
 

·
Registered
Joined
·
80 Posts
I have just had my car updated to 56.00.513 -EU and have seen the warnings that with 56.00.5xX "There is no GPS data anymore". The wording implies this is only significant to installations that have included the "Speedometer app" or that display GPS Data.
I only intend to remove the disclaimer and unlock the touchscreen.
If I do not install the Speedometer, can anyone tell me if will my factory fitted SatNav still work?
Based on my experience, your Nav won't be effected by those simple tweaks.
 

·
Registered
Joined
·
416 Posts
Hi all, I have an small script to automatically hide the small speedo when you start android auto:

Please Siutsch if you can put it in the install (At the end)

# hide small speedometer if androidauto is open
show_message "HIDE SMALL SPEEDO ..."
LN=$(grep -n "if(framework.getCurrentApp() == 'backupparking'){" /jci/opera/opera_dir/userjs/speedometer-startup.js | cut -d":" -f1)
sed -i ''"$LN"' i\ }' /jci/opera/opera_dir/userjs/speedometer-startup.js
sed -i ''"$LN"' i\ $('"'#SbSpeedo'"').fadeOut();' /jci/opera/opera_dir/userjs/speedometer-startup.js
sed -i ''"$LN"' i\ if(framework.getCurrentApp() == '"'"'_androidauto'"'"'){' /jci/opera/opera_dir/userjs/speedometer-startup.js

Hope you can enjoy it
 

·
Registered
Joined
·
5 Posts
I tried searching through the thread, but had no success... so I'm sorry if this is redundant.

Has anyone had any issue with their custom background.png going away and coming back?

Typically, I listen to Pandora so I'll note the time the background goes out and comes back... seems to be truly random; 30 seconds here, 60 there, and various values in between.
 

·
Registered
Joined
·
80 Posts
Siutsch,

When comparing the mini speedometer to the "Where am I screen" in the Fiat Spider using the beta 1.51 AIO, I notice that both the altimeter and the compass readings are way different. The compass seems to be between 90 and 180 degrees off and the altimeter is randomly off by 100 to 150 feet. Any suggestions?
 

·
Registered
Joined
·
718 Posts
Discussion Starter #1,873
Siutsch,

When comparing the mini speedometer to the "Where am I screen" in the Fiat Spider using the beta 1.51 AIO, I notice that both the altimeter and the compass readings are way different. The compass seems to be between 90 and 180 degrees off and the altimeter is randomly off by 100 to 150 feet. Any suggestions?
Sorry, I have no idea.

Can you give us a screenshot?

It could be that things are different with Fiat.

Perhaps Diginix (developer of speedo) can help. or has an idea.
 

·
Registered
Joined
·
3 Posts
Hello Siutsch.

Like the good work you have done for the AIO tweaks, works fine for me.

I have made a USB drive ready to intall on the latest version for my new CX5 wit FW 56.00.513 B.

One question leaves for future use: When there comes a new FW version, is it nessecary to uninstall the AIO tweaks first, install the new FW and after that, reinstall AIO, or can the new FW install on the system with AIO installed on?

Thanks.
 

·
Registered
Joined
·
513 Posts
Siutsch,

When comparing the mini speedometer to the "Where am I screen" in the Fiat Spider using the beta 1.51 AIO, I notice that both the altimeter and the compass readings are way different. The compass seems to be between 90 and 180 degrees off and the altimeter is randomly off by 100 to 150 feet. Any suggestions?
I have no idea. As Siutsch said, this can be caused by different code in Fiat. Without having this car for testing, I can't do anything.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #1,876
Hello Siutsch.

Like the good work you have done for the AIO tweaks, works fine for me.

I have made a USB drive ready to intall on the latest version for my new CX5 wit FW 56.00.513 B.

One question leaves for future use: When there comes a new FW version, is it nessecary to uninstall the AIO tweaks first, install the new FW and after that, reinstall AIO, or can the new FW install on the system with AIO installed on?

Thanks.
By installing a new FW, almost all tweaks will be removed, until enabling of the touchscreen, afaik.
I think, that it's not nessecary to uninstall the tweaks before, I myself have done this several times and never had a problem, but as we don't know what changes will come for future FW versions, I would uninstall the tweaks before doing a FW update.

So after that, you have to install the tweaks again.
 

·
Registered
Joined
·
43 Posts
Hello guys,

I am about to install some tweaks from AIO pack. At first I have already installed SSH-bringback (as I am no 56.00.513 EU N) in case everything would go bad.

I also tried to enable Wi-Fi in the car and connect it to my iPhone hotspot. Now, I would like to try the SSH connection, just to be sure SSH-bringback was installed correctly and I have access to the car's infotainment system. I am using Putty as SSH client.

My questions:
1) Could you please provide me with root login and password for SSH connection?
2) I noticed there is missing part of Wi-Fi icon on the Mazda's display. This is probably no big deal, but is this normal or the tweak caused this?

Thanks
 

Attachments

·
Registered
Joined
·
19 Posts
2) I noticed there is missing part of Wi-Fi icon on the Mazda's display. This is probably no big deal, but is this normal or the tweak caused this?
It's normal. The segments of the Wi-Fi icon indicate how strong the signal is. So if segments are greyed-out it just means: the signal is not 100% vital. There's nothing wrong with your icon.
 

·
Registered
Joined
·
43 Posts
It's normal. The segments of the Wi-Fi icon indicate how strong the signal is. So if segments are greyed-out it just means: the signal is not 100% vital. There's nothing wrong with your icon.
I fully undestand what these segments mean, I was networking product manager for few years :) But it was strange to me why there is only part of third stripe active (I would suppose there will be either three or four segments active, not 2 and half :-D )
 

·
Registered
Joined
·
513 Posts
Idol doesn't understand what you mean. I have checked the original icon files and in this the levels are fully filled with white or gray.
Don't know if there is a overlay to show the traffic like on Android (with arrows). But in my Atenza the lines are complete one color.
 
1861 - 1880 of 8776 Posts
Top