2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1781 - 1800 of 8776 Posts

·
Registered
Joined
·
513 Posts
This could be one of the original Mazda apps that is disabled by default in most of all countries.
The IDM app shows also some driving parameter, but looks different.

 

·
Registered
Joined
·
513 Posts
Afaik it is only available in Japan and can't be enabled in other regions. But the app code is included in all firmware versions.
 

·
Registered
Joined
·
43 Posts
Thanks for the great utility! Got a suggestion...
Back in V 33, you could disable the proximity dashboard (car with distance from other car ) in the HUD. Is there a tweak to get that back? or perhaps modifying some files?

When turned off, only the Speed will be displayed.
 

Attachments

·
Registered
Joined
·
5 Posts
When opening the "choose" command, I receive the following message. "cannot open choose\lang\1\lang1.txt The system cannot find the path specified" Anyone have any ideas on what the solution is?
 

·
Registered
Joined
·
2 Posts

·
Registered
Joined
·
181 Posts
Thanks for the great utility! Got a suggestion...
Back in V 33, you could disable the proximity dashboard (car with distance from other car ) in the HUD. Is there a tweak to get that back? or perhaps modifying some files?

When turned off, only the Speed will be displayed.
You can still get the only speed mode. You have to disable all nanny features like LDWS, DRSS, MRCC. Some of them from physical buttons, some of them from touch screen settings. After you disable those systems, only big speed indicator will remain on ADD. At least i can do that and I'm using the latest firmware version available 513B.
 

·
Registered
Joined
·
23 Posts
@Siutsch

I' need yout help for sed command and your AIO Tool:

sed /'LockWhenDriving'/s/\b'Verriegeln: Beim Fahren'\b/'NEUER TEXT'/g jci/gui/resources/js/vehsettings\vehsettingsAppDict_de_DE.js

sed /'LockWhenDrivingUnlockIGNoff'/s/\b'Verriegeln: Beim Fahren'\b/'NEUER TEXT'/g jci/gui/resources/js/vehsettings\vehsettingsAppDict_de_DE.js
 

·
Registered
Joined
·
42 Posts
Hi @hanmin , that is not a fix, please don't spread this information, this is not correct. People are having problems running castscreen on a >=.511 system, and the "fix" that you suggest is not a fix for this problem.

hi, is the cast screen compatible with Android 6.0.1? I could not make it work! All other tweaks are OK!
Using Nexus 5. Thank you.
It is, read below.

I couldn't make castscreen work on 56.00.100 (33.00.500)
Is there anyone who can?
Ok so, this is what I have understood so far, please go to the http://mazda3revolution.com/forums/2014-2016-mazda-3-skyactiv-audio-electronics/172337-castscreen-ssh-issues.html thread to reply, so we keep the thread(s) clean and organized:

a) .511 enables the network firewall. To make castscreen work, you need to either disable the firewall or open port 53515. Sooner or later I'm going to package this into a script. If you can't wait, to disable the firewall:
1) ssh into the car (assuming you have re-enabled ssh already)
2) /jci/scripts/jci-fw.sh stop
done. Cast screen should now work *via WIFI*

b) for some reasons, adb is lo longer able to authorize devices. Therefore castscreen doesn't work via usb, unless we find a way to authorize devices again. My humble opinion is that adb tries to create the two needed files to authorize a device: adbkey and adbkey.pub. However it doesn't have permissions to write those in the correct location, so the devices stay unauthorized and it's impossible to make castscreen work *via USB*.
To solve this issue, I need someone with a clean .230 installation to:
1) ssh into the car
2) find / | grep adbkey
3) give me the output of 2), or even better, give me the two files: adbkey and adbkey.pub and tell me the location(s) they were found in.
If it's not a permission issue, then it may be slightly more complex.

Please, someone with .230 help here! :) You'll receive credit for helping ;)

regards
 

·
Registered
Joined
·
6 Posts
Hi
I noticed that AIO dont activate the wifi on my car (cx-5 northamerica): the settings file is identical before and after the script change (and the script line seems that is supposed to modify the unit settings file looks OK).
Somebody noticed it ?
 

·
Registered
Joined
·
15 Posts
Hi guys, I've installed v1.50 I love it!

But I noticed an issue this weekend, when I listen to music from a USB drive while on the NAV screen, the music start to skip after a while, like the CPU can't keep up or something similar.

If I'm on any other screen it doesn't happen, and if I'm listening to FM radio on the NAV screen it's fine too. Even if I don't have a destination selected it happens, just being on the NAV screen is enough to trigger the "skipping".

I've tried the search feature in this thread to find an answer, but I guess I didn't use the right words...

Anyway thanks for the help !
 
  • Like
Reactions: croussel

·
Registered
Joined
·
3 Posts
Hi
I noticed that AIO dont activate the wifi on my car (cx-5 northamerica): the settings file is identical before and after the script change (and the script line seems that is supposed to modify the unit settings file looks OK).
Somebody noticed it ?
Same here, North America too, on a Mazda 3 with 56.00. I hope there is a solution.:frown2:
 

·
Registered
Joined
·
19 Posts
Hi guys, I've installed v1.50 I love it!

But I noticed an issue this weekend, when I listen to music from a USB drive while on the NAV screen, the music start to skip after a while, like the CPU can't keep up or something similar. (...)
Either your USB stick is too slow or your Nav SD card or both. Did you try a faster USB stick? If this doesn't help try a UHS-I/ class 10 SD card for your navi.

I use a simple Sandisk Cruzer USB 2.0 stick (with just 16GB to keep everything stable) + the original Nav SD card from Mazda which isn't the fastest (class 4 or so) and this combination works surprisingly fine without any hick-ups.
 

·
Registered
Joined
·
1 Posts
I just wanted to disable the disclaimer upon boot-up. I ran the program then noticed something after reboot. Yes it did get rid of the disclaimer, but booted straight to the main screen. I prefer to have my screen off most of the time and with the disclaimer, if i left the screen off, it booted up staying off.

Due to the annoyance of always booting up to the main screen and then having to manually turn off the screen each time, I just uninstalled that tweak. AIO is a pretty cool little program though.
 
1781 - 1800 of 8776 Posts
Top