2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

981 - 1000 of 8528 Posts

·
Registered
Joined
·
11 Posts
i still get this error.
the the cmd block comes up with multiple lines reading:
"The system cannot find the path specified."

after unzipping the file the "choose" file only shows files "lang" and "more_background-images"
viewing it in winzip pro shows more files? - are these files hidden?


Help?
Right, so i tried this in 2x comps.
both failed with the 27 country code.

then i put it in a 3rd comp. came up with 1 country code and then worked perfectly.
so i am all good.
but might be a bug? - nothing other than the initial country code changed.
 

·
Registered
Joined
·
19 Posts
@Siutsch i have this problem,i upload two photos.
I cant continue after that two window...
If you have experience about editing shell files. Please open choose.cmd in a suitable editor. And change the line 88

Code:
if %CCode%==34 set set CountryCode=34& language=Spanish
to

Code:
if %CCode%==34 set CountryCode=34& language=Spanish
There is double 'set' command mistakenly.

And do not put AIO files in a protected folder like "c:\Program files" or "c:\windows"

:)
 

·
Registered
Joined
·
19 Posts
Ups!
There was a bug in choose.cmd for Spanish. :frown2:

I will update new testversion later today.

There are double set commands at line 88 and line 108.
Sorry for them, I just try to help you.
I think you having a vacation.

Regards.
 

·
Registered
Joined
·
25 Posts
SSH is port 22, but SSH is disabled by default from Mazda since FW version .511, so far as I know, unless you installed the tweak before to enable SSH again.

username has to be root, password is jci

Don't know, if you can use websocketd port for this, but if so, this could be a solution.

The backuped file is named /jci/lib/libmc_user.so.org, you can find it on your MZD system.
You only have to do the following, if you can login:

mv /jci/lib/libmc_user.so.org /jci/lib/libmc_user.so

I hope it works.

Bad news. No ssh possibility. Used portscan, there were no ports available. :sad::sad:
Also tried with a cd, it only accept "music" files.
Perhaps it must be a bootable cd, does someone has the correct bootable (linux?) cd?

Does someone know if there is a hardware reset on the CMU? Or a "management" connector (usb?)
on the CMU itself?
Is there a "How to" to reach/disassemble the CMU without damaging the dashboard?

Or the only option, ask the dealer for help. :death:
 

·
Registered
Joined
·
718 Posts
Discussion Starter #986
If you have experience about editing shell files. Please open choose.cmd in a suitable editor. And change the line 88

Code:
if %CCode%==34 set set CountryCode=34& language=Spanish
to

Code:
if %CCode%==34 set CountryCode=34& language=Spanish
There is double 'set' command mistakenly.

And do not put AIO files in a protected folder like "c:\Program files" or "c:\windows"

:)
And there is no set before language=Spanish.

I corrected all this and will upload bugfixed version soon.

Thanks for hint.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #987
Bad news. No ssh possibility. Used portscan, there were no ports available. :sad::sad:
Also tried with a cd, it only accept "music" files.
Perhaps it must be a bootable cd, does someone has the correct bootable (linux?) cd?

Does someone know if there is a hardware reset on the CMU? Or a "management" connector (usb?)
on the CMU itself?
Is there a "How to" to reach/disassemble the CMU without damaging the dashboard?

Or the only option, ask the dealer for help. :death:
I don't know, if something like this USB2ethernat adapter works, altough USB ports are not working?
Has somebody tried this out?

Another possible solution is to enable Hotspot on MZD system (I don't know, if that still works with .51x FW versions):

1. Open diagnostics menu (buttons Music + Favorites + Pwr / Mute and hold until menu appears)
2. Hold down "DEL" until "JCI Test Mode Active" appear at right black box (15-20 sec.).
3. Press "11" and then press "Enter."
4. Select script WiFi AP Toggle (sor so)

Then the access point of the car is running.
You should see a WLAN "cmu ...".
Simply log in and then access via IP 192.168.53.1 on the system.
 

·
Registered
Joined
·
19 Posts
ijs_99

Did you try this procedure. Flashing CMU may be solve your problem.
http://mazda3revolution.com/forums/1342082-post36.html

I know USB port doesn't work in your case, but CMU may be use USB port in raw mode or may use special primitive access to the port during FW update.

And another possible solution may be diagnostic menu hidden property. There is a way in diagnostic screen to run some internal scripts. I don't remember but like " press 15 seconds to DEL button and enter 11". You can search forum for it.
Waiting good news.
 

·
Registered
Joined
·
451 Posts
Hi,

I like to request small graphics fix in NO background buttons patch.

It's great, but there is small glitch in fuel consumption menu.

the background is now transparent, so when menu selected inside the app,
i see the previous menu buttons behind the active menu.

question can we use the normal background only in fuel app?
This is the only place i see this graphic bug.

Thanks. :smile2:
After I read this post - I noticed this, so to say bug of the tweak in my car too.
It's not critical, but yeah, as dorimanx suggested, enabling background just for Fuel Consumption Menu would make it better.

Maybe we should ask the original creator of the tweak about it?
 

·
Registered
Joined
·
19 Posts
I don't know, if something like this USB2ethernat adapter works, altough USB ports are not working?
Has somebody tried this out?

Another possible solution is to enable Hotspot on MZD system (I don't know, if that still works with .51x FW versions):

1. Open diagnostics menu (buttons Music + Favorites + Pwr / Mute and hold until menu appears)
2. Hold down "DEL" until "JCI Test Mode Active" appear at right black box (15-20 sec.).
3. Press "11" and then press "Enter."
4. Select script WiFi AP Toggle (sor so)

Then the access point of the car is running.
You should see a WLAN "cmu ...".
Simply log in and then access via IP 192.168.53.1 on the system.
I noticed your reply after I send my own.

ijs_99

Did you try this procedure. Flashing CMU may be solve your problem.
http://mazda3revolution.com/forums/1342082-post36.html

I know USB port doesn't work in your case, but CMU may be use USB port in raw mode or may use special primitive access to the port during FW update.

And another possible solution may be diagnostic menu hidden property. There is a way in diagnostic screen to run some internal scripts. I don't remember but like " press 15 seconds to DEL button and enter 11". You can search forum for it.
Waiting good news.
I find a post from "hodags" about systemhooks.sh which runs when enter "JCI Test Mode". List of buttons are following.

SYSTEM_UNAVAILABLE=0
SYSTEM_HDCP_TOGGLE=1
SYSTEM_SPEED_RESTRICTION_TOGGLE=4
SYSTEM_DEV_MODE_TOGGLE=7
SYSTEM_CPUGAUGE_TOGGLE=10
SYSTEM_DISP_CONFIG_TOGGLE=13
SYSTEM_RESET_MAP=16
SYSTEM_RESET_VIP=17
SYSTEM_USB_DRIVERS=18
SYSTEM_TAUSIM_TOGGLE=19
SYSTEM_TERMINAL=22
SYSTEM_WIFI_AP_TOGGLE=25
SYSTEM_USERTTY_TOGGLE=28
LVDS_SPEED_RESTRICTION_TOGGLE=31
VCF_FILES_TOGGLE=34
DELETE_BDS_FILES_TOGGLE=37
NNG_DEBUG_TOGGLE=40

#18 runs "usb_drivers.sh". And USB related kernel modules are re-inserted to kernel.

Code:
#!/bin/sh

insmod /lib/modules/3.0.35/kernel/drivers/hid/hid.ko
insmod /lib/modules/3.0.35/kernel/drivers/hid/usbhid/usbhid.ko

insmod /lib/modules/3.0.35/kernel/sound/core/snd-rawmidi.ko
insmod /lib/modules/3.0.35/kernel/sound/usb/snd-usbmidi-lib.ko
insmod /lib/modules/3.0.35/kernel/sound/core/snd-hwdep.ko
insmod /lib/modules/3.0.35/kernel/sound/usb/snd-usb-audio.ko


# Special configuration for CMU hardware
insmod /lib/modules/3.0.35/kernel/drivers/i2c/jci/i2c_session.ko bus=2 rstGpio=16

touch /var/run/usb_driver_ready
I hope you get back USB ports.
:nerd:
 

·
Registered
Joined
·
24 Posts
ssh access does not work on the latest versions 5600511/512/513., and the latest version of 55.... to solve the problem there is the tweak "ssh BringBack".
but it's irrevocably.
Any reason why it's not possible to revert to original seetings? I PM'd mzd3-k if he can create uninstall script but no reply...:sad 1:

TBH not feeling too comfortable to change the source code without possibility reverting back to original :sad010:

Maybe it's possible to extract the appropriate lines of original code onto USB (create backup) when applying the SSH bringback tweak and then delete the tweak and insert the lines back with an uninstall option?

Otherwise only way is to re-install the whole system :argh 1:, right? Is it actually possible to "overwrite" current version with same one?
 

·
Registered
Joined
·
451 Posts
BTW, adding FLAC support - which tech specs are supported?
16/44.1? 24/48? 24/96?

Has anyone tested it?
 

·
Registered
Joined
·
25 Posts
I noticed your reply after I send my own.



I find a post from "hodags" about systemhooks.sh which runs when enter "JCI Test Mode". List of buttons are following.

SYSTEM_UNAVAILABLE=0
SYSTEM_HDCP_TOGGLE=1
SYSTEM_SPEED_RESTRICTION_TOGGLE=4
SYSTEM_DEV_MODE_TOGGLE=7
SYSTEM_CPUGAUGE_TOGGLE=10
SYSTEM_DISP_CONFIG_TOGGLE=13
SYSTEM_RESET_MAP=16
SYSTEM_RESET_VIP=17
SYSTEM_USB_DRIVERS=18
SYSTEM_TAUSIM_TOGGLE=19
SYSTEM_TERMINAL=22
SYSTEM_WIFI_AP_TOGGLE=25
SYSTEM_USERTTY_TOGGLE=28
LVDS_SPEED_RESTRICTION_TOGGLE=31
VCF_FILES_TOGGLE=34
DELETE_BDS_FILES_TOGGLE=37
NNG_DEBUG_TOGGLE=40

#18 runs "usb_drivers.sh". And USB related kernel modules are re-inserted to kernel.

Code:
#!/bin/sh

insmod /lib/modules/3.0.35/kernel/drivers/hid/hid.ko
insmod /lib/modules/3.0.35/kernel/drivers/hid/usbhid/usbhid.ko

insmod /lib/modules/3.0.35/kernel/sound/core/snd-rawmidi.ko
insmod /lib/modules/3.0.35/kernel/sound/usb/snd-usbmidi-lib.ko
insmod /lib/modules/3.0.35/kernel/sound/core/snd-hwdep.ko
insmod /lib/modules/3.0.35/kernel/sound/usb/snd-usb-audio.ko


# Special configuration for CMU hardware
insmod /lib/modules/3.0.35/kernel/drivers/i2c/jci/i2c_session.ko bus=2 rstGpio=16

touch /var/run/usb_driver_ready
I hope you get back USB ports.
:nerd:
I don't know, if something like this USB2ethernat adapter works, altough USB ports are not working?
Has somebody tried this out?

Another possible solution is to enable Hotspot on MZD system (I don't know, if that still works with .51x FW versions):

1. Open diagnostics menu (buttons Music + Favorites + Pwr / Mute and hold until menu appears)
2. Hold down "DEL" until "JCI Test Mode Active" appear at right black box (15-20 sec.).
3. Press "11" and then press "Enter."
4. Select script WiFi AP Toggle (sor so)

Then the access point of the car is running.
You should see a WLAN "cmu ...".
Simply log in and then access via IP 192.168.53.1 on the system.

Guys,

I can access:
1. Open diagnostics menu (buttons Music + Favorites + Pwr / Mute and hold until menu appears)
2. Hold down "DEL" until "JCI Test Mode Active" appear at right black box (15-20 sec.). Doesn't work :no::argh 1::sad 1:
Tried holding down "DEL" and "Clear", also.
Seems they change it in .51 FW version :death::angry:
 

·
Registered
Joined
·
19 Posts
Guys,

I can access:
1. Open diagnostics menu (buttons Music + Favorites + Pwr / Mute and hold until menu appears)
2. Hold down "DEL" until "JCI Test Mode Active" appear at right black box (15-20 sec.). Doesn't work :no::argh 1::sad 1:
Tried holding down "DEL" and "Clear", also.
Seems they change it in .51 FW version :death::angry:
Let me check my car in the evening. I updated it to 56.00.513B last weekend.
:closedeyes 1:
 

·
Registered
Joined
·
19 Posts
JCI test menu is working.
My fresh experience follows.
In diagnostic menu touch DEL button. Hold on button continuously till 'JCI test menu' text appears in upper-right box on the screen (may be more than 20seconds), write 11 with numeric keys and press enter.
:)
 

·
Registered
Joined
·
5 Posts
Hi, I'm on 56.00.240 4A version, I've successfully installed the AIO 1.47b, well after some troubles by remove the double colons to set the language, for the video player, first time go in always show Record Driver Log? Then second time it display all videos playable, if I'm on FM radio first, then the video screen will block the UI, appear in front as a layer, which no way to turn it off, the audio playable from video files are quite limited I think, PCM/Dolby AC3 audio is not playable, only mp3/aac? It would be good if the video player has more controls. Also the USB drive file system must be FAT32, any possible support for NTFS system in future? Wifi Mirrorlink is working? I can success using CastScreen to mirror link, but MZD touchscreen won't feedback to the phone, is this a permanent limitation?
 

·
Registered
Joined
·
385 Posts
Hi, I'm on 56.00.240 4A version, I've successfully installed the AIO 1.47b, well after some troubles by remove the double colons to set the language, for the video player, first time go in always show Record Driver Log? Then second time it display all videos playable, if I'm on FM radio first, then the video screen will block the UI, appear in front as a layer, which no way to turn it off, the audio playable from video files are quite limited I think, PCM/Dolby AC3 audio is not playable, only mp3/aac? It would be good if the video player has more controls. Also the USB drive file system must be FAT32, any possible support for NTFS system in future? Wifi Mirrorlink is working? I can success using CastScreen to mirror link, but MZD touchscreen won't feedback to the phone, is this a permanent limitation?
No to all your questions.
 

·
Registered
Joined
·
25 Posts
JCI test menu is working.
My fresh experience follows.
In diagnostic menu touch DEL button. Hold on button continuously till 'JCI test menu' text appears in upper-right box on the screen (may be more than 20seconds), write 11 with numeric keys and press enter.
:)
Nope, it's not working, even holding it for 60secs.:sad:
When pressing "DEL" it becomes greyout.
After 30sec it becomes "DEL" becomes normal again.

Flashing CMU with FW also not working, usb can not be found.
 

·
Registered
Joined
·
1 Posts
Just got linked to this from another site.


I wish I could do something like this to my Subaru.... The system is so slow and cumbersome. We have zero way of getting updates to it. Nowhere online, dealers have no clue.

I would do this in a heartbeat
 
981 - 1000 of 8528 Posts
Top