2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

921 - 940 of 8692 Posts

·
Registered
Joined
·
718 Posts
Discussion Starter #921 (Edited)
IMPORTANT INFORMATION FOR USERS WITH 4A FIRMWARE VERSIONS:

As I wrote here, within AIO I only check the numbers of the FW versions so far, e.g. for FW 56.00.100A ADR, which is supported, I only check if it's 56.00.100, same with 56.00.230A EU 56.00.511A EU, etc.

To recognize also firmware version with "4A", I have to change the version detection within AIO for future versions.

Therefore I need some help from people with that FW versions:
The info from AIO_log.txt behind "=== CMU_SW_VER = "


So please DO NOT INSTALL media order tweak at the moment, if you have one of the following FW versions:
- 56.00.100A 4A
- 56.00.230A 4A
- 56.00.511A 4A (and .512A 4A / 513A 4A, if they exists too)

It seems, that the file libmc_user.so, which will be replaced during the installation of this tweak, isn't compatible with that FW versions and unfortunately you don't have USB access after rebooting your system!!

If you have newer version .51x, than you also have no longer SSH access and there is no way to replace the file libmc_user.so with the backuped version (at least I know of no way to do this).
So, if somebody has this problem in the past and could repair this, please share your knowledge!


Sorry for that, but I was recently not aware that there are these 4A versions and especially that they have the same name/numbering, than EU versions.
And there are no download links for these in the MZD Connect ALL Firmware version thread.
 

·
Registered
Joined
·
25 Posts
Then I think the problem could be the install of the media order tweak.

In some very rare cases there are problems with replacing a file, that is needed for USB access.
It's the file /jci/lib/libmc_user.so

If that fails, then you have the problems you described.

I tried to prevent that by checking the checksum of the copied files and copying is repeated up to 3 times, if that check fails and after that the original file will be used from backup again, but it seems, that there must be another problem with it.
During installation was made a backup of this file on your system which is called libmc_user.so.org.

You have to replace this backup with your not correct copied version and you should have USB access again.

But without SSH access via WIFI, I don't know how to do.

I myself fortunately never had the problem with it and as I still use FW .230 with SSH access, I could repair anything, if I have such problems.


Perhaps someone here with experience with it can help, I hope.

Ok, no problem. Will try to find a solution to get it up and running.
The CMU has wifi access to my G4/Wifi dongle for traffic and weather updates on the internet.
(I can connect it also to my home router.)
I can connect my laptop to this G4/wifi dongle also.
- is the ssh port 22 or is it changed? userid and password?
- or can I use the websocketd port?

Is it possible to use the SD card slot?
Is it possible to reset it to factory default, other than using the system menu?
 

·
Registered
Joined
·
718 Posts
Discussion Starter #923
Ok, no problem. Will try to find a solution to get it up and running.
The CMU has wifi access to my G4/Wifi dongle for traffic and weather updates on the internet.
(I can connect it also to my home router.)
I can connect my laptop to this G4/wifi dongle also.
- is the ssh port 22 or is it changed? userid and password?
- or can I use the websocketd port?

Is it possible to use the SD card slot?
Is it possible to reset it to factory default, other than using the system menu?
SSH is port 22, but SSH is disabled by default from Mazda since FW version .511, so far as I know, unless you installed the tweak before to enable SSH again.

username has to be root, password is jci

Don't know, if you can use websocketd port for this, but if so, this could be a solution.

The backuped file is named /jci/lib/libmc_user.so.org, you can find it on your MZD system.
You only have to do the following, if you can login:

mv /jci/lib/libmc_user.so.org /jci/lib/libmc_user.so

I hope it works.
 

·
Registered
Joined
·
12 Posts
SSH is port 22, but SSH is disabled by default from Mazda since FW version .511, so far as I know, unless you installed the tweak before to enable SSH again.

username has to be root, password is jci

.
Hi, would it be an idea that AIO always enabled SSH access on all versions, so that any problems should they occur would have a better chance of being fixed?
 

·
Registered
Joined
·
718 Posts
Discussion Starter #925
Hi, would it be an idea that AIO always enabled SSH access on all versions, so that any problems should they occur would have a better chance of being fixed?
At least I could mark SSH access by default for installation on start of AIO, if that is OK for you.

If this tweak is used on an older FW version, which needs no SSH access enabled, then it will not be installed, because there is also a FW verification for this, so this would be no problem.

I think I will do this, everyone can then still unmark this tweak, if he wants.
 

·
Registered
Joined
·
19 Posts
Bug for users uses a computer OS which has countrycode grater than 52

New version of AIO V1.47b for testing, download here.

Before I release this new version I need some more testing, so have fun with it! :)
At line 155 in choose.cmd, %CountryCode% variable forcibly changed to 1 for greater values than 52. And this causes languages which has greater values are undetected.

Code:
......
......
:: if CountryCode is >52 set language to english
if %CountryCode% GTR 52 set CountryCode=1
:: if CountryCode is 90 for turkish, set language to turkish, beause there is translation available
if %CountryCode%==90 set language=Turkish
:: if CountryCode is 421 for slovakian, set language to slovakian, beause there is translation available
if %CountryCode%==421 set language=Slovakian
......
Thanks again your big effort. :smile2:
 

·
Geek
Joined
·
171 Posts
At least I could mark SSH access by default for installation on start of AIO, if that is OK for you.

If this tweak is used on an older FW version, which needs no SSH access enabled, then it will not be installed, because there is also a FW verification for this, so this would be no problem.

I think I will do this, everyone can then still unmark this tweak, if he wants.
i dont know if its possible, cant we add another menu option something to the below like 1010 option to uninstall modifications or revert back to previous configurations:
6) Press the music, favorites, and mute buttons in your car all at the same time and hold for 2 to 5sec.
ONLY USE ''TOUCH SCREEN'' FOR NEXT UPDATE INPUTS - DO NOT USE DIAL KNOB.
7) Input code 3 to test for DTC's, enter, then clear, IF there's any DTCs listed, Input code 2, enter, then clear to remove all DTC's.
8 Input code 99, enter, to start the system update process.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #928
i dont know if its possible, cant we add another menu option something to the below like 1010 option to uninstall modifications or revert back to previous configurations:
6) Press the music, favorites, and mute buttons in your car all at the same time and hold for 2 to 5sec.
ONLY USE ''TOUCH SCREEN'' FOR NEXT UPDATE INPUTS - DO NOT USE DIAL KNOB.
7) Input code 3 to test for DTC's, enter, then clear, IF there's any DTCs listed, Input code 2, enter, then clear to remove all DTC's.
8 Input code 99, enter, to start the system update process.
Sorry, but I don't understand, what exactly do you want.

The steps, you describe, are yet to prepare a FW update, or not?
Or can you revert back with this? I don't think so.
 

·
Geek
Joined
·
171 Posts
Sorry, but I don't understand, what exactly do you want.

The steps, you describe, are yet to prepare a FW update, or not?
Or can you revert back with this? I don't think so.
when you select 99, the menu for update pops up, can we add another number like 88 which a menu pops up to revert back the modifications.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #931 (Edited)
I believe Siutsch can do it. Need some motivation.:smile2:
Oh no! :001_rolleyes:

Sorry, but I don't know which code within MZD has to be modified to do this.

And without plugged in USB drive you can't restore / uninstall all of the tweaks, because not all original backuped files are on MZD system but on the USB drive.

And as I said many times before:
I'm only the collector all all tweaks out there, no developer. :nerd:
 

·
Registered
Joined
·
718 Posts
Discussion Starter #932
At line 155 in choose.cmd, %CountryCode% variable forcibly changed to 1 for greater values than 52. And this causes languages which has greater values are undetected.

Thanks again your big effort. :smile2:
You're absolutely right.

I made some more tests and I hope this time it works as intended.

Updated version of AIO 1.47b will be online in a few ours, I make a new post, so that you can test again.

Thanks for hint.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #933 (Edited)
Just to remember:

I need some help from people with that 4A FW versions:
The info from AIO_log.txt behind "=== CMU_SW_VER = "

I need this info to make a bugfixed version.

And it would be nice, if someone could upload whole /jci folder to compare some files.

Thanks,
Siutsch.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #936 (Edited)
Updated test version V 1.47b.

What's new from last beta version:

1.47b - 2016-05-23
CHANGES/NEWS:
- Small update of Speedometer 4.2 (increased to 8000 r/pm)
- Update of "Android Auto" Headunit App to V0.91b
- Fixed language detection, should work now (thanks to mozsert for hint)
- Fixed version detection for some tweaks (pause_on_mute, media order patch, speedcam-patch), because there are FW versions out there with same numbering, e.g. 56.00.230A-EU and 56.00.230A-ADR, etc.


There may still be problems with the recognition of the FW versions, so please report, if so (had no time to test).

Actually with ADR FW version (4A) pause_on_mute, media order patch and speedcam patch can not be installed.
If get the version identifications, I will update the version detection.
 

·
Registered
Joined
·
62 Posts
Updated test version V 1.47b, same link.

What's new:

1.47b - 2016-05-23
CHANGES/NEWS:
- Small update of Speedometer 4.2 (increased to 8000 r/pm)
- Update of "Android Auto" Headunit App to V0.91b
- Fixed language detection, should work now (thanks to mozsert for hint)
- Fixed version detection for some tweaks (pause_on_mute, media order patch, speedcam-patch), because there are FW versions out there with same numbering, e.g. 56.00.230A-EU and 56.00.230A-ADR, etc.


There may still be problems with the recognition of the FW versions, so please report, if so (had no time to test).
Where is the link to the new version? When I click on the 1.46 link on the first page of this thread it still indicated 1.46, not 1.47b. Thanks.
 
921 - 940 of 8692 Posts
Top