2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
9101 - 9120 of 9420 Posts

·
Registered
Joined
·
1 Posts
[QUOTE = "MX-5RF, publicación: 2228002, miembro: 387234"]
Pude editar y reorganizar cosas ...

En el archivo "speedometer-config" v5.0b, "Gauge" está mal escrito ... ¿Puedo corregir también esta etiqueta con el editor?


[/CITA]
Hi @Trezdog44:

Feedback for Speedometer 5.0b beta:
Thanks for the beta. I do have the same freeze-problem as strelica (here) with the Speedometer 5.0b (on my CX-5 / 56.00.513C EU).

What I did:
Installation was possible. But on the first activation/click on Speedometer in MZD apps the complete MZD froze while the MZD apps list was still shown. Speedometer did not start. Nothing could be done/clicked at the display/selected via commander knob, except a reboot via nav+mute. I tried several installations/matrix: With&without nav SD card and an update on an already installed speedo 5.0 and I tried a clean install (previously deinstalled speedometer). Always the same freeze happened.

Unfortunatley I do not have the AIO_log.txt or any other logs - and I do not have access to the car for one week now. But after the installation of the beta there did not show up a statusbar speedometer. Before (with 5.0) there was no speedometer in the statusbar installed.

Feedback for Speedometer 5.0 from AIO 2.7.4:
  • 56.00.513C EU (my CX-5): Only after removing the nav SD card the altitude and altitude min/max worked fine. With inserted SD card it was just one value which did not change.
  • 56.00.511 EU (another CX-5): Altitude etc. works fine with inserted SD card.
  • So it`s just pressing (not turning) the command knob that changes the rows - now I experienced it. Thanks for adding the info to the instructions in the next AIO version - thats a cool feature and will probably be used more, when it is mentioned in the instruction.

German Translation for Speedometer 5.0:
User Tobi-HN from our Mazda CX-5 Forum did some translations for the german language in "speedometerUpdate.js" - you are free to use them:
Code:
  // [B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B]*[/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B]
  // [B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B]*[/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B]
    // language specific labels
  // [B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B]*[/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B]
  // [B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B][B]*[/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B][/B]
    // Deutsch
  else if(language === 'DE'){
    // $('#gpsSpeedFieldSet legend').html('Geschw. GPS');
    $('#tripDistFieldSet legend').html('Strecke <span class="spunit">(<span class="distUnit">km</span>)</span>');
    $('#speedTopFieldSet legend').html('Geschw. max');
    $('#speedAvgFieldSet legend').html('Geschw. ∅');
    $('#gpsAltitudeFieldSet legend').html('Höhe ü. NN <span class="spunit">(<span class="altUnit">m</span>)</span>');
    $('#gpsAltitudeMinMaxFieldSet legend').html('<span>min/max</span>');
    $('#gpsHeadingFieldSet legend').html('Fahrtrichtung');
    $('#gpsLatitudeFieldSet legend').html('Breite');
    $('#gpsLongitudeFieldSet legend').html('Länge');
    $('#tripTimeFieldSet legend').html('Gesamtzeit');
    $('#idleTimeFieldSet legend').html('Standzeit');
    $('#engIdleTimeFieldSet legend').html('Leerlaufzeit');
    $('.NorthEast').html('NO');
    $('.East').html('O');
    $('.SouthEast').html('SO');
    $('#rpmDial .unit').text('U/min');
    $('#fuelGaugeFieldSet legend').html('Kraftstofftank');
    $('#gearPositionFieldSet legend').html('Ganganzeige');
     $('#outsideTempFieldSet legend').html('Aussentemp.  <span class="spunit">(°<span class="tempUnit"></span>)</span>');
    $('#intakeTempFieldSet legend').html('Ansaugtemp.  <span class="spunit">(°<span class="tempUnit"></span>)</span>');
    $ ('# coolantTempFieldSet legend'). html ('Kühlertemp. <span class = "spunit"> (° <span class = "tempUnit"> </span>) </span>');
    }[/código]

Pero algunas otras traducciones no fueron posibles para él, ya que no encontró el código para:
  - Economía de combustible de viaje (trpFuel)
  - Velocidad GPS (gpsSpeed)
  - Economía de combustible total promedio (totFuel)
  - Economía de combustible promedio (avgFuel)
  - Velocidad del motor (engSpeed)
[/CITA]
Buen día, alguien que me pueda asesorar o apoyar, tengo una Mazda 3 2016, le instale el video player y android auto, y al momento de activar el gestor de red wifi, se fue a falla, no me deja encender el auto, el tablero se volvio loco, la pantalla se apaga, desinstale el video player y el android auto, pero el gestor de red no me permite desinstalarlo, alguien me podria ayudar, de favor 🙏😔 tristan cx5 podrías apoyarme con este problema que tengo. De antemano muchas gracias
 

·
Registered
Joined
·
11 Posts
Hi all, I'm on FW70.00.110 (But not the updated hardware), and I heard that AIO android auto doesn't work well with this FW. Is it possible to downgrade it to a lower FW? If so, where can I find the FW files? The old threads seem to all have deleted links to the files.
And finally, do I need to downgrade first before I get AIO tweaks, or do I get AIO tweaks first? I need to do a serial connection either way though right?
Thanks in advance.
 

·
Registered
Joined
·
2,535 Posts
Correct, AIO AA 1.13 does not work at any FW 70.

All links to inofficial firmware servers (and the servers itself) were deleted by the copyright owners - so in this forum it will be hard to find any links.

Yes, it is possible to downgrade - as far down as 59.00.502. And yes, you will have to do the serial access: www.mazdatweaks.com/serial.

Process:
1. Downgrade to any FW 59 for your region (ADR/4 AN). FW 59.00.502 is recommended as most stable for AIO AA 1.13.
2. Do the serial access
3. Install AIO AA 1.13
 

·
Registered
Joined
·
11 Posts
@Tristan-cx5 thanks for your reply! Any idea where I could find a download link? Or is that asking for too much :p in any case I will do some of my own digging.

One last question regarding the downgrade process, I was reading some conflicting info.
Some guides say you need to install the failsafe file FIRST and then the reinstall SECOND, to DOWNGRADE.
Some guides say the opposite, install reinstall FIRST and then failsafe SECOND, to downgrade.
Which one is the correct one?
 

·
Registered
Joined
·
2,535 Posts
I do not know any source for the firmware files and even if, I would not publish/share it. Sorry.

As there is no official instruction from Mazda for downgrades, it is hard to tell what the "correct" process is. For many people the standard update process worked fine (failsafe 1st) also for the downgrade. But some in developement experienced user stated, that for a downgrade you should better swap/change the file installtion order at a downgrade (to reinstall 1st). This should be more safe in case of an error. When I downgrade, I use "reinstall 1st".
 

·
Registered
Joined
·
11 Posts
Hi all, managed to downgrade my FW to 59.00.545.
When trying to do the serial connection method, when I paste this command in putty

cp -r /mnt/sd*/XX/* /mnt/data_persist/dev/bin/; chmod +x /mnt/data_persist/dev/bin/autorun; /mnt/data_persist/dev/bin/autorun

I get an error say cp error, cannot create directory, no such file or directory.
Any ideas?
Thanks in advance
 

·
Registered
Joined
·
11 Posts
Hi Tristran,
I downgraded from 70.00.110.
I double checked and my autorun files are in my USB stick in a folder called XX, this was created from AIO 2.8.6.
I think it's something to do with logging in to gain root access that is screwing up, even though I log in successfully with username: user and password: jci. The error appears to be a permissions issues. I've attached 2 screenshots, one is the error I get when I enter the auto run command, and the other is when I try to manually create the directory.
 

Attachments

·
Registered
Joined
·
2,535 Posts
Which username did you use? Have you tried both? user and cmu ?

Have you tried to install an AIO tweak anyway? Perhaps it worked already?

And you could try to change permissions via the command
Code:
mount -o rw,remount /
, before pasting the cp command.
So some points to try.
 

·
Registered
Joined
·
11 Posts
I managed to get AIO tweaks going!
This post helped me a lot.
What I did was basically the ID7v2 method with the ID7 files.
First I connect via serial.
Then I installed the FW over my current FW (it was fine reinstalling the same FW number, as expected).
At the end of this, in my terminal I had root access.
I had to create the directories first with:

mkdir -p /mnt/data_persist/dev/bin/

before running

cp -r /mnt/sd*/XX/* /mnt/data_persist/dev/bin/; chmod +x /mnt/data_persist/dev/bin/autorun; /mnt/data_persist/dev/bin/autorun

Thanks for all your help @Tristan-cx5 !
 

·
Registered
Joined
·
294 Posts
Hello
Did someone manage to get into the Connect 2 (2019) system like the friends on Connect 1 (before 2019) with AIO-Tweaks?
This would allow with some linux knowledge (if Connect 2 is also under linux) to create customization scripts.
Thank You
 

·
Registered
Joined
·
4 Posts
Silly questions, hoping someone can help sort me out, please. I have a '17 CX-5 running 59.00.504 NA N (with original non-upgraded USB ports) that I've successfully performed the serial connection to successfully install AIO tweaks on a few years ago. From what I can see, I had installed AA v1.12 at the time.

While things are "generally" working with my Android 11 phone, behaviour with Google Maps and Spotify can sometimes be a little wonky, while I see the audio stuttering that I sometimes encounter whilst using Spotify is something others have experienced as well. Rebooting either/both the phone and the CMU seem to clear things up temporarily.

1) Would it be worth the trouble to update to AA 1.14b?
2) Would there be a point to updating the CMU FW, or would that break things without the upgraded USB ports?
3) There's someone, not on this forum, claiming to be RW, and is asking for $30 for AA v1.15b. Assuming this is legitimate, is there anything I should be wary of before I attempt an install?

Thanks!
 

·
Registered
Joined
·
2,535 Posts
re 1: 1.14b is not available here in the forum. Latest AIO Version is AA 1.13.

re 2: For AIO AA is 59.00.502 said to be the most stable version. As yours is just slightly different, I would stick to your version.

If I were you, I simply would install AIO AA 1.13 over your installed AIO AA 1.12. But still it will be more instable than the official AA/CP with the new hub/cables. And AIO AA Wiresless is laggy/instable - so stick to the cable connection.
 
9101 - 9120 of 9420 Posts
Top