2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

8861 - 8875 of 8875 Posts

·
Registered
Joined
·
8 Posts
I just upgraded my 2019 Yaris from 59.??? to .335 a few days ago, am I understanding correctly that I can no longer use any of the tweaks? I would like to enable the touch screen and maybe change the colors and logo back to Toyota.

EDIT: reading a bit more, if I reinstall .335 on top of itself or even install .352 and run the ID7 serial access after the install will that allow tweaks via usb?
 

·
Registered
Joined
·
8 Posts
1. No. ID7/Autorun files will be deleted by the install of .335/.352/.367. Thats why you have to do ID7v2 directly after the install of .335/.352 (not possible at .367): www.mazdatweaks.com/id7
2. .335 and .352 are located in another folder - search for folder "z develop -> outdated" - direct link: HiDrive
My full process was: Factory reset via aio program, install autorun, verify autorun was active with dry script, install tweaks, upgrade firmware from 59.4xx to 70.100.
I was under the impression that because I had that autorun recovery active before upgrading, I could install the tweaks via USB like before on 70.100, but when plugging in usb and waiting nothing happens/aio prompt on infotainment doesnt show up. Did I do something wrong/mistaken?
 

·
Registered
Joined
·
1,726 Posts
@tms2010 : Correct. ID7v2 serial access process for .335/.352 allows you to install tweaks via usb: www.mazdatweaks.com/id7

@Zyphur : You did not do something wrong. Your assumption is correct. I do not know why it did not work for you. Have you used the same FAT32 formatted usb stick as before? Do so. Compile the tweaks, copy them to the usb stick and rename the tweaks.sh to run.sh - perhaps this works.
 

·
Registered
Joined
·
8 Posts
@Tristan-cx5

Thanks. So even though I didn’t do the ID7 when I initially upgraded to .335, if I instal .335 on top of itself or upgrade to .352 and do ID7 it will still work? Depending where I read some places make it sound like I can’t do it anymore.
 

·
Registered
Joined
·
19 Posts
I'm unable to make a serial connection and some help is appreciated. I've done the following steps, but PuTTy only beeps when executing.

  1. The CP 2102 is recognized and Windows 10 assigns it to COM3
  2. The COM3 port and the baud rate are correctly entered
  3. The RX/TX pins are connected to the wiring harness. A paperclip was necessary to make contact with the CMU pins
  4. There is continuity between the CP2102 and the wires connecting to the harness
  5. I've swapped the RX/TX pins
It seems my setup is correct but I can't get PuTTY to connect and I appreciate the help.
 

·
Registered
Joined
·
19 Posts
Unfortunately, there's nothing to share. The Putty screen does not change. A beep is all that happens. Every time I select "open", it just beeps. I've got the car back together for now, but if there's any chance of getting figured out, I'll again try the serial connection.

Without the connection, my only option is purchasing the Mazda kit.

I appreciate the help.
 

·
Registered
Joined
·
7 Posts
I'm unable to make a serial connection and some help is appreciated. I've done the following steps, but PuTTy only beeps when executing.

  1. The CP 2102 is recognized and Windows 10 assigns it to COM3
  2. The COM3 port and the baud rate are correctly entered
  3. The RX/TX pins are connected to the wiring harness. A paperclip was necessary to make contact with the CMU pins
  4. There is continuity between the CP2102 and the wires connecting to the harness
  5. I've swapped the RX/TX pins
It seems my setup is correct but I can't get PuTTY to connect and I appreciate the help.
Silly question, but did you make a good ground connection also?
 

·
Registered
Joined
·
19 Posts
I figured out the putty problem. Now I'm stuck on the serial connection procedure. Installed software is 70.000.21 NA N.

Must the serial commands be issued immediately after a firmware update/install, and before a CMU restart?
 

·
Registered
Joined
·
1,726 Posts
Not for 70.00.021. If you want to do the serial access at this version, stick to: www.mazdatweaks.com/serial

If you want to update to .335 or .352, you have to paste the commands via serial access directly after the firmware update, before the reboot. See www.mazdatweaks.com/id7 for details.

Edit: In another post you wrote, that you have 70.00.352 installed. Here you wrote 70.00.021. Please check which version is really installed... just to get the fitting info.
 

·
Registered
Joined
·
19 Posts
Edit: In another post you wrote, that you have 70.00.352 installed. Here you wrote 70.00.021. Please check which version is really installed... just to get the fitting info
When I couldn't get anywhere, I upgraded to 70.00.352, which I've successfully installed and used AIO-Tweaks. But, now I need to figure out how to get AA working. The AA thread has me so confused, I don't even know where to start. Will you help?

THanks,
 

·
Registered
Joined
·
1,726 Posts
I can not, as I do not know. @Radarwild is the developer of the AA True-go 1.14 and 1.15 (one of them might be capable to work at .352) - check his threads for details or ask him there.
 
8861 - 8875 of 8875 Posts
Top