2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

8521 - 8536 of 8536 Posts

·
Registered
Joined
·
17 Posts
HELLO FRIENDS, CAN I DOWNLOAD FROM FW 59.00.504 TO .502 AND THEN INSTALL THE ID7? OR FIRST INSTALL THE ID7? AND THEN UNDER VERSION TO MAKE IT WORK WELL ANDROID AUTO
 

·
Registered
Joined
·
1,202 Posts
Please do not shout / not use CAPS LOCK.
You can downgrade from .504 to .502 (but not below .502). If you want to install ID7 at any of these 2 FW versions, you have to do the serial access - see www.mazdatweaks.com/serial .
If you currently have a FW installed, that is smaller/lower than 59.00.502 (but minimum FW 55), you can install ID7 from AIO via USB and then update to e.g. 59.00.502. After this FW update you still will be able to install AIO tweaks like Android Auto Tweak. At this procedure you do not have to do the serial access. But you can not downgrade from 59.00.502 (or higher) to a version below 59.00.502.
 

·
Registered
Joined
·
20 Posts
@IZZY76 download AA Tru_go v1.14 into comp first. I would suggest reinstall fw59.00.502 adr and redo serial connection for id7 then once completed successfully install AA Tru_go v1.14 tweaks into your car system and test (fresh clean system). If its working u can install other tweaks afterwards. (Check your fuse as well if its not blown).
How do i reinstall the same FW ?
 

·
Registered
Joined
·
6 Posts
So I've went down to 59.0.502 with no trouble. Dry run.sh still shows success. So I believe id7 v1 that I installed as the very first thing is active. Nothing else I've tried from aiotweaks will run.

I've been searching for a pointer to a USB Ethernet adapter known to work, any tips there?

I was hoping to ssh via Android adb since I have a developer tablet and cables for that, but I can't get the adb tweak to run either.

Really appreciate any advice on getting tweaks back up and running, easiest way to set up for ssh access if clearing logs via ssh is the correct path.

Thanks in advance!
 

·
Registered
Joined
·
20 Posts
How do i reinstall the same FW ?

Ok i fixed the problem by doing a system reset through the cmu. i then accessed the cmu via serial connection again and whuala. Tweaks work again immediately. I also installed the new AA version 1.4 and it seems alot clearer and readable.

Thanks to all who helped
 

·
Registered
Joined
·
6 Posts
Yes, the id7 v1 recovery from aio v.2.8.6 was the very first thing I installed, all by itself, then did a dryrun to verify. I installed the AA 1.13 that was included with the latest AIOTweaks v2.8.6.

Nothing else is connected to the car, no sticks, no bluetooth etc., drives fat32 formatted from Linux, and also tried fresh fat32 formats from Windows to be sure.

So it sounds like maybe I need to clean out logs? Since the dryrun test autorun script is running, is there a way to feed it log deletion? Or I guess I need to figure out how to SSH in...
My USB adapter showed up yesterday. The sshd is still set to 36000 and key auth only, though I had installed the ssh_bringback script previously.

278086


Dryrun above indicates that my id7 v1 install stuck around. But since the sshd config was reset, and I can't get any tweaks to run, I tried embedding a log cleanup in the run.sh:
Code:
# disable watchdog and allow write access
echo 1 > /sys/class/gpio/Watchdog\ Disable/value
mount -o rw,remount /

# remove dumps
rm -f /tmp/mnt/data_persist/log/dumps/*.bz2
and it at least ran through to the success message. No change after, still can't get a tweak to run.

If it's truly a log cleanup that's preventing the tweaks.sh from executing successfully, I'm hoping I can hit on the right incantation of cleanups to embed in the run.sh to get me there w/out having to crack the dash and try a serial access hack.

I would greatly appreciate advice for how I might get this going again. Thanks!
 

·
Registered
Joined
·
5 Posts
[QUOTE = "Gusbar, bài đăng: 2492987, thành viên: 554533"]
BẠN CÓ THỂ CẬP NHẬT TRỰC TIẾP TỪ FW 33.00.500 ĐẾN 59.00.441NA KHÔNG? CÓ THỂ CÀI ĐẶT TWEAKS MÀ KHÔNG LÀM KẾT NỐI SERIES ID7 KHI CÀI ĐẶT PHIÊN BẢN SIÊU ƯU ĐÃI.
[/TRÍCH DẪN]

Bạn up FW31 rồi lên FW 70 sẽ cải thiện hơn
 

·
Registered
Joined
·
5 Posts
[QUOTE = "Asulimany, bài đăng: 2492283, thành viên: 556254"]
Chào
Tôi có cx5 fw v51
Tôi có thể cài đặt android auto không View attachment 277841
[/TRÍCH DẪN]
được, nhưng bạn nên nâng cấp phần mềm lên FW 59.00.502
 

·
Registered
Joined
·
5 Posts
[QUOTE = "Gusbar, bài đăng: 2491447, thành viên: 554533"]
Xin chào ai đó có thể giúp tôi với, tôi có phiên bản 70.00.335 NA, với ID7 V2, nếu tôi cài đặt AA nếu nó hoạt động? hoặc là nó không tương thích với phiên bản này ?.
[/TRÍCH DẪN]

Xe của bạn đã có carplay chưa? Nếu không, tôi nghĩ nó sẽ hoạt động. Tôi đã thử nó trên xe hơi với Carplay nhưng nó không hoạt động tốt lắm.
 

·
Registered
Joined
·
6 Posts
My USB adapter showed up yesterday. The sshd is still set to 36000 and key auth only, though I had installed the ssh_bringback script previously.

View attachment 278086

Dryrun above indicates that my id7 v1 install stuck around. But since the sshd config was reset, and I can't get any tweaks to run, I tried embedding a log cleanup in the run.sh:
Code:
# disable watchdog and allow write access
echo 1 > /sys/class/gpio/Watchdog\ Disable/value
mount -o rw,remount /

# remove dumps
rm -f /tmp/mnt/data_persist/log/dumps/*.bz2
and it at least ran through to the success message. No change after, still can't get a tweak to run.

If it's truly a log cleanup that's preventing the tweaks.sh from executing successfully, I'm hoping I can hit on the right incantation of cleanups to embed in the run.sh to get me there w/out having to crack the dash and try a serial access hack.

I would greatly appreciate advice for how I might get this going again. Thanks!
LOL, read all these threads, never saw it mentioned - perhaps I just missed it - Once you are depending on id7, you need to change any generated or supplied tweaks.sh files to run.sh files 🤦 Lightbulb finally went on when I found the option in AIOTweaks to generate run.sh rather than tweaks.sh

Doing that, and changing the AA 1.14b tweaks.sh to run.sh worked like a charm.
 

·
Registered
Joined
·
41 Posts
I just installed the aio 2.8.6 in my car and at the moment of turning the car off and on, it misconfigured the time it added 55min more and

Enviado desde mi SM-N960F mediante Tapatalk
 
8521 - 8536 of 8536 Posts
Top