2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

7741 - 7753 of 7753 Posts

·
Registered
Joined
·
2 Posts
Dude I was so hyped when I read this yesterday but now i'm sad! Went in to get my car fixed today (AIO was restored) and mentioned something about the bluetooth being skippy, and I guess he listed it as a problem since they gave me back my car with v70.0.335 installed.. Kind of curious if it's feasible to make having a serial connection easy. Also, have any plans on adding the i-dm into the possible apps?
 

·
Treveloper
Joined
·
528 Posts
  • If I want to update, do I simply put the content of AA-v1.12 in a USB and update it as usual?\
Yes
  • Do I need to uninstall the previous version first then only update AA-v1.12? What if I want to return back to AA-v1.11
No. Then you install AA 1.11, the installer is designed to overwrite the last version but if you have issues you can try uninstalling AA. I doubt you will want to go back anyway because the bug fixes are pretty solid.
As for the volume bar thing that is much more difficult to accomplish then it sounds. The official AA has the luxury of communication with every other part of the system while our version is a hacked implementation running on top of the GUI so you can't really bring just one piece of the back layer (the vol bar) up in front of the top surface (or at least I don't know how to).
 

·
Registered
Joined
·
32 Posts
No. Then you install AA 1.11, the installer is designed to overwrite the last version but if you have issues you can try uninstalling AA. I doubt you will want to go back anyway because the bug fixes are pretty solid.
Sorry, I don't follow... I have AA V1.11 already installed. If I want AA V1.12, I just put the content of the zip in a USB and install it?

FYI, it is currently running so well, really happy with it especially with the latest AA apk 4.7.593814
 

·
Registered
Joined
·
499 Posts
@san098: Correct, just put 1.12 on an USB stick (FAT32 formatted) and install it over your already installed 1.11. If you want to go back to 1.11 afterwards, just install 1.11 over the then installed 1.12. At every installation the installed version will be deleted/overwritten.

If you want to uninstall AIO AA completely (or want to do this step between the update from 1.11 to 1.12), go to AIO and choose the red square for deinstallation aside the AA tweak, compile this uninstaller of the tweak and "install" it in the car. Afterwards AA will be deleted/uninstalled completely.
 

·
Registered
Joined
·
108 Posts
Head Up Display Feedback on 1.12.

Thanks to @Trezdog44 for keeping this going.
A quick little bit of navigation today gave turn by turn and distance countdown in miles. However, after 0.1mi the display on the head-up reverts to meters (m). The screeen display show the same numeric value with yds tacked on. Other than that working well. Music playback started automatically as it should.
 

·
Registered
Joined
·
32 Posts
I installed V1.12 but having a problem with the GPS, how do I include those options that are available in AIO installer?
273682


Update
Removing the SD card seems to have fixed the GPS issue. Maybe you guys can point out which file i need to edit in V1.12.

Everything running well.
 

·
Registered
Joined
·
2 Posts
Hello there! So as I mentioned above, I went to Mazda a few days ago for a problem about my AC link getting disconnected, and I mentioned the bluetooth was sluggish. Not only did they update me to the latest version, making it harder to install AIO, but it seems that the bluetooth problem didn't get fixed at all.. Been thinking about it for a while now, and I still think getting a serial connection seems like way too scary of a process for me, is there no hope for me in the future without a serial connection? Also, wanted to ask again about the i-dm application if there's any interest in bringing it out for the AIO tweak.
 

·
Registered
Joined
·
499 Posts
@san098: You could try to edit the values "GPS reverse", "WiFi Transport" and "carGPS" from true to false or vice versa. They are located in this file: config/androidauto/data_persist/dev/bin/headunit.json
A least that was the way to do it in earlier standalone versions.

@VanAxelaIII : Have you tried to disconnect the Bluetooth module (simply remove the connector and plug it in again). I think recently I read that someone solved BT issues this way.
 

·
Registered
Joined
·
27 Posts
Hey guys I am almost ready to release an AIO update but I want a little feedback on this version of AA 1.12 because it may be a while before the next update.
So if you try that please give me some feedback so I can get this release out.
Hi. Tested it today...
Mazda3 (2015) v59.00.545
Looks good like previous version.
Problems:
1. Music is very choppy during Audio navigation from Waze
2. Audio navigation is also choppy (don't know why)
3. And a previous problem is still here, I can't listening to radio and hear the Audio navigation from Waze. It started from version 1.11, maybe you can fix it ?
Thanks
 

·
Registered
Joined
·
6 Posts
Hi. I am after tests V1.12 on CX5 2016 70.0.100EU.
Unfortunately, there is the same problem as with V1.11 - after AA installation, the Communication module does not import contacts from a telephone via BT. BT audio connection does not work.
Connecting the phone via USB does not start AA (in v1.10 it worked). Connection on a standard USB input only displays the Black Screen, from which you can exit to MZD Connect with the Home or Entertainment buttons.
BTW: So far the best working version for me is 1.10, but BT audio stream from phone to AA didn't work there. The phone recognized MZD Connect as an audio receiver, but there was no sound from the car.
Question: will going back to 59.00.545 solve problems?
 

·
Registered
Joined
·
10 Posts
BLUF: Suddenly USB stick isn't recognized to install any tweaks. It worked to uninstall some stuff today but now I can't seem to do a thing when I try to put back on. I had originally installed things about a year ago... today I used 2.8.4-1.

Any help appreciated.

I have a 2015 Mazda 3.
I bought it used about 2 years ago. When I got it... it was on firmware V59.* I had to do the serial port thing etc. to get access to apply tweaks over my USB.

The only reason I initially found out about this site and the great community is I had the phantom ghost touch issue with touch screen and wanted to find a way to disable touch. Then I learned about android auto and was stoked to fix one thing and get an awesome feature I've used a lot over the past year.

Someone had posted a zip a while back that disabled the touchscreen completely:
Fully-Disable-Touchscreen.zip (not actually attaching zip here but can). That worked to disable (doesn't work for android auto but does for mazda software).

I recently got the thing in the mail that Mazda was going to fix the screens on these cars as it is a known issue. I therefore wanted to re-enable touch so that the hardware problem presented itself again. I ran that zip again and it properly re-enabled touch.

For the hell of it I said to myself... maybe I should remove android auto as well as they could see that and argue I did something wrong or invalidated warranty. So I downloaded 2.8.4 AIO (i think when I intially installed a year or so ok it was 2.7.*). I ran the uninstall and removed android auto. After that I went to double check I had the ID7_recovery scripts installed. I remember running that when I initally did install.

When running that it didn't seem to work right. The screen would show the installer (ask me to click install, uninstall, skip... but wasn't reponsive to my touch). Click skip confirmation when making usb stick files didn't seem to help. Eventually just being patient and clicking "install" on my screen it started to work and then said there was a problem, it had aborted, and to remove my stick.

Eventually I just gave up and went to dealer. They did NOTHING. No fix yet and have not touched software/harder. Just took my info and said they'd call me back later this week or next to get the fix in. As I do NOT want the touchscreen issue myself while I wait I went to reinstall Android Auto and to disable touch... but I can't.

For whatever reason the USB stick doesn't seem to be recognized at all. I've tried formatting and rebuilding a few to do different things and my car doesn't seem to recognize the stick at all.

Sorry for wall of text... just trying to give context and not waste any helpful replies time.
Do I need to rip the unit out and serial port all over again? I hate messing with the trim like that. Any other thoughts?
 
7741 - 7753 of 7753 Posts
Top