2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
7561 - 7580 of 9290 Posts

·
Registered
Joined
·
2 Posts
Hello dear All,
I've been following the thread for quite a while and must thank you!
I had installed ID7 via USB before upgrading to 59.000.445. EU and was waiting for my warranty to expire
AND THEN
Today I finally got my car back from a mazda center for a radio problem. They solved it but to my horror they upgraded to 70.000.335.

My understanding is that ID7 ver1 has been removed with this upgrade and that I lost USB and even serial access. I did not verified but it should be take for granted right?

So it seems my only option is this one I'm asking for:
is it possible to downgrade from 70.000.335 to 59.000.501 to gain at least serial access?
I've only read about some users on older systems and not this last fw.
 

·
Registered
Joined
·
2,313 Posts
...they upgraded to 70.000.335.
My understanding is that ID7 ver1 has been removed with this upgrade and that I lost USB and even serial access. I did not verified but it should be take for granted right?
So it seems my only option is this one I'm asking for:
is it possible to downgrade from 70.000.335 to 59.000.501 to gain at least serial access?
I've only read about some users on older systems and not this last fw.
Correct 70.00.335 removes the old ID7 and serial access.

To gain serial access & USb installability back at FW 70.00.335 follow the ID7v2 instructions at www.mazdatweaks.com/id7 . Short: Install FW 70.00.335 again (over the existing 70.00.335) and make serial connection after/during update process - according to ID7v2 instructions. I wrote my field report here.
 

·
Registered
Joined
·
2 Posts
FW 70.00.335 EU to hell and back

Ok. Time to make the serial work...I wish it was easier but if there is no way to recover the old id7...damn
I will definitely try to following the mazdatweaks serial guide to the letter.

What about the tweaks? You reported that most stuff works, just a couple did not.

Today I tested some AIO 2.8.4-1 tweaks ("my set") on FW 70.00.335 EU. Here are the results:

Successful:
  • Touchscreen While Moving (MZD)
  • Reverse Camera Safety Warning
  • No More Beeps
  • Speedometer (Digital Bar Layout)
  • Semi-transparent parking sensor graphics
  • (not from AIO, but single tweak: colored parking sensor graphics)

Not successful:
  • No More Disclaimer
  • Order of Audio Source List
    They have to be adapted to FW 70.00.335 in the next AIO version. I already sent the requested systemApp.js to aioATmazdatweaks.com Trez answered very fast and with a little adaption of the tweaks.sh I also tested these both tweaks successfully positive.

Edit: Please keep in mind, that AIO 2.8.4-1 is not tested/approved by it`s developers for FW 70.00.335. This might happen with a future AIO version.
I provide this other quote for others interested in make those 2 work

@taron93:
For the no more disclaimer and order of audio source tweaks from AIO 2.8.4-1 to work on FW 70.00.335 search in tweaks.sh (at the USB stick, after you/AIO copied the tweaks there) and replace "$_VER_EXT -le 100" with "$_VER_EXT -le 335" (e.g. via Notepad++) and both tweaks shall be installed & work fine. At least they did for me.
Is it possible to put AIO AA? I do not want to install the official kit.
 

·
Treveloper
Joined
·
534 Posts
If I have OEM Fuel Economy Monitor on screen when I shut down the car (stop the engine), when I restart the car it comes back to it.
In case of Speedometer on screen when I stop the engine, the home screen comes back when I restart the car, not Speedometer.
Is this the way it is supposed to be?
Or am I missing something?
The system does not know about the existence of the Speedometer app so when it sees that the last screen was speedometer it defaults to the home screen. There might be a workaround for this but I don't really have much time to find it. I tried a few times to figure it out in the past but was unsuccessful.
 

·
Registered
Joined
·
25 Posts
The system does not know about the existence of the Speedometer app so when it sees that the last screen was speedometer it defaults to the home screen. There might be a workaround for this but I don't really have much time to find it. I tried a few times to figure it out in the past but was unsuccessful.


Thanks Trezdog44.
Makes a lot of sense.
I thought I may have messed up something.
Thanks again.
Yushi


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
32 Posts
I have terrible audio stuttering when using waze. I factory reset it, removed everything and just put a few small tweaks like eliminating beeps and the backup camera mod and AA. I had heard the wifi can cause problems so I removed that and disabled it through the car. But for some reason it is still running even when removed/off. Is there any other way to disable the wifi?
 

·
Registered
Joined
·
35 Posts
Was anyone here able to copy a custom app to casdk/resources/aio/mzd-casdk/apps/ (? the folder where the CASDK apps and the "app.js" live)?

Even after "mount -o rw,remount /" I get the error "File system is read only" or something. :(
 

·
Registered
Joined
·
2 Posts
Hi everyone. after installing tweaks MZD-AIO v.2.8.4-1 on FW 56.00.230A, have stopped working commander and touch screen , the diagnostics mode are also not included now. I suspect the USB also doesn't work anymore. what are the options now?
 

·
Treveloper
Joined
·
534 Posts
Was anyone here able to copy a custom app to casdk/resources/aio/mzd-casdk/apps/ (? the folder where the CASDK apps and the "app.js" live)?
Even after "mount -o rw,remount /" I get the error "File system is read only" or something. :(
Code:
mount -o rw,remount /tmp/mnt/resources
# then copy the files to
cp /files/you/want/to/copy /tmp/mnt/resources/aio/mzd-casdk/apps/
 

·
Registered
Joined
·
3 Posts
Hi,

Quick question about AA. Whenever I receive incoming call on AA there is no sound. If there is some music playing in the background it stops/mute and there is notification on the screen who is calling.

Any idea how to solve it?
 

·
Registered
Joined
·
2,313 Posts
You could update to a NA (North America) firmware (FW) version 55 or 59.00.441 from this NA folder - e.g. the v55 with the highest number. Stick to the word to the latest update manual. Everything on your own risk (CMU is approx. worth 1000 USD). Then install software AIO to your PC and with that the tweaks via USB stick in the car. Recommended to install Autorun/ID7-Tweak from AIO top left corner first. If you install FW 59.00.502 or higher directly, you can install tweaks via USB only after serial access, which is much more effort - hence I would not recommend it for you, as you only want to install tweaks.
 

·
Registered
Joined
·
14 Posts
Hi everyone

I cannot get AA to work over wifi on my Mazda2 . Over USB it works fine.
I'm running firmware 59.00.502 EU N with latest AIO2.8.4-1. It's compiled with AA wifi support.

The head unit connects successfully with my Huawei Mate 20 pro access point. The head unit gets the ip 192.168.43.187.
Then on the AA android app i enabled developer settings and enabled “Start Head unit Server”.
Nothing happens after that. Also if I wait 10min.
Also tried to start AA manually on my car, but it hangs on the splash screen.

Is there something i'm missing?
Thanks
Hi All,
Did somebody know how to fix this issue when AA is working over USB but not with WIFI connection?
 

·
Registered
Joined
·
13 Posts
Hi All,
Did somebody know how to fix this issue when AA is working over USB but not with WIFI connection?

If you find out I would love to know, tried for hours to get my AA to work over Wifi and nothing I did seems to work. It works pretty well on the USB cable, but the port doesn't put out much current so the phone effectively does not charge when it is plugged in.
 

·
Registered
Joined
·
23 Posts
Which GPS signal does AA use in navigation and can we change it? I recently installed a new tint on my car and it's having issue with the signal, but if I don't connect to AA my phone's GPS works just fine.
 
7561 - 7580 of 9290 Posts
Top