2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
6401 - 6420 of 9424 Posts

·
Registered
Joined
·
60 Posts
Hi, after applying the tweaks (which ones you have?), do you still have a carplay icon in top left corner on MZD Connect when the iPhone is connected?

Thanks.
The CP/AA icons disappear when Tweaks are installed, but like the other guy said, you can hold HOME to return or if it's playing music, press the Audio button or go to applications and select AA/Car Play.
I'm on NA with official kit running v70 and tweaks installed.
Everything seems to work except that AA/CP icon, and when AA is running, in the audio sources menu, CD is white like there's a CD in my system, selecting it does nothing.
I have these tweaks installed:
Touchscreen While Moving
No More disclaimer
reverse camera safety warning
improved list loop
shorter delay mod
no more beeps
order of audio source list
pause on mute
remove message reply
boot animation (remove)
bigger album art
change blank album art frame
 

·
Registered
Joined
·
185 Posts
Hi to all.
I'm new for all this stuff. And I have a few questions... I will start from scratch.
I have Mazda 3 (2015).
1. CMU version was 30.00.330 and I update it to 59.00.449A in two steps. First to EU 31.00.100A and second to EU 59.00.449A like explained here. All went smoothly.
2. I installed a few tweaks via MZD-AIO-TI v2.8.0. All went smoothly.
3. My CMU have Hebrew interface and also have Hebrew keyboard.
4. Navigation programs installed on my phone (OnePlus 5T): Google Maps and Waze
5. My phone paired to CMU via BT and have 4 options (Use for):
* Phones calls
* Media audio
* Contact sharing
* Text Messages

QUESTIONS:
1. Why after using "Android auto" it always disable Phones calls from paired Mazda. To fix it I always need to Force Stop BT in my phone and start BT again.
It possible permanently fix this problem ?

2. Sometimes happens and I cant start "Android auto" not automatically and nor manually from CMU. In this case I need switch engine off, waiting some time and start again.
Maybe it possible to restart "Android auto" without switching off engine ? Some combination of buttons or something ?

3. in the both Google Maps and Waze (from "Android auto") I can't do voice search, the voice always tell me that it need to do web search and can't right now... Why ? Possible to fix ? (phone always connected to 4G).
Also I can't do voice search in Hebrew, only English even though in the phone I can do voice search in Hebrew in the Waze app.

4. in the both Google Maps and Waze (from "Android auto") I have only English and Russian keyboard even though in CMU and in the phone I have also Hebrew. Why ? Possible to add Hebrew vkb ?

5. I never succeed to run ScreenCast tweak, don't know why. Some detailed steps ?

6. Fuel Consumption Tweak. Additional display of KM / L (or MPG). Can't find where it should show me ?

7. If I want to remove only one or two tweaks, what the right steps ? First I need to remove all installed tweaks and after this recompile new set of tweaks and install them ? Or just compile remove files only for specific tweak ?
Same if I want to add some new tweaks ? Or I just can compile one new tweak and install it ?

Thanks
I have the same phone. op 5t. Phone calls option disabled after a while. That's a bug appeared after the last security patch and it's not only for the car. I can't even use my bt headphones to make phone calls. Easiest fix is toggling airplane mode on and off. That will fix the issue for a while but it comes back. There's a discussion page on oneplus forums for that issue.

I am also facing rarely the android auto not starting automatically issue. Yo don't need to switch engine off. Remove the usb cable from phone. Hold back + nav + mute buttos for about 10-15 seconds. That will reboot the whole system and you will be good to go. After the contact sync done, reconnect the usb cable.
 

·
Registered
Joined
·
44 Posts
fyi - if you are on FW 70, do not install pause-on-mute tweak from AIO 2.8.0. It is not working properly (mp3 from usb stick) - at least in my tests. If its already installed, just uninstall it via AIO.
Yes, you are right. But anyway, this embedded “pause on mute” is not working within CarPlay.
 

·
Registered
Joined
·
8 Posts
fyi - if you are on FW 70, do not install pause-on-mute tweak from AIO 2.8.0. It is not working properly (mp3 from usb stick) - at least in my tests. If its already installed, just uninstall it via AIO.
v70 includes pause-on-mute without needing to tweak it. It's even better than the tweak because it works across the whole system (nav, apps, etc) not just when you're using the music player.
 

·
Registered
Joined
·
4 Posts
Quick question guys, i have v55.753_Tweaks_USB_Speed_Disclaimer_WiFi installed from about 3 years ago and havent done anything with it since. Do i need to uninstall them prior to using the AIO tweaks or will the AIO Tweaks install right over top of them. Also does anyone know how to remove them if i need to.

Thanks a lot in advance
 

·
Registered
Joined
·
17 Posts
Hi to all.
I'm new for all this stuff. And I have a few questions... I will start from scratch.
I have Mazda 3 (2015).
1. CMU version was 30.00.330 and I update it to 59.00.449A in two steps. First to EU 31.00.100A and second to EU 59.00.449A like explained here. All went smoothly.
2. I installed a few tweaks via MZD-AIO-TI v2.8.0. All went smoothly.
3. My CMU have Hebrew interface and also have Hebrew keyboard.
4. Navigation programs installed on my phone (OnePlus 5T): Google Maps and Waze
5. My phone paired to CMU via BT and have 4 options (Use for):
* Phones calls
* Media audio
* Contact sharing
* Text Messages

QUESTIONS:
1. Why after using "Android auto" it always disable Phones calls from paired Mazda. To fix it I always need to Force Stop BT in my phone and start BT again.
It possible permanently fix this problem ?

2. Sometimes happens and I cant start "Android auto" not automatically and nor manually from CMU. In this case I need switch engine off, waiting some time and start again.
Maybe it possible to restart "Android auto" without switching off engine ? Some combination of buttons or something ?

3. in the both Google Maps and Waze (from "Android auto") I can't do voice search, the voice always tell me that it need to do web search and can't right now... Why ? Possible to fix ? (phone always connected to 4G).
Also I can't do voice search in Hebrew, only English even though in the phone I can do voice search in Hebrew in the Waze app.

4. in the both Google Maps and Waze (from "Android auto") I have only English and Russian keyboard even though in CMU and in the phone I have also Hebrew. Why ? Possible to add Hebrew vkb ?

5. I never succeed to run ScreenCast tweak, don't know why. Some detailed steps ?

6. Fuel Consumption Tweak. Additional display of KM / L (or MPG). Can't find where it should show me ?

7. If I want to remove only one or two tweaks, what the right steps ? First I need to remove all installed tweaks and after this recompile new set of tweaks and install them ? Or just compile remove files only for specific tweak ?
Same if I want to add some new tweaks ? Or I just can compile one new tweak and install it ?

Thanks
I have the same phone. op 5t. Phone calls option disabled after a while. That's a bug appeared after the last security patch and it's not only for the car. I can't even use my bt headphones to make phone calls. Easiest fix is toggling airplane mode on and off. That will fix the issue for a while but it comes back. There's a discussion page on oneplus forums for that issue.

I am also facing rarely the android auto not starting automatically issue. Yo don't need to switch engine off. Remove the usb cable from phone. Hold back + nav + mute buttos for about 10-15 seconds. That will reboot the whole system and you will be good to go. After the contact sync done, reconnect the usb cable.
Same problem with music here, not playing back again when the voice commands from navigation.

Also the phone call not working
 

·
Registered
Joined
·
27 Posts
I have the same phone. op 5t. Phone calls option disabled after a while. That's a bug appeared after the last security patch and it's not only for the car. I can't even use my bt headphones to make phone calls. Easiest fix is toggling airplane mode on and off. That will fix the issue for a while but it comes back. There's a discussion page on oneplus forums for that issue.

I am also facing rarely the android auto not starting automatically issue. Yo don't need to switch engine off. Remove the usb cable from phone. Hold back + nav + mute buttos for about 10-15 seconds. That will reboot the whole system and you will be good to go. After the contact sync done, reconnect the usb cable.
Thanks for clarification about Calls option.
About restart CMU, I found it can restart by pressing NAV + mute, without back button... But in all times when I tried this, it's not helped..
What the differences between pressing 3 buttons to what I did? And can I do this while driving?
 

·
Registered
Joined
·
29 Posts
Thanks for clarification about Calls option.
About restart CMU, I found it can restart by pressing NAV + mute, without back button... But in all times when I tried this, it's not helped..
What the differences between pressing 3 buttons to what I did? And can I do this while driving?
Hello, for restarting CMU, press the 3 buttons of the image at the same time during about 10s and the cmu restarts.
Engine off not always restarts the cmu, only it is restarted if car is off during some time (some minutes i think).
You can restart the CMU without problems while you are driving...I usually do.
 

Attachments

·
Registered
Joined
·
17 Posts
Thanks for clarification about Calls option.
About restart CMU, I found it can restart by pressing NAV + mute, without back button... But in all times when I tried this, it's not helped..
What the differences between pressing 3 buttons to what I did? And can I do this while driving?
Hello, for restarting CMU, press the 3 buttons of the image at the same time during about 10s and the cmu restarts.
Engine off not always restarts the cmu, only it is restarted if car is off during some time (some minutes i think).
You can restart the CMU without problems while you are driving...I usually do.
I always restart the CMU by pressing just Nav+Mute buttons.
I think depends on the CMU version is with 2 or 3 buttos.

New FW is just with 2 buttons
 

·
Registered
Joined
·
185 Posts
Thanks for clarification about Calls option.
About restart CMU, I found it can restart by pressing NAV + mute, without back button... But in all times when I tried this, it's not helped..
What the differences between pressing 3 buttons to what I did? And can I do this while driving?
I haven't tried the nav + mute button combination. I guess it's the same as nav + mute + back. It reboots the system starting with mazda logo and yes you can do this while driving.
 

·
Registered
Joined
·
27 Posts
Thanks guys. Yep, 2 or 3 buttons probably do the same things. But it still not help me when AA suck while using it via WIFI...
When I disconnect server and exit app on the phone and CMU, I still have message in the notification bar of my phone:
Google Play services
Android Auto
Connected to your car
In this case I can't reconnect/restart AA in my car not via wifi and not via usb cable...
I also can't remove this message at all... Tried from the phone setting - apps - Force stop on AA app, but it don't do nothing, it just not stop this service. I also tried some different apps for killing processes, but it also don't do nothing... Only after reboot of my phone I can restart and use AA again (wifi or usb)... It's not so convenient..

Any idea how to stop it on the phone without reboot the phone?
Thanks
 

·
Registered
Joined
·
5 Posts
I installed AIO 2.8 in Mazda firmware 59.00.545. I used Android Auto via usb cable, everything worked fine. But after disconnected the usb cable, the Mazda connect was showed black screen every time. How to solve this problem?

Sorry for my bad language.
 

·
Registered
Joined
·
6 Posts
Hey guys this might have been asked already, sorry in advance lol, but does the AIO tweak v2.8 work on mazda infotainment v70 which I just installed for Carplay. I want to override the screen lockout while driving. Thanks.
 
6401 - 6420 of 9424 Posts
Top