2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
60 Posts
I have 50.00.504 NA I've done the serial method to put MZD AIO.
I would like to update to 540, can I just load up the 2 firmware files and do it?
Also, is there a dedicated forum for MZD AIO stuff rather than this 591 page thread?
 

·
Registered
Joined
·
60 Posts
I have 50.00.504 NA I've done the serial method to put MZD AIO.
I would like to update to 540, can I just load up the 2 firmware files and do it?
Also, is there a dedicated forum for MZD AIO stuff rather than this 591 page thread?
Sorry I meant I have 59.00.504 NA N. Would like to update to whatever the latest is.
 

·
Registered
Joined
·
60 Posts
Had a slight scare today when I updated from 59.00.504 NA N to 59.00.545. Update went fine. Of course all the tweaks were gone, I then reinstalled all the tweaks and when it rebooted, it was stuck on the Mazda logo with a circle animation. I left it for a few minutes, nothing, restarted still same thing.
I then went to my computer and was making another USB to uninstall all the tweaks and prepping a bunch of USBs with a couple tweaks at a time so I can narrow down if a tweak was incompatible. Spent about 15 minutes.
I went back to the car, turn it on, and it was fine! Phew. All the tweaks I installed right after the update worked.
 

Attachments

·
Registered
Joined
·
60 Posts
AIO Tweaks 2.80 is pretty good, works well with v59.00.546, no more hanging on boot screen.
BUT Android Auto still a little messed up.
If you press Home to exit out of Android Auto, you're given a BLANK black screen. Have to press Navigation, that then switches to Mazda Nav then you can go ahead and use the system. This issue was present in 545/546 on AIO 2.79 previously too.
 

·
Registered
Joined
·
60 Posts
Thanks @Trezdog44 just to be sure, updating with tweaks installed might get into bootloop or some kind of issues? or if ID7 package is installed before, we can do an upgrade even with tweaks installed?
You don't need to uninstall to upgrade firmware.
If you want to be sure, go and install the ID7 recovery.
Then you can upgrade firmware to 59.000.546. When it's finished you can install your tweaks made with MZD AIO 2.80.
No More Disclaimer and Audio Input Reorder List tweaks will need to be reinstalled after the first install.
 

·
Registered
Joined
·
60 Posts
@Trezdog44, Can you check 546 with Android Auto issue I have?
When on 546, running Android Auto, if you press Home on the controls, it goes to a black screen and stays there. You have to press Audio/Favorites/or Nav to get it to exit that black screen. This is present in AIO 2.79 and 2.80.
Thanks.
 

·
Registered
Joined
·
60 Posts
I read a few pages back that a downgrade was done from 545EU to 532EU. I just installed 545NA and am wondering if I could do the same (but for NA)?
I clearly remember reading a while back that downgrades were no longer possible past 502!
Thanks
Yes that's possible, I've done it. I went from 546NA to 504NA. Just do it like a normal firmware install. Notice that 546 has Gracenote 8.0 built in and 504 has 7.0.
 

·
Registered
Joined
·
60 Posts
Yes that's possible, I've done it. I went from 546NA to 504NA. Just do it like a normal firmware install. Notice that 546 has Gracenote 8.0 built in and 504 has 7.0.
Why would you want to downgrade? What’s better in 504?
On 545/546, when you're in Android Auto and you press Home on the car controller, it goes to a black screen. You then have to press, nav or music or favorites to get it to show something.
This wasn't fixed with AIO 2.80.
 

·
Registered
Joined
·
60 Posts
Hi, after applying the tweaks (which ones you have?), do you still have a carplay icon in top left corner on MZD Connect when the iPhone is connected?

Thanks.
The CP/AA icons disappear when Tweaks are installed, but like the other guy said, you can hold HOME to return or if it's playing music, press the Audio button or go to applications and select AA/Car Play.
I'm on NA with official kit running v70 and tweaks installed.
Everything seems to work except that AA/CP icon, and when AA is running, in the audio sources menu, CD is white like there's a CD in my system, selecting it does nothing.
I have these tweaks installed:
Touchscreen While Moving
No More disclaimer
reverse camera safety warning
improved list loop
shorter delay mod
no more beeps
order of audio source list
pause on mute
remove message reply
boot animation (remove)
bigger album art
change blank album art frame
 

·
Registered
Joined
·
60 Posts
Quick question about 352.
I have 335 installed with serial access id7v2 and everything working. If I want to update to 352 do I need to do id7v2 again or no need because I did it with 335?
 
1 - 12 of 12 Posts
Top