2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, I have a weird problem with my advanced keys and hopefully you'll be able to help me.

When I try to unlock the doors using the button on the handle, it doesn't work. I click the unlock button on the key and it open and I use the "push to start" button and the engines turns on normally but the the Key sign with the exclamation mark stays there, it doesn't turn off. Even if I insert my key and press the "push to start" button, it starts but the sign stays there.

Any idea what the problem is? I tried both keys and they both have the same issue. Since the push to start button works fine, i'm assuming its not a Key battery's issue.

The car was hit two days ago and it was being repaired for the whole day yesterday and the key was left inside while it was unlocked for the whole day, do you think that might have caused an issue?
 

·
Registered
2018 Mazda 3 GT
Joined
·
2,444 Posts
Replacing the key's battery may be a quick and easy fix, if it's not something more serious.

What color is the key light? Green is good, orange means the battery and red is bad.
CK
 

·
Registered
Joined
·
270 Posts
The system has several antennas to read the fob. Maybe one of them was damaged or disconnected when the body work was done.
Replace the fob battery first, and if that doesn't work, reboot the system by disconnecting the main 12v battery. If you still have problems, maybe it's one of the antennas. If you can work it from the trunk or the passenger door, the driver door antenna isn't working.
 
1 - 3 of 3 Posts
Top