2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, anyone with a good solution for fixing ABS/TCS lights coming on in their Mazda3?

I have a 2nd gen 2009 Mazda3 with 50,000 miles on the clock. A couple of weeks ago the ABS and TCS lights came on at the same time. After a few days the lights went off, and after another few they came back on again. This happened a couple of times, now the ABS light is on constantly and the TCS light comes on about 10 seconds after starting the car. Brakes work properly.

I went to see my mechanic for a diagnostic test and got these fault codes:
C006A95 Acceleration Sensor / Incorrect Configuration
U300316 Battery Voltage / Circuit Voltage Below Threshold
U042862 Steering Angle Sensor Module / Invalid Data Received
C00201C ABS Pump Motor Control / Circuit Voltage Out Of Range
U041592 CAN-message: ABS/ESP Control Module / Invalid Message

My mechanic couldn’t pinpoint the problem based on the fault codes and suggested to start taking things apart. Any ideas how to fix this?
 

·
Super Moderator
Joined
·
5,475 Posts
Before you start throwing money at it without knowing what the problem is, have the battery checked. If the system is operating at a voltage that is insufficient for proper sensor operation you'll get a bunch of codes just like that.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Before you start throwing money at it without knowing what the problem is, have the battery checked. If the system is operating at a voltage that is insufficient for proper sensor operation you'll get a bunch of codes just like that.
Will try that, thanks.
 
1 - 3 of 3 Posts
Top