2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

301 - 320 of 351 Posts

·
Om Shanti Shanti Shanti O
Joined
·
164 Posts
There is no hardvware difference in the CMU device of different model years.
P.S. More severe stuttering is present if an SD navigation card is inserted.
 

·
Registered
Joined
·
8 Posts
Hello,
I tested "AA v1.14b Tru_go_fw55-59_Standard_view_00" uploaded 09/06 this morning.
No more stuttering in Waze when listenning spotify or TuneIn :)
This is the best version until now for me (M3 2016 59.00.502)
Good job !!
Thanks for your work @Radarwild
 

·
Registered
Joined
·
32 Posts
There is no hardvware difference in the CMU device of different model years.
P.S. More severe stuttering is present if an SD navigation card is inserted.
I can't believe it, but this works. I have taken out the SD navi card and no more stuttering while navigation guidance fade out music or switch the AA screen (Map, Music, AA Home...). And whole MZD (CMU) works much faster without lags.
Only there is a stutter when switch on headlight and AA switch to night mode and vica versa.
This was a very short trip, but I am very happy with these results.

What is the problem with the SD card? Have to buy a faster one and copy data? Or there are file system errors?
 

·
Registered
Joined
·
168 Posts
Discussion Starter #304 (Edited)
I can't believe it, but this works. I have taken out the SD navi card and no more stuttering while navigation guidance fade out music or switch the AA screen (Map, Music, AA Home...). And whole MZD (CMU) works much faster without lags.
Only there is a stutter when switch on headlight and AA switch to night mode and vica versa.
This was a very short trip, but I am very happy with these results.

What is the problem with the SD card? Have to buy a faster one and copy data? Or there are file system errors?
@peti007 yes clone slow sd_nav to a higher/faster speed data transfer rate sdcard should help.
 

·
Om Shanti Shanti Shanti O
Joined
·
164 Posts
Also noticed on this version the volume of music from the phone is louder than the radio. And this is good. Radio was louder on the previous version.
 

·
Registered
Joined
·
47 Posts
AA Version: v1.14b Tru_go_fw55-59_Standard_view_00
FW Details: 56.00.240 4A N

I tested on my S8 and it was stuttering a lot while on Google Maps and Spotify or TuneIn running. It also kept kicking spotify or crashing the app. Only can use again from the phone. But on the S10e things seem to work flawlessly.

Since I need it to work on the S8, i have cleared all the caches from used apps and will test again.

There is the issue with the interface as it switched sides, we drive on the right. The previous version didn't have this problem.

277305


Previous version
277306
 

·
Registered
Joined
·
168 Posts
Discussion Starter #308 (Edited)
AA Version: v1.14b Tru_go_fw55-59_Standard_view_00
FW Details: 56.00.240 4A N

I tested on my S8 and it was stuttering a lot while on Google Maps and Spotify or TuneIn running
(try remove the nav sdcard to minimize this problem when navigating). i'm using s8 (Android version 9) no/zero issue whatsoever. Maybe something on your phone is causing problems with google/waze maps; low memory, large apps..etc is it Andriod version 9, uninstall some apps could help with lag?

But on the S10e things seem to work flawlessly.
Since I need it to work on the S8, i have cleared all the caches from used apps and will test again.
There is the issue with the interface as it switched sides, we drive on the right. The previous version didn't have this problem.
@san098 edit the file from headunit.json and change "rightHandDrive":false to "rightHandDrive":true save headunit.json and resintall to enable driving on the right hand side AA interface or copy and paste below to your headunit.json file and save reinstall.
usb root->config->androidauto->data_persist->dev/bin

{
"launchOnDevice": true,
"carGPS": true,
"wifiTransport": false,
"phoneIpAddress": "192.168.43.1",
"reverseGPS": false,
"rightHandDrive":true
}
 

·
Registered
Joined
·
32 Posts
AA v1.14b Tru_go_fw55-59_Standard_view_00 downloaded on 20200609 and NAVI SD take off.
I had a 5 km trip to the shop and same back to home.
After cold boot there was no stutter at all! No stutter when navigation guidance fade the music nor switch AA screen nor switch on-off the headlight and AA switch to dark mode! I was really happy :D
After spend 5-10 mins in the shop I think the MZD not doing cold boot (not sure). On the way back home there was some stuttering when switch the AA screen and when the car turns and GMaps rotate the screen. I had a phone call over AA when start back home, maybe this caused the stuttering.
 

·
Registered
Joined
·
47 Posts
So after clearing the cache of AA, Google Maps, Play Store, Play Services, Spotify, TuneIn, Phone the stuttering is very very minimal.
 

·
Registered
Joined
·
14 Posts
Hi, I just did a first test with "AA v1.14b Tru_go FW70 USB_HD_beta2" with my Abarth 124. Audio via USB works (not via Bluetooth) but I have a problem with Waze GPS, is really slow to find my position and to update it. No problem with Google Maps. To have audio working (via USB) I had to set bluetooth connection as audio source in the media player (instead of FM/DAB). Exiting from AA get more then 4 seconds. I'll do new tests asap.

Update: I cleared all app caches and did new tests, same problem, GPS does not work with Waze, Maps is ok
 

·
Registered
Joined
·
168 Posts
Discussion Starter #314 (Edited)
Hi, I just did a first test with "AA v1.14b Tru_go FW70 USB_HD_beta2" with my Abarth 124. Audio via USB works (not via Bluetooth) but I have a problem with Waze GPS, is really slow to find my position and to update it. No problem with Google Maps. To have audio working (via USB) I had to set bluetooth connection as audio source in the media player (instead of FM/DAB). Exiting from AA get more then 4 seconds. I'll do new tests asap.

Update: I cleared all app caches and did new tests, same problem, GPS does not work with Waze, Maps is ok
@abarth124 thanks for testing again. Apparently newer version of waze is having this known issue/bug with gps fix even on the phone too. I had tried with all my AA versions and having the same problem. Im not quite sure which older waze version to downgrade Will get a faster fix u need to find that out, but if u open waze on your car then disconnect the usb cable and reconnect it it'll get gps signal right away. Hope that helps.

Or you could disabled carGPS edit the file from headunit.json and change "carGPS": true to "carGPS": false save headunit.json and resintall to see if waze lock onto GPS any quicker?
usb root->config->androidauto->data_persist->dev->bin

{
"launchOnDevice": true,
"carGPS": false,
"wifiTransport": false,
"phoneIpAddress": "192.168.43.1",
"reverseGPS": false,
"rightHandDrive":false
}
 

·
Registered
Joined
·
32 Posts
Today stuttering is back. I don't know what is the difference. I tried to reset the CMU (BACK+NAV+MUTE) but nothing changed. Tried to clear AA cache too. In the morning it was very good.
 

·
Om Shanti Shanti Shanti O
Joined
·
164 Posts
It seems to me the thing is carGPS. if you turn it off, it will be better.
I also had problems due to a poor quality USB cable.
 

·
Registered
Joined
·
32 Posts
Also noticed on this version the volume of music from the phone is louder than the radio. And this is good. Radio was louder on the previous version.
For me the AA volume is much lower than MZD (Radio, USB, BT,...) volume. I t could be much louder. When I arrive AA connected, next time when start the car without the phone, the FM radio is very loud, have to lower the volume.

It seems to me the thing is carGPS. if you turn it off, it will be better.
I also had problems due to a poor quality USB cable.
With carGPS:false I had stuttering issues, with carGPS:true no stuttering or at least rarely. But not the carGPS setting is the key, instead remove the factory NAV SD card.
 

·
Registered
Joined
·
14 Posts
@Radarwild
Out of curiosity, will you develop 1.14+ separately from the existing AiO-AA by Trez, so there might be two streams of AA in the future or will 1.14 be included in future versions of AiO-Tweaks and you & Trez are combining the awesome work you already did?
 

·
Om Shanti Shanti Shanti O
Joined
·
164 Posts
I tested the latest versions of AA 10 days:
  • AA v1.14b Tru_go_fw55-59_HD_Standard_Driverside
  • AA v1.14b_Tru_go_fw55-59_Standard_view
Constant stuttering in music from the phone. NAV SD card is removed! The caches is cleared!

Installed AA from 22 April.
Not any stuttering. Even in Waze.
 

·
Registered
Joined
·
8 Posts
I tested the latest versions of AA 10 days:
  • AA v1.14b Tru_go_fw55-59_HD_Standard_Driverside
  • AA v1.14b_Tru_go_fw55-59_Standard_view
Constant stuttering in music from the phone. NAV SD card is removed! The caches is cleared!

Installed AA from 22 April.
Not any stuttering. Even in Waze.
Can you re upload 22 April version?
 
301 - 320 of 351 Posts
Top