2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

181 - 200 of 285 Posts

·
Registered
Joined
·
6 Posts
@bgx i noticed this bug too. I managed to fix it but it created all kinds of other issues. Like once you're back into AA you can not change FM stations. If that's matters?
Ok, but for me it is no problem when I can't change FM station because I don't hear often radio. For me it is more important that I can change track in spotify also when I'm back to MZD because I want to see my fuel consumption.

Is there a way to fast change between AA and MZD? I know I can back to MZD when I long press back button. It would be nice if the other way to change fast back to AA.

Anyway nice mod and I enjoy it. Thank you...

ah... and I can't get the HUD thing to work... I only use gmaps... I tried to clear cache but no HUD...
 

·
Registered
Joined
·
11 Posts
@BossMann stuttering is a normal thing now as AA uses alot more resources (HUD etc) it can be done, but would u give up HUD, no navigation sound, Google assistant..back to version AA aio v1.05? Else if not navigating idle screen on music instead of waze. Else install official mazda AA/Cp = no stuttering = no HUD and no touch for AA. Your choice.
The USB hub you have in the op do you think that would help with the audio stuttering? Or is that just for charging the phone more quickly when connected?
 

·
Registered
Joined
·
12 Posts
What are the changes between version April 11 and April 22?
I have version April 11 and it works without problems.

The problem with the calls that I had in previous versions are already corrected in the April 11. (y)
 

·
Registered
Joined
·
135 Posts
Discussion Starter #184 (Edited)
The USB hub you have in the op do you think that would help with the audio stuttering? Or is that just for charging the phone more quickly when connected?
@BossMann for fast charging and data as well but still stuttering occurs. Maybe trez might come up with a fix and i can implement it into my version one day. But that how it goes for now.

@masive_x see main op. Robust interleaved, driver correction..etc but keep your backup just incase bugs.

@bgx i might have something for you but it's in the works atm. I'll release it as a separate version in standard form when its ready.
Fast switch from AA->Mzd = yes (not the other way around), and spotify, pulsar+, Google music, Fermata..etc can change track outside AA.(beware bugs are at large) = keep a backup of working version.
 

·
Registered
Joined
·
6 Posts
Just tried installing this on v70.00.335, with the original USB hub (connecting by cable), and no luck. Same thing happens as with v1.13, black screen and nothing loads. Have tried fiddling around with it clearing caches and one time I plugged it in I got a message on my phone saying there was no application that supported the device, and it redirected me to the headunit github repo.

I already unlock 70.00.35 to be able to install AIO settings, I appreciate if you can tell me how you did it since I could not achieve it
 

·
Registered
Joined
·
135 Posts
Discussion Starter #187 (Edited)
@Radarwild whatever you did in your latest build is working great! there is absolutely no audio stuttering anymore when listening to music and having Waze open! its great!
@BossMann :) are you absolutely 100% sure about this? Did u test this out more than once? You are "not" navigating in waze and just playing AA music app while the screen is idle on waze/gmaps? (Vehicle in motion/idle) = no sound stuttering? Any chance you could upload a short clip to show on your system? That would be greatly appreciated. Cheers!

@RevWillie are you able to test this as well? Do you get the same results as BossMann on your system? Thanks.
 

·
Registered
Joined
·
4 Posts
I already unlock 70.00.35 to be able to install AIO settings, I appreciate if you can tell me how you did it since I could not achieve it
Not sure if you asking how I got AIO working on 70.00.335 or how to install AA. The AIO installation was all according to the website (serial hack, etc), and the AA can be installed by just putting the tru_go files on a thumb drive and plugging it into your car (auto tweak installation must be enabled, that can be done through the AIO app, part of the serial process).
 

·
Registered
Joined
·
135 Posts
Discussion Starter #191
The HUD thing does not work here. Had it to do with my old MZD version? Somebody mention it here: https://github.com/gartnera/headunit/issues/135#issuecomment-590981869

My MZD version is 56.00.511 EU N

should I update to 59.*** ?

Edit: But I can confirm... Absolutely no hickups and stutter anymore with the last version! Really good job!
@bgx yes HUD required better fw. Fw59 is best, but make sure either u have id7/id7v2 install so you can install tweaks.

New AA Tru_go USB beta, fast switch and able to change spotify songs in mazda main screen while you check your fuel economy etc. Please test..Fm audio with be compromised. See more details main op.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #192 (Edited)
@Radarwild : tested today version (tested both usb and bluetooth), sound never worked. Why usb audio is only working on march version?
@abarth124 @luyenok
New AA v1.14b fw70 USB HD beta2. Can you guys please test it out on your fw70? If its working with sound? (Bugs Fm radio will have no navigation notifications)
Please test in usb cable mode and wireless as well. Now if sound is heard, check for stuttering if any. Thanks.
 

·
Registered
Joined
·
11 Posts
@BossMann :) are you absolutely 100% sure about this? Did u test this out more than once? You are "not" navigating in waze and just playing AA music app while the screen is idle on waze/gmaps? (Vehicle in motion/idle) = no sound stuttering? Any chance you could upload a short clip to show on your system? That would be greatly appreciated. Cheers!
Yes! I tested now for 2 days back and forth to work. I had Waze going at all times and was playing music through soundcloud on my phone sometimes and on tunein radio from AA sometimes and both had no stutters. I wasn't "navigating", as in set a destination. it was just open/idle but even that before was stuttering; that wasn't happening now. Sure I can try making a video next time I go driving, might be a few days since it's weekend now.
 

·
Registered
Joined
·
12 Posts
59.00.504 NA N with AA V1.14b (April 22). Mazda 3.

It works very well. GMaps open with no route loaded and 3d view. Spotify without stuttering. Sometimes when turning on a street you will notice a small stutter.

Today I will install the April 25th version and test it back to home.
I will also test wirelessly.
 

·
Registered
Joined
·
16 Posts
@abarth124 @luyenok
New AA v1.14b fw70 USB HD beta2. Can you guys please test it out on your fw70? If its working with sound? (Bugs Fm radio will have no navigation notifications)
Please test in usb cable mode and wireless as well. Now if sound is heard, check for stuttering if any. Thanks.
testing it now on my mazada6 2020 fw 7.00.352 will check back when finished
 

·
Registered
Joined
·
135 Posts
Discussion Starter #197
Audio doesn’t work unless I reconnect Bluetooth after android auto starts
@burt111 (i do not have fw70 running) so let get this specifically you connect your Android device to your mazda 6 fw70.00.352 (id7v2)

So you're saying:

1. Connection by usb cable, no blank/black screen? Thats good start (Usually that happens)..
2. No Audio but can see AA active screen at this stage.
3. You then fast switch to Mazda main selected "Bluetooth output source" navigate back to AA. Now you can hear navigation notifications? And your Spotify music, google music, cloud music..etc?
4. If you have a usb thumbdrive inserted in one of your usb(s) slot with mp3s. You fast switch selected "Usb" hopefully can hear music playing->navigate to AA. Music still playing and also can hear navigation notifications? If BT also played, you pause it with *fav button?
5. Same with wireless? ...no stuttering for both mode?(usb cable/wireless). Thank you. Cheers!
 

·
Registered
Joined
·
16 Posts
@burt111 (i do not have fw70 running) so let get this specifically you connect your Android device to your mazda 6 fw70.00.352 (id7v2)

So you're saying:

1. Connection by usb cable, no blank/black screen? Thats good start (Usually that happens)..
2. No Audio but can see AA active screen at this stage.
3. You then fast switch to Mazda main selected "Bluetooth output source" navigate back to AA. Now you can hear navigation notifications? And your Spotify music, google music, cloud music..etc?
4. If you have a usb thumbdrive inserted in one of your usb(s) slot with mp3s. You fast switch selected "Usb" hopefully can hear music playing->navigate to AA. Music still playing and also can hear navigation notifications? If BT also played, you pause it with *fav button?
5. Same with wireless? ...no stuttering for both mode?(usb cable/wireless). Thank you. Cheers!
1. When I connect the device it takes a minute for black screen to go away
2. Yes active screen displays can navigate Android auto like normal
3. Yes audio works but required me to open my phone's settings and go to Mazda and click connect under Bluetooth I didn't need to do anything on my car system just phone side

4. USB thumbdrive I have no clue didn't test
5. I tried wireless and yes it works lag is minimal and was having a glitch switching back to the main mzd connect screen but a simple reboot of the car fixed the issue once I set everything back up
 

·
Registered
Joined
·
264 Posts
@abarth124 @luyenok
New AA v1.14b fw70 USB HD beta2. Can you guys please test it out on your fw70? If its working with sound? (Bugs Fm radio will have no navigation notifications)
Please test in usb cable mode and wireless as well. Now if sound is heard, check for stuttering if any. Thanks.
I have re-checked with 70.00.100, it working but not unstable:
  • I must manual choose bluetooth from audio source (for factory AA it auto switch to USB 1 when AA started).
  • Black screen when switch between AA and MZD
  • Can not back to AA after switch to MZD.
 

·
Registered
Joined
·
16 Posts
I have re-checked with 70.00.100, it working but not unstable:
  • I must manual choose bluetooth from audio source (for factory AA it auto switch to USB 1 when AA started).
  • Black screen when switch between AA and MZD
  • Can not back to AA after switch to MZD.
Weird switching back and forth works for me on latest 352b besides that audio similar situation except I don't need to do anything on the car just reconnect Bluetooth on the phone
 
181 - 200 of 285 Posts
Top