2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Got up this morning (-5 Celsius out) to my driver side windshield wiper only going about 3/4 of the way up the windshield which was weird. So I cleared all the ice and snow from around the arm, which shouldn't necessarily matter as it wasn't in the way, and it got worse. It went half way to the arm barely moving. I went out to see if the arm was still solid and it's not, I can wiggle it around and its incredibly loose which leaves me to believe the motor is shot or a bearing or bushing is shot. I've had the car for 11 months, purchased it brand new and doesn't even have 17000 km on it. Has ANYONE else had this issue?
 

·
Registered
Joined
·
69 Posts
If they have, it's certainly not a common issue. Anyway, that's why God invented the new car warranty.
 

·
Registered
Joined
·
310 Posts
I had a recall on the 2016 wiper motor and had it done this last time with vehicle inspection by the dealer. Never had a problem, but there were issues enough to necessitate a recall.

Ralph
 

·
Super Moderator
Joined
·
4,449 Posts
I had a recall on the 2016 wiper motor and had it done this last time with vehicle inspection by the dealer. Never had a problem, but there were issues enough to necessitate a recall.

Ralph
The recall was for a problem with the wiper relay associated with the Body Control Module. Nothing to do with broken linkages.....
 

·
Registered
Joined
·
308 Posts
Nevertheless take it to the dealer to fix your problem and they'll do the recall at the same time if you already haven't.
 

·
Registered
Joined
·
1 Posts
Did you get this fixed? I've had this problem before and it was a loose bolt on the arm itself so the shaft was not fully engaged.
 
1 - 8 of 8 Posts
Top