2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So neither of my outlets work. I already replaced the fuses in the driver side fuse box. I've read that there's another fuse box behind the glove box. I've completely removed the glove box and see nothing that resembles a fuse box at all. Can someone please help me?

I'll attach some pics.

Is it possible that someone removed the secondary fuse box? I didn't think that was possible...

Thank you everyone.

- Beau


Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Maybe I just have bad information. Is there even a passenger side fuse box in 2011's? The fuses on the driver side are good and getting power. Why wouldn't either outlet work?

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Maybe I just have bad information. Is there even a passenger side fuse box in 2011's? The fuses on the driver side are good and getting power. Why wouldn't either outlet work?

Sent from my SM-G950U using Tapatalk
I don't think so
I got a 3 HB S and I saw in some tutorial or DIY that mentions that passenger fuse box
But I think it refers to the driver side
Maybe in some other versions or depends where were assembled, the fuse box may change of side
 

·
Registered
Joined
·
135 Posts
I believe you are speaking of Gen 1 Mazda 3 with fuse box behind glove box. See How to on Replacing Cabin Air Filter for pictures of said fuse box.
 
1 - 7 of 7 Posts
Top