2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2011 Mazda 3i that I bought used. it now has 85,000km. At speeds less then 50km/h but most notable between 10-30 when driving, turning the AC or or suddenly removing my foot from the gas petal I have an audible chirp coming from the rear of the car. I thinks its now the both back ends some days but mostly from the right. I've gone to my local dealer and they said everything appeared ok when I told them what I thought the problem was. They replaced my engine mounts free for me. It's annoying when driving with my windows down and would like some help.

I've looked at my rear sway bar bushings and they look fine. Any thoughts?
 

·
Super Moderator
Joined
·
6,392 Posts
Are you sure its coming from the rear of the car? Sounds like a belt slipping. Check your AC compressor and the accessory drive belt.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Its not from under the hood but thanks. I've also noticed the same sound from a another 3 driving by before. Its high pitch like a blowoff valve but not.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Are you sure its coming from the rear of the car? Sounds like a belt slipping. Check your AC compressor and the accessory drive belt.
So after going for a drive I think that's exactly what the problem is and you were spot on! Thanks! How do I fix this as I've never played with belts.
 
1 - 5 of 5 Posts
Top