2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello everyone! :azn:

Im new here and I drive a 2010 Mazda 3 2.0

Its my first time in a cars forum so, Hi :)
Decided to come here and ask something I dont know how to ask Google so I hope you guys will understand me enough.

So after driving my car for 9 years, having more than 130K km on it, knowing it from front to back, regulary maintaining it, it still runs and feels as new.
Today I got a chance to drive my uncles' 2007 Mazda 3 1.6, and I tell you all, It was something else. I have no idea why, but the throttle feel was amazing, it felt alive.
It is not tuned, nothign out of the ordinary. Just regulary maintaining it like me. Every tap of the pedal was like trying to not wake up a beast.
I am not exaggerating, Ive driven many cars in my life, including much faster than these two.
I was hoping someone would understand what Im trying to say - Why is my 2.0 feeling lazy compared to his car?
My dad, who is also familier with my car, told me Im just imagining things, and as soon as he went on a ride he told me: "What the hell is this?"
My uncle told me that Im driving all these years like an old granny and never "Broke in the engine". I just did what the manual said to break it in.
Hoping you guys can shed light on this topic.
Thanks and happy to be here!
 

Attachments

·
Registered
Joined
·
47 Posts
Hai88 I feel ya.
I have a 2012 and below 2000rpm it feels like crap. I know it isn't throttle body related cuz I checked that and I know for a fact that my throttle body response is in sync with pedal (watched with a mirror while playing with the pedal plus I can hear the difference between throttle position when driving). I also feel it's really sluggish at said rpm range and what I notice is when accellerating the rpm kinda sticks for a brief moment around 1500rpm before shooting up. This lets me believe that there's something up with acceleration. It's not linear. It's like the engine hesitates for a second before regaining it's accelleration. I have the skyactiv model btw.
Maybe spark related or restriction somewhere??

Sent from my SM-G960U1 using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Hey to both of you guys and thanks for the comments!
dogla, Im not sure what you meant by 'restriction' :) But this is exactly what I feel. Im not happy that it happens to you too but that Im not alone in that.
arathol, I have used Gumout Fuel Systen Treatment 2K ago.
I also replaced the Spark plugs not long ago.
Thanks again, Ill do some more research and if I find something Ill let you guys know.
 

·
Super Moderator
Joined
·
752 Posts
Fuel treatment doesn't really help if it's a direct injection engine. You'd have better luck by spraying some DI cleaner in the intake tube past the MAF sensor or do an air intake cleaning procedure.
 
1 - 7 of 7 Posts
Top