2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I've been away for 3 weeks while my car was having new ball joints put on both front wheels. Once I came back, the mechanic told me that they had trouble putting the car into gear after having it in park, which was weird since before I left, this hadn't happened before.

I've been looking around at other threads to see what the problem might be and I've narrowed it down somewhat but I'm still not sure exactly what the problem is. I've checked all the fuses to see if they were fine and they are. The brakes lights work while the brake pedal is pushed down and the horn works fine. If you listen carefully, you can also hear the click of the break pedal switch after pushing the pedal 3/4 of the way down.

Right now I'm thinking that the problem is the shift interlock solenoid since I can shift freely after pushing the release for the shift lock manually.

Any ideas?

Thanks,
Adam
 

·
Registered
Joined
·
2 Posts
So I've been away for 3 weeks while my car was having new ball joints put on both front wheels. Once I came back, the mechanic told me that they had trouble putting the car into gear after having it in park, which was weird since before I left, this hadn't happened before.

I've been looking around at other threads to see what the problem might be and I've narrowed it down somewhat but I'm still not sure exactly what the problem is. I've checked all the fuses to see if they were fine and they are. The brakes lights work while the brake pedal is pushed down and the horn works fine. If you listen carefully, you can also hear the click of the break pedal switch after pushing the pedal 3/4 of the way down.

Right now I'm thinking that the problem is the shift interlock solenoid since I can shift freely after pushing the release for the shift lock manually.

Any ideas?

Thanks,
Adam
Does anyone have any information? I have the same issue. Thanks!
 
1 - 2 of 2 Posts
Top