2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
115,000 miles, all maintenance current (including brake pads within the past year)..... love my car, but this is driving me crazy.

Car has always had a fair amount of travel in brake pedal, but stops reasonably well. Recently I noticed a vibration in the front end (not pulling from one side or the other), The travel in the brake pedal completely disappeared, the brake pedal was felt like it engaged instantly. Incidently, my mpg would drop as well as long as I drove with the vibration (from 33 mpg to 29 mpg according to the info button. I am assuming the front calipers are hanging up.

Is this a ABS issue? I have spent a fair amount of money on the brakes in the past year (replaced the booster, pads etc). Has anyone else had this problem?

Another clue, when I pulled off the road the first few times it did this (traveling around 60 mph, found a safe place to pull over), I turned off the car, looked it over (tire issue, no!). Upon starting the car, the travel in the brake pedal was normal, no vibration, and I resumed getting good mileage. , drove the next 300+ miles no problem until it did it again (done this now 4 times over sevearl months). Any ideas?
 

· Registered
2012 Mazda 3 GX MT5 non sky
Joined
·
1,568 Posts
I am assuming you replaced the Brake fluid / and bleed the lines
 
  • Like
Reactions: RocketmanKarl

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yes, replaced and flushed about 12 months ago,brake fluid looks clear and its hold its level (no leak). This problem just started to surface within the past month or so, and its so intermittent that I am not sure I can replicate it for the shop.. I think it has been catching at lower speeds too, as my mileage has been intermittently up and down around town (I just had new iridium plugs put in and had the transmission fluid flushed and replaced about 2 months ago). I am really stumped on this one....

When its driving like it should, its fantastic (I've had it for 12 years now). Do you think it is worth a try to bleed the brakes again? No abs light, no pulse in the brake pedal, just suddenly it has no travel in the pedal and it sounds like I have a flat tire (or low tire) gas mileage drops 15% or so. I turn the car off, it seems to reset and go back to normal. Thanks for your first response, any other ideas?
 
1 - 5 of 5 Posts
Top