2004 to 2016 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My wife's 05 3 has about 105k miles on it and we just changed the plugs and did an oil change. Afterwards it's been having a strange RPM bouncing issue. It only happens in 4th gear around 1000rpm. It'll go up to 1500 then back down to 1000 a few times then stop. It will do this anywhere from 2 to 6 times. A few things I've read say it could be a vacuum issue, a co-worker suggested it's searching for 3rd to downshift which could also be vacuum related.

Here's a crappy video I made
https://www.youtube.com/watch?v=W9VVR33rfuk
 

·
Demon Spawn
Joined
·
758 Posts
yeah, that looks to be a vacuum leak. there is a bunch of vacuum hoses near the throttle body to the drivers side of the engine check to be sure none came loose while changing the plugs. vacuum leaks usually show up at idle more than driving but its not impossible. you may also want to check that all your coils are on tight and plugged in tight. a member around here may have the factory vacuum diagram or you can more than likely have your local dealer print you one to check that none are loose or off. has the check engine light come on? if so having the codes scanned may help pinpoint the issue. if you get the codes scanned post them and we can help.
 

·
Registered
Joined
·
2 Posts
Hi everyone. I couldn't really find the most appropriate form for this but I thought I'd shooted here with my question. Recently my Mazda 3 2.3 l has been having the Rev bouncing similar to the previous post but has occurred in first and second gear. I noticed when I shift into a gear at High Rev from first , 3000 + RPM, I don't get any bouncing occurring in second. When I shift from 1st to 2nd and let's the RPM drop to around 1000 and I give the car medium throttle load, the car does a slate balance / engine lug at 1200 to 1500 RPM before going back to normal. I've been driving it for the past hour to figure out what the triggers are but sure what exactly is going on. Services I've done to the car are transmission fluid flush, spark plugs, brake fluid flush and some other non engine related services. The jumps usually happens about two to four times before it settles, something recently I've done was get a misfire in cylinder one and I swapped ignition coil from cylinder 1 2 cylinder 4 to figure out if the ignition coil had given me the misfire. No check engine light has appeared since I've swap them and the jumping happened after I swap them. It's been roughly a week since I did the ignition coil swap.
 
1 - 7 of 7 Posts
Top