2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey Guys and Gals,

I'm a fresh newbie to the forums so be gentle with me haha
So I brought a 2005 Mazda 3 hatchback 2.0L about 2 years ago. I've had no issues with the car what so ever until now.

First the car wouldn't start after leaving it for over a week, then it was leaving it for 3 days, then 2 and now it won't start at all (battery being drained, which is another issue I have to fix).

So as it is right now, the battery is 2 months old, full charged but when going to start the car, it does the "click click click click" as if the battery is half flat or going flat. Check with a volt meter and it has 12.5v. I took the battery out and charged for 24 hours, put the battery back into the car, went to start and click click click.

Got the battery from my Mitsubishi Pajero and it does the same thing (this battery starts the Pajero fine).

If I use jumper cables from car to car to jump start it, it starts up fine, although it does sound a little slugish. Once the car was started I checked that the battery is being charged, between 13.3v - 14.3v going to the battery. After driving to work (2 hour drive), I turned the car off and thought I would try turn it straight back on again. Same thing with the clicking.

Once getting the car home, I thought it might be a ground so I connected the negative from the mazda to the negative on the Pajero so it has somewhat an "extra" ground (not sure if this even makes sense to do but in my head at the time it did haha). Same thing again.

I'm not pretty stumped at what it could be. I thought starter motor at first but then thought, how could this be the starter motor, if I connect jumper leads it starts.

Any help would be great!
 
1 - 1 of 1 Posts
Top