2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

I have searched everywhere, google, youtube etc...I cannot find where the location is for the TCM on my 2005 3

Or maybe some one can pointy me in the right direction.

Sometimes the car engages in 1st and acts kind of normal other times it just revs in 1st. When it "acts" normal it shifts from 1-2 but when it gets to 3rd it slips/revs..When I put it in reverse it "surges" (if that makes sense).

This is what I've done so far:

  • Drained the transmission fluid and replaced filter - Fluid was black and the magnet had a lot of "powder"
  • Checked all 6 solenoids for resistance - all were good and within spec
  • Refilled the transmission

The problem (AT light) is still on, I've read that it's could possibly be the TCM - I also read somewhere that the 2005 does not have a TCM, that would explain why I only see threads or vides on TCM replacement for 2006 and up Mazda 3's

I just want to confirm if the 2005 does or does not have a TCM and if it does where is it located. Also, if there is hope for my transmission or if I should get a rebuilt/used one to replace the one in the car?

I bought this car at a great price knowing that the transmission had issues - worst case would be that I would need to replace the transmission - but even then the car would still be worth it because I can do the work myself.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
1 Posts
my son has a 2004 and I have searched both locations where the 2006 and newer \mazda TCM's are located.....without success. I am betting the 2004 and 2005 don't have a TCM, but instead, input and output sensors which I have located on the top of the tranny below where the airbox/battery box are located. Best reached by removing the metal bracket which surrounds the tranny motor mount. Have you had any success? You posted in June, nobody here helped....surprising from a auto forum group I would suggest.
 

·
Mazda "E" Division
Joined
·
1,265 Posts
Hi All,

I have searched everywhere, google, youtube etc...I cannot find where the location is for the TCM on my 2005 3

Or maybe some one can pointy me in the right direction.

Sometimes the car engages in 1st and acts kind of normal other times it just revs in 1st. When it "acts" normal it shifts from 1-2 but when it gets to 3rd it slips/revs..When I put it in reverse it "surges" (if that makes sense).

This is what I've done so far:

  • Drained the transmission fluid and replaced filter - Fluid was black and the magnet had a lot of "powder"
  • Checked all 6 solenoids for resistance - all were good and within spec
  • Refilled the transmission

The problem (AT light) is still on, I've read that it's could possibly be the TCM - I also read somewhere that the 2005 does not have a TCM, that would explain why I only see threads or vides on TCM replacement for 2006 and up Mazda 3's

I just want to confirm if the 2005 does or does not have a TCM and if it does where is it located. Also, if there is hope for my transmission or if I should get a rebuilt/used one to replace the one in the car?

I bought this car at a great price knowing that the transmission had issues - worst case would be that I would need to replace the transmission - but even then the car would still be worth it because I can do the work myself.

Any help would be greatly appreciated.

This online manual/parts is handy for specific info: alldatadiy.com
 
1 - 4 of 4 Posts
Top