2004 to 2020 Mazda 3 Forum and Mazdaspeed 3 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all, new here.. just happily paid off my 05 i bought like a year ago, naturally it starts acting up when the payments are gone... i have this weird issue i cant seem to find any info on from google.. im pretty mechanically inclined but not really with these cars.. I have this weird issue where my engine will hesitate from first to second when the A/C is running, it makes the motor feel underpowered in up hills and rolling stops, occasionally it will jerk a little or feel like its revving and not moving.. to me it feels like a slipping clutch ( its manual )

A garage once told me when they were inspecting the entire car that the battery was for an automatic transmission model of the vehicle and i was using the wrong battery... ive never heard of a battery causing issues with performance based on the transmission used... has anyone else heard of this?
 

·
Working Class Hero
Joined
·
3,705 Posts
Welcome aboard.

Battery argument is bullshit. You dont drive a hybrid.

Clutch slippage is usually accompanied by a rise in engine speed, an inconsistent revving if you will.

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

·
Demon Spawn
Joined
·
758 Posts
my 08 did this, I just found it as a weird quirk never found the cause shift at higher rpm see if that helps, that's what I did in my 08 and it worked well. shifting at about 25-2800rpm would cause it to hesitate but 2900-3500 rpm would not. mine was also sometimes hard to get through the 2nd gear gate as well.
 
1 - 3 of 3 Posts
Top